X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Everytime I open up Firefox, two tabs open up. The first is a Firefox page and the other is my home page. How do I stop the first tab from opening?

Được đăng

I would like to stop the firefox tab (what I assume is the firefox home page) and only want one tab to open when I bring up my browser.

I would like to stop the firefox tab (what I assume is the firefox home page) and only want one tab to open when I bring up my browser.

Giải pháp được chọn

I had this happen after I updated Firefox. I got rid of the second Mozilla "home Page" by doing the following: Click Tools Click Options Click General Tab In the "When Firefox Starts" drop-down menu, choose "Show My Home Page". Just below that, you will see; Home Page, with a space for the URL of the home page you want to use typed into it. Check it carefully. My second pop-up page was caused because of an improper URL. It was showing the following: http://www.abcdef.com/ (my home page), HOWEVER, there was additional information on the right of the forward slash after .com All I did was delete this additional information, closed my browser, restarted it, and the second "Home Page" NEVER came back. Note: If you restore your browser defaults, you may have to fix the issue again.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Google Update
  • Shockwave Flash 11.6 r602
  • iTunes Detector Plug-in
  • 5.1.20125.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DjVu browser plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NPWLPG

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

Thông tin chi tiết

KarMar6361 0 giải pháp 4 câu trả lời
Được đăng

Hi braverydude

How I found my fault was to copy the folder in my profile folder with no specific name eg:n2wl8q06.default-137797180 for mine to the desktop.(I made two copies to be on the safe side) Then did a reset to firefox and when finished reset without replacing any of your files from the folder on the desktop tested firefox for the problem and it was OK different looking but no problem. I then cut and pasted one folder / file at a time from the old files in the desktop folder to the new folder in profiles that was made by the reset process and tested firefox start-up after every cut and paste until I found my culprit file. 'user.js' I then found the line in above that I deleted, you hopefully should find your problem file and either leave it out or modify like I did.

Hope it helps with yours

Also:- I tried a reset the first time and just copied the files back in one lot and it was still there so I went through the process above. You may want to do a few files at a time to make it quicker but need to keep track of what you move across.

Hi braverydude How I found my fault was to copy the folder in my profile folder with no specific name eg:n2wl8q06.default-137797180 for mine to the desktop.(I made two copies to be on the safe side) Then did a reset to firefox and when finished reset without replacing any of your files from the folder on the desktop tested firefox for the problem and it was OK different looking but no problem. I then cut and pasted one folder / file at a time from the old files in the desktop folder to the new folder in profiles that was made by the reset process and tested firefox start-up after every cut and paste until I found my culprit file. 'user.js' I then found the line in above that I deleted, you hopefully should find your problem file and either leave it out or modify like I did. Hope it helps with yours Also:- I tried a reset the first time and just copied the files back in one lot and it was still there so I went through the process above. You may want to do a few files at a time to make it quicker but need to keep track of what you move across.

Được chỉnh sửa bởi KarMar6361 vào

braverydude 0 giải pháp 12 câu trả lời
Được đăng

Hi cor-el. Yes I tried renaming the compatibility.ini file to a different name. It has not made any difference. Firefox re-created a new compatibility.ini file and still opened with the "Welcome to Firefox" and my home page.

Quit a challenge, eh? BTW, here's the content of the compatibility.ini file:

[Compatibility] LastVersion=23.0.1_20130814063812/20130814063812 LastOSABI=WINNT_x86-msvc LastPlatformDir=C:\Program Files (x86)\Mozilla Firefox LastAppDir=C:\Program Files (x86)\Mozilla Firefox\browser

Hi cor-el. Yes I tried renaming the compatibility.ini file to a different name. It has not made any difference. Firefox re-created a new compatibility.ini file and still opened with the "Welcome to Firefox" and my home page. Quit a challenge, eh? BTW, here's the content of the compatibility.ini file: [Compatibility] LastVersion=23.0.1_20130814063812/20130814063812 LastOSABI=WINNT_x86-msvc LastPlatformDir=C:\Program Files (x86)\Mozilla Firefox LastAppDir=C:\Program Files (x86)\Mozilla Firefox\browser
braverydude 0 giải pháp 12 câu trả lời
Được đăng

Hi KarMar6361,

The problem is that I do not have a user.js file.

Hi KarMar6361, The problem is that I do not have a user.js file.
KarMar6361 0 giải pháp 4 câu trả lời
Được đăng

Try the process of elimination like I did and this should at least tell you if your problem is in the folder in the profile folder. As you dont have the user.js file its what I would try, if firefox works after a reset only without your old files added, you know it is something in that folder, if not your problem must be elsewhere.

Try the process of elimination like I did and this should at least tell you if your problem is in the folder in the profile folder. As you dont have the user.js file its what I would try, if firefox works after a reset only without your old files added, you know it is something in that folder, if not your problem must be elsewhere.
cor-el
  • Top 10 Contributor
  • Moderator
17578 giải pháp 159013 câu trả lời
Được đăng

You can check for problems with preferences.

Rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value.

You can check for problems with preferences. Rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences
braverydude 0 giải pháp 12 câu trả lời
Được đăng

Hi cor-el and KarMar6361,

First off, thank you so much for all your efforts to help me with this issue! I really appreciate it!

Here's what I just did. I did a complete uninstall of Firefox, including all user data and preferences. Once this completed, I verified that there were no files or subfolders left in the profiles folder.

I then downloaded the current Firefox installer and did a fresh install, including creating a new profile with a custom name. A new profile folder was created and all the files are dated 9/3.

When Firefox started for the first time, it opened with the "Welcome to Firefox" tab and the Firefox Start page tab. I closed both tabs and exited Firefox.

I then restarted Firefox, and sure enough the "Welcome to Firefox" tab and the Start page tab re-opened.

So bottom line: I think I have eliminated any issue with the profile folder or prefs.js, compatibility.js or user.js files.

So I am out of ideas here. If you have any further ideas I would love to hear them! Thanks again.

Brian

Hi cor-el and KarMar6361, First off, thank you so much for all your efforts to help me with this issue! I really appreciate it! Here's what I just did. I did a complete uninstall of Firefox, including all user data and preferences. Once this completed, I verified that there were no files or subfolders left in the profiles folder. I then downloaded the current Firefox installer and did a fresh install, including creating a new profile with a custom name. A new profile folder was created and all the files are dated 9/3. When Firefox started for the first time, it opened with the "Welcome to Firefox" tab and the Firefox Start page tab. I closed both tabs and exited Firefox. I then restarted Firefox, and sure enough the "Welcome to Firefox" tab and the Start page tab re-opened. So bottom line: I think I have eliminated any issue with the profile folder or prefs.js, compatibility.js or user.js files. So I am out of ideas here. If you have any further ideas I would love to hear them! Thanks again. Brian
braverydude 0 giải pháp 12 câu trả lời
Được đăng

Hi two more updates:

First, I was able to get rid of the stupid "Welcome to Firefox" tab by going into about:config and deleting the entry for: startup.homepage_override_url

So at least that got rid of the "Welcome to Firefox" issue!

Second, it DOES appear that you may be correct in that some of the preferences are not being saved. Here's what's interesting: I can change some preferences successfully (for example, I changed my home page and de-selected the option to save passwords). But some preferences will not save, such as having Firefox check to see if it is the default browser or changing automatic download settings.

I only have one prefs.js file, newly created this morning after a full reinstall. And the date stamp, shows it updates every time I close Firefox. The read-only attribute is not checked on the file. There are no other prefs files in the folder and no user.js file.

So while my immediate problem is fixed for now, I am still working on the "why" behind the issue. I will keep working on it and let you know!

Hi two more updates: First, I was able to get rid of the stupid "Welcome to Firefox" tab by going into about:config and deleting the entry for: startup.homepage_override_url So at least that got rid of the "Welcome to Firefox" issue! Second, it DOES appear that you may be correct in that some of the preferences are not being saved. Here's what's interesting: I can change some preferences successfully (for example, I changed my home page and de-selected the option to save passwords). But some preferences will not save, such as having Firefox check to see if it is the default browser or changing automatic download settings. I only have one prefs.js file, newly created this morning after a full reinstall. And the date stamp, shows it updates every time I close Firefox. The read-only attribute is not checked on the file. There are no other prefs files in the folder and no user.js file. So while my immediate problem is fixed for now, I am still working on the "why" behind the issue. I will keep working on it and let you know!
Vinay B S 0 giải pháp 2 câu trả lời
Được đăng

Hi,

Type "about:config" into your Firefox address bar (without the quotes).

If you get a warning message, click on I'll be careful button.

Then you'll get a page with a list of all the preferences. Select the preference with the name "startup.homepage_override_url". Right click on this preference and click on Modify and delete if any text is present in the string value field.

I hope this solves your problem!!

Hi, Type "about:config" into your Firefox address bar (without the quotes). If you get a warning message, click on I'll be careful button. Then you'll get a page with a list of all the preferences. Select the preference with the name "startup.homepage_override_url". Right click on this preference and click on ''Modify'' and delete if any text is present in the string value field. I hope this solves your problem!!

Được chỉnh sửa bởi Vinay B S vào

some_old_bloke 0 giải pháp 1 câu trả lời
Được đăng

Brilliant, brilliant, brilliant! It works !

Like other users, this problem has been plaguing me since (I think) the last Firefox upgrade but I've only just got round to reseraching a solution. I found this thread and tried all the other things suggested above until I came to the last entry, which worked, simply and easily. Many thanks to Vinay.

I wonder why Mozilla didn't offer this solution?

Brilliant, brilliant, brilliant! It works ! Like other users, this problem has been plaguing me since (I think) the last Firefox upgrade but I've only just got round to reseraching a solution. I found this thread and tried all the other things suggested above until I came to the last entry, which worked, simply and easily. Many thanks to Vinay. I wonder why Mozilla didn't offer this solution?
Born1947 1 giải pháp 1 câu trả lời
Được đăng

Giải pháp được chọn

I had this happen after I updated Firefox. I got rid of the second Mozilla "home Page" by doing the following: Click Tools Click Options Click General Tab In the "When Firefox Starts" drop-down menu, choose "Show My Home Page". Just below that, you will see; Home Page, with a space for the URL of the home page you want to use typed into it. Check it carefully. My second pop-up page was caused because of an improper URL. It was showing the following: http://www.abcdef.com/ (my home page), HOWEVER, there was additional information on the right of the forward slash after .com All I did was delete this additional information, closed my browser, restarted it, and the second "Home Page" NEVER came back. Note: If you restore your browser defaults, you may have to fix the issue again.

I had this happen after I updated Firefox. I got rid of the second Mozilla "home Page" by doing the following: Click Tools Click Options Click General Tab In the "When Firefox Starts" drop-down menu, choose "Show My Home Page". Just below that, you will see; Home Page, with a space for the URL of the home page you want to use typed into it. Check it carefully. My second pop-up page was caused because of an improper URL. It was showing the following: http://www.abcdef.com/ (my home page), HOWEVER, there was additional information on the right of the forward slash after .com All I did was delete this additional information, closed my browser, restarted it, and the second "Home Page" NEVER came back. Note: If you restore your browser defaults, you may have to fix the issue again.