X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Chủ đề này đã đóng và được lưu lại. Vui lòng hỏi một câu hỏi mới nếu bạn cần giúp đỡ.

How do I change my default search engine in the URL bar back to Google after my ISP replaced my default search engine with their own?

Được đăng

Before I changed internet service providers, I could type my search queries into the url bar and receive search results from Google. After I switched ISPs, my queries typed into the url bar are put into my new ISP's horrible search engine. How do I change it back?

I've already tried going to about:config and changing the value of the keyword.URL preference to "http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=" but that didn't fix my problem.


New information since creation of the post:

My ISP is Optimum. I have opted out of DNS Assistance and still have seen no change.

When my search term is two words or more, I am directed to Google search results. If my search term is only one word, however, I am still directed to Optimum's search results.

Before I changed internet service providers, I could type my search queries into the url bar and receive search results from Google. After I switched ISPs, my queries typed into the url bar are put into my new ISP's horrible search engine. How do I change it back? I've already tried going to about:config and changing the value of the keyword.URL preference to "http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=" but that didn't fix my problem. New information since creation of the post: My ISP is Optimum. I have opted out of DNS Assistance and still have seen no change. When my search term is two words or more, I am directed to Google search results. If my search term is only one word, however, I am still directed to Optimum's search results.

Được chỉnh sửa bởi samshine vào

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 11.6 r602
  • Version 3.16.0.12200
  • Google Talk Plugin Video Accelerator version:0.1.44.24
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Coupons Inc., Coupon Printing FireFox Plugin
  • 5.1.10411.0
  • GameTree Download Manager Plug-in
  • Octoshape Streaming Services web integration browser plug-in
  • Musicnotes Viewer plugin 1.18.8 http://www.musicnotes.com
  • iPhoto6

Ứng dụng

  • Firefox 19.0.2
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:19.0) Gecko/20100101 Firefox/19.0
  • URL hỗ trợ: http://support.mozilla.org/1/firefox/19.0.2/Darwin/en-US/

Tiện ích mở rộng

  • Reddit Enhancement Suite 4.1.2 (jid1-xUfzOsOFlzSOXg@jetpack)
  • Search by Image for Google 1.2.0 ({ab4b5718-3998-4a2c-91ae-18a7c2db513e})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription:
  • adapterDeviceID: 0x 46
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine
  • windowLayerManagerType: OpenGL

Thay đổi cài đặt

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: https://www.google.com/|https://www.facebook.com/|http://www.reddit.com/
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • gfx.blacklist.webgl.msaa: 4
  • keyword.URL: http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1364823753
  • places.history.expiration.transient_current_max_pages: 104019
  • places.history.expiration.transient_optimal_database_size: 166429982
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không

Người tạo câu hỏi

The new profile has the same issue.

The new profile has the same issue.
jscher2000
  • Top 10 Contributor
8774 giải pháp 71729 câu trả lời
Được đăng

I think I wasn't clear in my own mind on the problem, but I'm clearer now. :-)

When you enter one word in the address bar, Firefox will always assume it is a server name. If you are on an intranet, it's not strange to have a server with a single-word name. However, that will not be true on the internet. So the fixup feature (which we disabled) tries www. + word + .com and this enables you to, for example, just toss yahoo in the address bar and get to the expected site.

The problem is that when you are searching for a word that you do not think is a specific site, or for which the specific site isn't what you want, Firefox's assuming that the word is a server name is a problem. Firefox doesn't run a search until it gets the server not found error.

Ideally, your ISP would simply tell Firefox that the server was not found, but instead your ISP is taking the opportunity to "help" you by presenting its own results page. Of course, you knew that; it's too bad the opt-out didn't work. We might need to fire your ISP.

Unless we can convince Firefox to treat a single word as a search instead of a server name (maybe someone knows a setting for that?), you could:

  1. Use the search box instead of the address bar for searching; or
  2. Change your DNS servers so that your ISP is out of the picture.

On that second point, companies such as Google offers public DNS servers you could use. More info: Google Public DNS (8.8.8.8, 8.8.4.4). Of course, Google probably does something will all the data it collects from your browsing; nothing's really completely free!

I'm not sure exactly how the replacement DNS servers would be implemented in your setup -- it could be a Mac setting, it could be in your network router -- but this would resolve the issue of your ISP intercepting the server not found and helping you with its results page.

I think I wasn't clear in my own mind on the problem, but I'm clearer now. :-) When you enter one word in the address bar, Firefox will always assume it is a server name. If you are on an intranet, it's not strange to have a server with a single-word name. However, that will not be true on the internet. So the fixup feature (which we disabled) tries www. + word + .com and this enables you to, for example, just toss yahoo in the address bar and get to the expected site. The problem is that when you are searching for a word that you do not think is a specific site, or for which the specific site isn't what you want, Firefox's assuming that the word is a server name is a problem. Firefox doesn't run a search until it gets the server not found error. Ideally, your ISP would simply tell Firefox that the server was not found, but instead your ISP is taking the opportunity to "help" you by presenting its own results page. Of course, you knew that; it's too bad the opt-out didn't work. We might need to fire your ISP. Unless we can convince Firefox to treat a single word as a search instead of a server name (maybe someone knows a setting for that?), you could: # Use the search box instead of the address bar for searching; or # Change your DNS servers so that your ISP is out of the picture. On that second point, companies such as Google offers public DNS servers you could use. More info: [https://developers.google.com/speed/public-dns/ Google Public DNS] (8.8.8.8, 8.8.4.4). Of course, Google probably does something will all the data it collects from your browsing; nothing's really completely free! I'm not sure exactly how the replacement DNS servers would be implemented in your setup -- it could be a Mac setting, it could be in your network router -- but this would resolve the issue of your ISP intercepting the server not found and helping you with its results page.
dpyang@cox.net 0 giải pháp 4 câu trả lời
Được đăng

I have the same issue -- address bar search when you type in an abbreviated URL. Except it wasn't changed by my ISP. It was changed without my permission by some program I installed. Changed to Yahoo. How do I get Google back?

I have the same issue -- address bar search when you type in an abbreviated URL. Except it wasn't changed by my ISP. It was changed without my permission by some program I installed. Changed to Yahoo. How do I get Google back?
dpyang@cox.net 0 giải pháp 4 câu trả lời
Được đăng

Try this page: https://support.mozilla.org/en-US/questions/944592#answer-434154

Read all the way down to martinio's comment. It worked for me!

Try this page: https://support.mozilla.org/en-US/questions/944592#answer-434154 Read all the way down to martinio's comment. It worked for me!
MattWilcox1 0 giải pháp 1 câu trả lời
Được đăng

Hi samshine. I had the same problem and it was so annoying! I'll tell you what fixed it for me. -I went to about:config and searched "keyword.url" - I then right-clicked it and hit "Reset" - I then right-clicked again and hit "Modify" and posted this exact address [ https://www.google.com/search?q= ] in the "Enter string value" box that popped up (ignore the brackets).

I hope this helps!

P.S. - I also made sure I checked all the settings that jscher2000 said:

- browser.fixup.alternate.enabled should be false - keyword.enabled should be true - keyword.URL should be blank

Hi samshine. I had the same problem and it was so annoying! I'll tell you what fixed it for me. -I went to about:config and searched "keyword.url" - I then right-clicked it and hit "Reset" - I then right-clicked again and hit "Modify" and posted this exact address [ https://www.google.com/search?q= ] in the "Enter string value" box that popped up (ignore the brackets). I hope this helps! P.S. - I also made sure I checked all the settings that jscher2000 said: - browser.fixup.alternate.enabled should be false - keyword.enabled should be true - keyword.URL should be blank

Được chỉnh sửa bởi MattWilcox1 vào

finitarry 251 giải pháp 3421 câu trả lời
Được đăng

jscher2000,

"When you enter one word in the address bar, Firefox will always assume it is a server name. "

That used to be true but is not true now. If I type a single word into my address bar, the search engine I set to work from there will start searching for it. I am not sure exactly when that changed - it was sometime after FF 3.6.

The fixup enable setting is still there and still active. I just tried to reset it, but it only changed to the default value and did not change to an empty string value and later disappear.

jscher2000, "When you enter one word in the address bar, Firefox will always assume it is a server name. " That used to be true but is not true now. If I type a single word into my address bar, the search engine I set to work from there will start searching for it. I am not sure exactly when that changed - it was sometime after FF 3.6. The fixup enable setting is still there and still active. I just tried to reset it, but it only changed to the default value and did not change to an empty string value and later disappear.
jscher2000
  • Top 10 Contributor
8774 giải pháp 71729 câu trả lời
Được đăng

Hi finitarry, you wrote:

jscher2000,

"When you enter one word in the address bar, Firefox will always assume it is a server name. "

That used to be true but is not true now. If I type a single word into my address bar, the search engine I set to work from there will start searching for it. I am not sure exactly when that changed - it was sometime after FF 3.6.

Wow, you're right! My more recent installation of Firefox doesn't even seem to try to use fixup. I'll have to compare my old installation and see what preferences are different. "Something" must have been migrated from earlier versions that makes it behave the old way.

Hi finitarry, you wrote: <blockquote>jscher2000, <br><br>"When you enter one word in the address bar, Firefox will always assume it is a server name. " <br><br>That used to be true but is not true now. If I type a single word into my address bar, the search engine I set to work from there will start searching for it. I am not sure exactly when that changed - it was sometime after FF 3.6. </blockquote> Wow, you're right! My more recent installation of Firefox doesn't even seem to try to use fixup. I'll have to compare my old installation and see what preferences are different. "Something" must have been migrated from earlier versions that makes it behave the old way.
Subzero 0 giải pháp 1 câu trả lời
Được đăng

I recently had the exact same problem and fixed it by following the Mozilla Support article.Search the web from the Address Bar and fixed it. I hope it helps, good luck.

I recently had the exact same problem and fixed it by following the Mozilla Support article.[https://support.mozilla.org/en-US/kb/search-web-address-bar Search the web from the Address Bar] and fixed it. I hope it helps, good luck.
XxARKxX 0 giải pháp 1 câu trả lời
Được đăng
Go here Its way easy :P https://addons.mozilla.org/en-US/firefox/addon/searchreset/

Được chỉnh sửa bởi XxARKxX vào

budm17 0 giải pháp 1 câu trả lời
Được đăng

I had a very similar issue! This solved it: http://www.wikihow.com/Change-Your-Browser%27s-Default-Search-Engine#Firefox

I hope it works for you also!

I had a very similar issue! This solved it: http://www.wikihow.com/Change-Your-Browser%27s-Default-Search-Engine#Firefox I hope it works for you also!
TheMZN21 0 giải pháp 1 câu trả lời
Được đăng

Hey, here is really easy and simple way to change your default search engine in your URL bar. Open a new tab and go to about:Config. Search for browser.search.defaultenginename. Once you right-clicked on it, you can move your mouse over to 'new' and click on 'string'. It will now ask for a name. Just type in the name of your search engine It will then ask for the string value. You will only have to enter your search engine's link. It should normally appear under the 'value' column, and it should work all fine, but if it doesn't, you have to right click on browser.search.defaultenginename again and select 'modify', and then enter your freshly made search engine's name. For example, if you would want to use Google as your URL bar search engine, you choose 'Google' as a name, and 'www.google.com' as string value.

There you go, hope it will help ;) It worked in my case

Hey, here is really easy and simple way to change your default search engine in your URL bar. Open a new tab and go to about:Config. Search for browser.search.defaultenginename. Once you right-clicked on it, you can move your mouse over to 'new' and click on 'string'. It will now ask for a name. Just type in the name of your search engine It will then ask for the string value. You will only have to enter your search engine's link. It should normally appear under the 'value' column, and it should work all fine, but if it doesn't, you have to right click on browser.search.defaultenginename again and select 'modify', and then enter your freshly made search engine's name. For example, if you would want to use Google as your URL bar search engine, you choose 'Google' as a name, and 'www.google.com' as string value. There you go, hope it will help ;) It worked in my case

Được chỉnh sửa bởi TheMZN21 vào

m16amachinegun 0 giải pháp 1 câu trả lời
Được đăng

I have this same problem, but with ISP Provider: Windstream. None of the solutions on this page worked.

I have this same problem, but with ISP Provider: Windstream. None of the solutions on this page worked.
jscher2000
  • Top 10 Contributor
8774 giải pháp 71729 câu trả lời
Được đăng

Hi m16amachinegun, does this problem occur with multi-word searches, or only with single word searches? When the problem is only single word searches, you could consider changing your DNS service provider to one that honestly reports a server is not found instead of substituting its own page. Options include OpenDNS and Google Public DNS. (This might not be possible in a work environment.)

Hi m16amachinegun, does this problem occur with multi-word searches, or only with single word searches? When the problem is only single word searches, you could consider changing your DNS service provider to one that honestly reports a server is not found instead of substituting its own page. Options include OpenDNS and Google Public DNS. (This might not be possible in a work environment.)
xPrincessEmilyx 0 giải pháp 1 câu trả lời
Được đăng

I had the same problem with it using yahoo to search but I wanted google.

Open a new tab and type in about:Config

Search for "keyword" and look for keyword.URL on the list

Double click on it

In the box that appears (for google) paste/type in this: http://www.google.com/search?&q=

Press Ok

That will set your address bar to searching google :) It will work for searches of more than one word only though. If you want to search for one word too then you need to turn off the setting that automatically makes firefox try and find the url for the word. Eg if you type in "ebay" firefox will try to access "www.ebay.com"

Hope this helps!

I had the same problem with it using yahoo to search but I wanted google. Open a new tab and type in about:Config Search for "keyword" and look for keyword.URL on the list Double click on it In the box that appears (for google) paste/type in this: http://www.google.com/search?&q= Press Ok That will set your address bar to searching google :) It will work for searches of more than one word only though. If you want to search for one word too then you need to turn off the setting that automatically makes firefox try and find the url for the word. Eg if you type in "ebay" firefox will try to access "www.ebay.com" Hope this helps!
recklezzrogue 0 giải pháp 2 câu trả lời
Được đăng

Hello All,

This is the closest thread I think to what I am looking. I have the exact opposite problem - I am painstakingly disconnecting every aspect of myself from the leviathan known as google (they've just gone way too creepy for me). While I love the app (Aurora on Android), it always sends unknown url entries to google, even though my default search engine is yahoo.

How can I stop Aurora from ever talking to google without me explicitly 'asking it to'? If the answer is de-install...then so be it.

thanks,

Rogue

Hello All, This is the closest thread I think to what I am looking. I have the exact opposite problem - I am painstakingly disconnecting every aspect of myself from the leviathan known as google (they've just gone way too creepy for me). While I love the app (Aurora on Android), it always sends unknown url entries to google, even though my default search engine is yahoo. How can I stop Aurora from ever talking to google without me explicitly 'asking it to'? If the answer is de-install...then so be it. thanks, Rogue
jscher2000
  • Top 10 Contributor
8774 giải pháp 71729 câu trả lời
Được đăng

Hi Rogue, what do you think about starting a new thread for that topic? This one is mostly about problems with address bar searching being taken over by an ISP. You could do that here:

https://support.mozilla.org/questions/new/desktop

Some connections with Google include:

  • Search providers
  • SafeBrowsing
Hi Rogue, what do you think about starting a new thread for that topic? This one is mostly about problems with address bar searching being taken over by an ISP. You could do that here: https://support.mozilla.org/questions/new/desktop Some connections with Google include: * Search providers * SafeBrowsing
recklezzrogue 0 giải pháp 2 câu trả lời
Được đăng

I will do that. thanks.

I will do that. thanks.
FL0WL0W 0 giải pháp 1 câu trả lời
Được đăng

The problem is your stupid IP sending back crap DNS. Change your DNS server to googles DNS servers. 8.8.8.8 and 8.8.4.4 you'll do this in Network and Sharing Center>Change Adapter Settings>Right Click on your connection>Properties>Internet Protocol Version 4 (TCP/IPv4)>Properties>Use the following DNS server addresses>set the addresses to 8.8.8.8 and 8.8.4.4 Your Welcome

The problem is your stupid IP sending back crap DNS. Change your DNS server to googles DNS servers. 8.8.8.8 and 8.8.4.4 you'll do this in Network and Sharing Center>Change Adapter Settings>Right Click on your connection>Properties>Internet Protocol Version 4 (TCP/IPv4)>Properties>Use the following DNS server addresses>set the addresses to 8.8.8.8 and 8.8.4.4 Your Welcome