Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

new tab about:home search does not work

  • 5 trả lời
  • 9 gặp vấn đề này
  • 1090 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I installed 18.0 today. I have it set up to open FF search page (about:home) when I open a new tab. This search page no longer functions; I can input search terms, but neither the search button nor enter does anything. It just sits there.

I tried the steps outlined here: https://support.mozilla.org/en-US/questions/934580?esab=a&as=aaq It didn't help. I also tried addons disabled. No go.

Được chỉnh sửa bởi stevieray vào

Giải pháp được chọn

OK. Found the problem. It was Tab Mix Plus.

Options > Tabs > Tab Mix Plus Options > New Tabs > address: was reset during the upgrade to "home:newtab" while the browser.newtab.url was "about:home". Set them both to about:home and now it works fine.

(Note: I don't know why disabling addons didn't work... it should have disabled Tab Mix Plus and eliminated the conflict.)

EDIT. Yes, I restarted the browser. And I had tried both of those other steps before I asked for help... see the link in my original question.

Thanks for the help, cor-el.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (5)

more options

Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

You need to close and restart Firefox to make the about:home page work properly.


If this didn't help then try this:

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Được chỉnh sửa bởi cor-el vào

more options

Thanks for the reply, cor-el.

I just tried the search reset addon. No help.

I found that if I manually change browser.newtab.url from about:home to another search engine (like www.google.com or www.bing.com) it works just fine. Interesting.

more options

Did you restart Firefox after installing SearchReset?

Did you try the second suggestion and reset the browser.startup.homepage_override.mstone pref on the about:config page and close and restart Firefox?

more options

Giải pháp được chọn

OK. Found the problem. It was Tab Mix Plus.

Options > Tabs > Tab Mix Plus Options > New Tabs > address: was reset during the upgrade to "home:newtab" while the browser.newtab.url was "about:home". Set them both to about:home and now it works fine.

(Note: I don't know why disabling addons didn't work... it should have disabled Tab Mix Plus and eliminated the conflict.)

EDIT. Yes, I restarted the browser. And I had tried both of those other steps before I asked for help... see the link in my original question.

Thanks for the help, cor-el.

Được chỉnh sửa bởi stevieray vào

more options

If prefs were set incorrectly by an extension then starting in Safe mode wouldn't reset them to meaningful value (safe mode doesn't affect prefs).