Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have an extraneous result in my awesome bar and can't remove it

  • 5 trả lời
  • 1 gặp vấn đề này
  • 331 lượt xem
  • Trả lời mới nhất được viết bởi jeffreypriebe

more options

When I begin typing in the awesome bar, I always get a particular result and I can't figure out how to remove it. It is not in my history, not in my bookmarks, I can't find it to remove it. Most annoningly, it is autocomplete suggestion so I have to consistently move around it.

It occurs everytime, as I type "read" - headed to Google Reader, but the autocomplete result is "readbility.com" though I can't find how to remove that.

http://img441.imageshack.us/img441/982/screenshot001ce.png

Giải pháp được chọn

You can probably only get rid of such entries by deleting the places.sqlite file.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (5)

more options

Go to options>Privacy>Location Bar drop down menu. There you can set what you see when you type in the awesome bar, such as bookmarks, history, nothing, or bookmarks and history together.

Được chỉnh sửa bởi user633449 vào

more options

Does that entry appear in the list if you type more letters of that result?

Is that site bookmarked or otherwise visited or typed?

Use these steps to remove saved (form) data from a drop down list:

  1. Click the (empty) input field on the web page to open the drop down list
  2. Highlight an entry in the drop down list
  3. Press the Delete key (on Mac: Shift+Delete) to remove it.

You can check for problems with the places.sqlite database file in the Firefox Profile Folder.

more options

No, I can't find that URL in the drop-down list ever. I tried ever combination of letters.

I've since found another example of this issue. Very frustrating since I don't visit the "default" site that Firefox is trying to force on me.

more options

Giải pháp được chọn

You can probably only get rid of such entries by deleting the places.sqlite file.

more options

Thanks for the pointer cor-el. I just queried for references to the site in the moz_places and moz_inputhistory tables of the places sqlite and removed them selectively. Fixed!

Small annoyance, but nice to solve it.

Được chỉnh sửa bởi jeffreypriebe vào