Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How to print any web page to PDF in Windows 7 after Firefox version 8?

  • 3 trả lời
  • 3 gặp vấn đề này
  • 2649 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

Some web pages do not print to PDF after Firefox Version 8. The result is either incomplete PDF or the print progress stops at some point and Firefox is stuck. For example the following web page http://en.wikipedia.org/wiki/Abraham_Lincoln prints to PDF with Firefox Version 8, but it does not print with any version of Firefox newer than 8. Note that the latest version of Acrobat Professional produced the same results as well as other PDF generating tools such as "FreePDF XP" and "Bullzip". Also the same web page on this same machine does print from within Internet Explorer. However using Internet Explorer is not a solution for our needs.

Thank you for looking into this. Plamen Djambazov

edited to remove email address

Được chỉnh sửa bởi TonyE vào

Giải pháp được chọn

That page prints to PDF for me in Firefox 17 on Windows 7x64 -- I tested pdfFactory Pro and PDF Creator.

You might try resetting all your print preferences in case some corruption has crept in over time. This article describes that in more detail: http://kb.mozillazine.org/Problems_printing_web_pages


Could you also try disabling graphics hardware acceleration? I don't know whether this affects printing at all, but just in case.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, do you notice any difference?


A standard diagnostic to bypass interference by extensions (and some custom settings) is to try Firefox's Safe Mode.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Troubleshoot Firefox issues using Safe Mode) using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode."

If you can print PDFs normally, this points to one of your extensions or custom settings as the problem.

To also disable plugins, you can try here:

orange Firefox button or classic Tools menu > Add-ons > Plugins category

Any change?

Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (3)

more options

Giải pháp được chọn

That page prints to PDF for me in Firefox 17 on Windows 7x64 -- I tested pdfFactory Pro and PDF Creator.

You might try resetting all your print preferences in case some corruption has crept in over time. This article describes that in more detail: http://kb.mozillazine.org/Problems_printing_web_pages


Could you also try disabling graphics hardware acceleration? I don't know whether this affects printing at all, but just in case.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, do you notice any difference?


A standard diagnostic to bypass interference by extensions (and some custom settings) is to try Firefox's Safe Mode.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Troubleshoot Firefox issues using Safe Mode) using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode."

If you can print PDFs normally, this points to one of your extensions or custom settings as the problem.

To also disable plugins, you can try here:

orange Firefox button or classic Tools menu > Add-ons > Plugins category

Any change?

more options

Setting the "Use hardware acceleration when available" to false fixed the problem. Thank you!

Still puzzled why this option has no effect with Firefox 8, but any version after. And more importantly why this option when turned on (checked) works fine on most machines, but on some others PDF does not print and Firefox freezes.

What suppose to be the benefits of the "Use hardware acceleration when available"? Testing some large files both ways did not show any significant difference one way or the other.

more options

Graphics driver support seems to be a difficult area to get right...

I'd just be guessing as to any specific differences between Fx8 and Fx17 that affect the Adobe Acrobat plugin.