X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

I select "Use custom settings for history", when Firefox updates, it reverts back to "remember history"

Được đăng

I keep having problems with my online banking website. Frequently, I have to re-register my computer with them. I have checked with their support and they find nothing wrong at their end. They said it probably had to do with security and/or privacy settings in Firefox. They told me to select "custom setting for history" under privacy in options. I did this and it seems to work until Firefox updates and then it resets to "remember history":under privacy. When this happens I have to re-register my computer on that web site. Since this happens every few days and I have 5 different accounts on this website, it is a pain. This has only been occurring in the past several weeks.

Why is this happening?

I keep having problems with my online banking website. Frequently, I have to re-register my computer with them. I have checked with their support and they find nothing wrong at their end. They said it probably had to do with security and/or privacy settings in Firefox. They told me to select "custom setting for history" under privacy in options. I did this and it seems to work until Firefox updates and then it resets to "remember history":under privacy. When this happens I have to re-register my computer on that web site. Since this happens every few days and I have 5 different accounts on this website, it is a pain. This has only been occurring in the past several weeks. Why is this happening?

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • npsitesafety
  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Winamp Application Detector
  • ActiveTouch General Plugin Container Version 105
  • Gaaiho Doc Plugin
  • 4.1.10329.0
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPWLPG
  • Best Buy pc app Detector Plug-in
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Plugin for Netscape Navigator

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

Thông tin chi tiết

Jan. 7 giải pháp 82 câu trả lời
Được đăng

Câu trả lời hữu ích

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox and any leftover program files and then reinstall Firefox. Please follow these steps one by one:

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu) and confirm all upcoming messages.
  3. Now, uninstall Firefox by following the steps mentioned in the Uninstall Firefox article.

IMPORTANT: On Windows, the uninstaller has the option to remove your personal data and settings. Make sure that you do not check this option; otherwise all of your bookmarks, passwords, extensions, user customizations and other Firefox user profile data will be removed from your computer.

After uninstalling Firefox on Windows, delete the "Mozilla Firefox" program folder, located by default in one of these locations:

  • (On 32-bit Windows) C:\Program Files\Mozilla Firefox
  • (On 64-bit Windows) C:\Program Files (x86)\Mozilla Firefox
  1. Go to the Windows Start menu and click on "Computer".
  2. In the Explorer window that opens, double click Local Disk (C:) to open the C:\ drive.
  3. Find the "Program Files (x86)" folder or "Program Files" folder.
    • On 32-bit Windows, double-click the Program Files folder to open it.
    • On 64-bit Windows, you will see a "Program Files (x86)" folder AND a "Program Files" folder. Open the Program Files (x86) folder.
  4. Look for a Mozilla Firefox folder. If you find one, right-click it and select Delete and confirm that you want to move the folder to the Recycle Bin.

Now, go ahead and reinstall Firefox:

  1. Double-click the downloaded installation file and go through the steps of the installation wizard.
  2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

Certain Firefox problems can be solved by performing a ''Clean reinstall''. This means you remove Firefox and any leftover program files and then reinstall Firefox. Please follow these steps one by one: #Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer. #After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu) and confirm all upcoming messages. #Now, uninstall Firefox by following the steps mentioned in the [[Uninstall Firefox from your computer#w_uninstall-firefox|Uninstall Firefox]] article. '''IMPORTANT:''' On Windows, the uninstaller has the option to remove your personal data and settings. Make sure that you do '''not''' check this option; otherwise all of your bookmarks, passwords, extensions, user customizations and other Firefox [[Profiles|user profile data]] will be removed from your computer. After uninstalling Firefox on Windows, delete the "Mozilla Firefox" program folder, located by default in one of these locations: * '''(On 32-bit Windows)''' ''C:\Program Files\Mozilla Firefox'' * '''(On 64-bit Windows)''' ''C:\Program Files (x86)\Mozilla Firefox'' #Go to the Windows Start menu and click on "Computer". #In the Explorer window that opens, double click Local Disk (C:) to open the C:\ drive. #Find the "Program Files (x86)" folder or "Program Files" folder. #* On 32-bit Windows, double-click the '''Program Files''' folder to open it. #* On 64-bit Windows, you will see a "Program Files (x86)" folder AND a "Program Files" folder. Open the '''Program Files (x86)''' folder. #Look for a '''Mozilla Firefox''' folder. If you find one, right-click it and select ''Delete'' and confirm that you want to move the folder to the Recycle Bin. Now, go ahead and reinstall Firefox: #Double-click the downloaded installation file and go through the steps of the installation wizard. #Once the wizard is finished, choose to directly open Firefox after clicking the Finish button. Please report back to see if this helped you!
cor-el
  • Top 10 Contributor
  • Moderator
17532 giải pháp 158526 câu trả lời
Được đăng

The "Use custom settings for history" selection allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings.
Firefox shows the "Use custom settings for history" selection as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.
If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".
"Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a check mark.


Websites remembering you and automatically log you on is stored in a cookie.

  • Create an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep such a cookie, especially for secure websites and if cookies expire when Firefox is closed.

Make sure that you do not run Firefox in Private Browsing mode.

Do not use Clear Recent History to clear the "Cookies" and the "Site Preferences"

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

The "Use custom settings for history" selection allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings.<br /> Firefox shows the "Use custom settings for history" selection as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.<br /> If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".<br /> "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a check mark.<br /> <br /> ---- Websites remembering you and automatically log you on is stored in a cookie. * Create an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep such a cookie, especially for secure websites and if cookies expire when Firefox is closed. Make sure that you do not run Firefox in Private Browsing mode. * https://support.mozilla.com/kb/Private+Browsing Do not use Clear Recent History to clear the "Cookies" and the "Site Preferences" * https://support.mozilla.com/kb/Clear+Recent+History Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.