Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

favicon not showing

  • 12 trả lời
  • 8 gặp vấn đề này
  • 2513 lượt xem
  • Trả lời mới nhất được viết bởi Mottie

more options

I have some demo pages for a plugin on github. Oddly, I can't get the favicon to show up in Firefox (try the simple demo page). They show up in webkit browsers and IE without any problems. The effected pages are "Main", "Simple", "Expand", "Video" and "FX".

Even more strange is that only one demo page ("CSS3") shows the favicon on the tab and when saved as a bookmark, but none of the other pages will.

Giải pháp được chọn

It works if I disable JavaScript.
Looks that it is caused by JavaScript that runs on the page and that modifies the URL (hash).

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (12)

more options

Try to add a type attribute to the link element.

<link rel="shortcut icon" href="demos/images/favicon.ico" type="image/x-icon">
more options

If you have the favicon.ico image file in the root directory of the website that "shortcut icon" code isn't needed.

more options

Adding type="image/x-icon" didn't change anything

Moving the favicon.ico to the same folder as the html file doesn't work either. If you meant the root of the website, I have no way to do that. And this doesn't explain why the css3 demo page does show the favicon while the others don't.

more options

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

It works for me though if I run this code in the Scratchpad (Shift+F4);

N=document.createElement("link");
N.setAttribute("href", "demos/images/favicon.ico");
N.setAttribute("rel", "shortcut icon");
N.setAttribute("type", "image/x-icon");
document.head.appendChild(N);
more options

Hmm, that is interesting that adding the link with javascript does work, but having the type added to the link still doesn't seem to work. Helpful, but not really the answer I need. I'd like to get it to work without using javascript.

more options

I'm not seeing that attribute in the current website code, so I can't test this.

more options

Ok, I've updated all of the demo pages. Still no luck =(

more options

The favicon.ico file doesn't seem to be working as a favcion.

Try to recreate or re-save the image file and upload that image to the server.

Được chỉnh sửa bởi cor-el vào

more options

Hmm, still no luck. I used this photoshop plugin to save the ico file (using Windows 7). Maybe I need to use something else.

more options

Giải pháp được chọn

It works if I disable JavaScript.
Looks that it is caused by JavaScript that runs on the page and that modifies the URL (hash).

more options

Ahhh, I see, now to figure out how to stop it. Thanks for the help!

more options