Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

I Can't Get Rid Of Babylon! PLEASE HELP!!

  • 51 trả lời
  • 87 gặp vấn đề này
  • 22 lượt xem
  • Trả lời mới nhất được viết bởi Tienie

more options

The other day I had an update for a program I already have. Like always it asked me if I wanted to install some toolbar and whatnot. And like always I clicked all the "No" boxes and updated like normal thinking it would honor my request.

It didn't.

Thinking I had just missed something I went to my Control Panel, Add/Remove Programs, uninstalled it and thought that was that.

It wasn't.

I get on this morning and it's still trolling my search engines and pages. I went to the Firefox help page to find any solutions but everything I've tried has failed! I've tried the "about:config" method where I reset all the Babylon stuff (they just come back when I restart) and I tried replacing it in the "keyword" section (it didn't even notice apparently).

I then ran Spybot four times and even ran a new program called Malwarebytes and it didn't change a thing. I even tried System Restore. Twice. Now I'm stuck with this program taking over my FF by adding advertisements in dumb places like all over Youtube and even in my typed text!

I'm at my wits end! There HAS to be some foolproof way of getting rid of it! PLEASE HELP!!

Tất cả các câu trả lời (20)

more options

i tried the the about:config method and scrolled through the listings and reset everything with the name babylon and replaced babylon with google where i needed to and that worked for me. At last no more babylon tabs!

cheers evetucker ... cool tip. one to remember.

more options

Glad it helped you. Wish we co.uld help Fryeheart.

more options

Have you tried removing babylon from your cookies, go to privacy and remove individual cookies and see if its buried in there and try the about :config method again.

Hopefully its something simple like this that your overlooking.

more options

Thanks, guys but I'm afraid I'll have to take my comp in to a professional. Last night my desktop began behaving strangely for no apparent reason. First, I noticed that my speakers weren't working even though they were turned on. I made sure they were plugged in and they were. Then my mouse and keyboard failed. I don't know if Babylon has anything to do with this but I can't do anything about it if nothing works.

more options

Sorry that it has come to that. Please post back how you make out and what they say, if anything, about Babylon and if it could have caused your problem. Thanks

more options

I recommend a good backup first. "Stuff happens" at some of those places and you might just need it later.

Note: if you can't use your computer because the keyboard doesn't work, a friend can use an external USB enclosure to attach your hard drive and make a backup to some other media. Or your service provider can do it if you insist on a backup before they make any changes.

Được chỉnh sửa bởi jscher2000 vào

more options

I don't know how to back it up if nothing is works. I have this hard drive made for backing up but I'm worried that even if I'm able to get the mouse working I'll backup Babylon along with it.

more options

sounds like something may have disrupted your registry or drivers. u should try opening in safe mode to see if ur system works there. if not then it could be a hardware problem. but safe mode should help give you an indication as to how serious the problem is.

more options

You sure it's safe? If the motherboard is dying wouldn't turning it on make it worse?

I really know nothing about this kind of stuff.

more options

Did you search on the about:config page for baby;on and reset related prefs via the right-click context menu?

Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

You can also try to reset Firefox.

Reset creates a new profile and tries to import some settings from the old profile leaving the old profile intact.

more options

yea ... go ahead and start in safe mode that's probably the first check that a Tec will do. this starts the system in its most basic format. if it opens in safe mode and you can use your system then your basic pc is working ... which is good news.. then its a matter of finding out what is causing the problem. give it a go and see if it works for u. if it does its a good start.

more options

Cor-el, If you read my original post you'll see that I've tried that several times and it just came back.

Sendtobarry, How do I open it in safe mode? I've never seen that option when I turn it on. I just press a button and it comes on.

more options

You can use one of these to start Firefox in Safe mode:

  • Help > Restart with Add-ons Disabled
  • On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut
  • On Mac, hold down the Options key while starting Firefox
  • https://support.mozilla.org/kb/Safe+Mode

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

Did you try a new profile?

more options

Cor-el, I think he was talking about Safe Mode on the main computer. Not just Firefox. Besides, it's kind of on IE as well even though it's not quite as obvious.

more options

Dea Fyreheartr: In order to change your search engine, please view this link: http://support.babylon.com/index.php?/Knowledgebase/Article/View/213/0/remove-toolbar-and-search-the-web-babylon

(scroll down for Mozilla firefox)

In order to change your homepage, please view this link: http://support.babylon.com/index.php?/Knowledgebase/Article/View/175/0/change-babylon-home-page

Babylon Offers a full service for all its products and features valid from the Babylon Store and on the world wide web You can gain a full support and assistance on how to remove Babylon from your computer by the following ways :

Phone-18668086361 (US) Email: Support@babylon.com Website for Chat and Q& A : http://support.babylon.com/

Cheers Babylon,Ltd

more options

I had this issue too for a while and I just found another post that helped me, hopefully it'll help you too. There's another program that you need to install that doesn't say Babylon in the title, "browser manger." Try uninstalling that program using your control panel. You can reset your homepage after that and hopefully it'll stick. That's what I did and FINALLY babylon is gone

more options

Thank you itisunny, I have also been able to get rid of babylon search, tried everything everyone suggested and then yours, it worked. Ok fyreheart, as itisunny said, go to Control Panel/Add Remove programs and find Browser Manager, hopefully it is there, then delete it, change homepage to what you want and everything should be ok. Thanks again itisunny, never want to see that thing again.

more options

I didn't find anything like that in add/remove programs and didn't even find it in a search. It's like every suggestion hits a dead end for me.

more options
more options

Ugh. That won't work either because apparently I don't have Sysinternals.

  1. 1
  2. 2
  3. 3