Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

I Can't Get Rid Of Babylon! PLEASE HELP!!

  • 51 trả lời
  • 87 gặp vấn đề này
  • 24 lượt xem
  • Trả lời mới nhất được viết bởi Tienie

more options

The other day I had an update for a program I already have. Like always it asked me if I wanted to install some toolbar and whatnot. And like always I clicked all the "No" boxes and updated like normal thinking it would honor my request.

It didn't.

Thinking I had just missed something I went to my Control Panel, Add/Remove Programs, uninstalled it and thought that was that.

It wasn't.

I get on this morning and it's still trolling my search engines and pages. I went to the Firefox help page to find any solutions but everything I've tried has failed! I've tried the "about:config" method where I reset all the Babylon stuff (they just come back when I restart) and I tried replacing it in the "keyword" section (it didn't even notice apparently).

I then ran Spybot four times and even ran a new program called Malwarebytes and it didn't change a thing. I even tried System Restore. Twice. Now I'm stuck with this program taking over my FF by adding advertisements in dumb places like all over Youtube and even in my typed text!

I'm at my wits end! There HAS to be some foolproof way of getting rid of it! PLEASE HELP!!

Tất cả các câu trả lời (20)

more options

Preferences reverting can be caused by an add-on changing them back or by a problem with the settings file not being saved.

Have you tried disabling or removing all non-essential add-ons? In particular, here:

orange Firefox button or classic Tools menu > Add-ons > Extensions category

On the second issue, see: How to fix preferences that won't save.

more options

I don't know if this'll help but it seems to have taken over AVG too. When I did the config:about it let me reset everything but the two avg applications. No matter what I did it wouldn't let me change it or anything. I have no idea how to get it to let me turn it off.

more options
more options

Hi Fyreheart, do you have the AVG Secure Search program? You need to remove that first, then see one of these:

more options

Apparently I don't have it because I didn't have that active or installed because it wasn't there when I looked. I went through the rest of the steps that I could anyway and nothing really changed.

Here's a screenshot of the config page. Hopefully this will help a bit.

Remember that when I right-click and Reset them they just come back when I restart. Same goes with the search bar. I delete, it comes back. Dumb program just won't take No for an answer.

more options

Check if you can see it in registry and delete from there, My Computer\HEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Firefox\extensions

thank you

more options

I don't have a folder that's called HEY_LOCAL_MACHINE. I did look through all the Mozilla folders I could find though and the one Extentions folder I aw was completely empty.

more options

I have had this problem too. When I searched for a solution I came up with the following. It takes a few tries to get rid of all of it, but I now get google as the start page in my new tabs. Woo Hoo. Thanks to the person who posted this originally and good luck to you guys. BTW it is important to use the : between about and config. Very, very helpful post.

To revert to Google as your preferred search engine, please do the following.

   In the location bar, type about:config and hit Enter.
   In the filter at the top, type: keyword.URL
   Double click it and remove whatever's in there and replace it with http://www.google.com/search?q= 

It's possible that Babylon will add itself to more than one place in about:config. Therefore, after completing the above steps, type "babylon" in the filter at the top. For every instance where you see a setting with that name in it, right click it and choose Modify and then Reset. Then close Firefox and restart it.

I found probably 30 or 40 more babylons in my about config, but they are finally all gone.

The URL to add in "keyword.URL" can be copied and pasted.

more options


Được chỉnh sửa bởi SafeBrowser vào

more options

Did you guys even read my first post? I tried to uninstall it and it didn't work. I tried to Reset everything and it didn't work. Suggesting things I've already tried 20 times already isn't going to help.

more options

Sorry. I thought I had tried everything too, but when I finally used the above instructions exactly as they are written, everything was gone and I am back to Google. Good luck. Sorry they don't work for you.

more options

So you're saying the reason Resetting didn't work was because there are more than that and I just have to keep restarting and resetting til they're gone?

more options

Yes, that is what I had to do. I had already removed the toolbar and uninstalled the program, but there was a lot of stuff in the about:config. I think I restarted the browers 3 or 4 times before everything was gone. Good luck. Let me know how you do. I hope it will work. That was the most obnoxious unsolicited program I have ever had.

more options

But what do I do about those two AVG files? They're the only ones that flat-out won't let me change anything.

more options

Hi Fyreheart, thank you for the screen shot. When I search those two preferences, I see references to a lot of clean-up logs, but didn't immediately spot a definitive article: "avg.install.userhpsettings" or "avg.install.userspsettings" - Google Search.

If you don't have any active AVG add-ons, then those preferences shouldn't have any effect -- Firefox would just ignore those two lines. I suspect you still have some AVG software or settings lingering somewhere. Could you try filtering on avg and see what you find?

You also could try a more drastic approach, which is the new Reset feature in Firefox 13. This duplicates certain key data from your active settings folder into a new one, bypassing some add-ons and custom settings. Your plugins will still be active, but could be disabled manually if you like.

More information in this article: Refresh Firefox - reset add-ons and settings.

If the new settings folder has the same problem, you can switch back if you like (using Firefox's Profile Manager).

Edit: By the way, the path given by ideato above is a registry path and HEY should be HKEY. However, you shouldn't need to go into the registry to disable an add-on in most cases.

Được chỉnh sửa bởi jscher2000 vào

more options

I don't know. I didn't run into that problem. Hopefully the post by jscher2000 will help you. BTW I also had to remove Babylon from Google Chrome. Fixing one didn't automatically fix the other. Good luck. Hope you get it figured out.

Được chỉnh sửa bởi evtucker vào

more options

I'm currently visiting my mom for the weekend but I'll let you guys know when I get back so I can try some of the new stuff.


more options

Ok, guys I'm back. Sorry for making you wait.

jscher, I searched the about:config for AVG and there was one called extention.installCache that after I reset just comes back when I restart like all the Babylon stuff does.

evtucker, I've tried to reset everything for almost 20 minutes now (not counting the other times I tried to reset them) and they still come back.

I've also noticed that when I run Spybot when I first start up the computer it always finds the Babylon toolbar. Malwarebytes finds nothing.

I'm at a loss. I don't want to spend money to take it to a professional but I don't understand how NONE of the suggestions work for me when there are tons of other people who got it gone first or second try.

more options

I am so sorry. I have no more ideas except you might try a different browser. Even when I was having the trouble in Firefox, Google Chrome and Internet Explorer, Babylon never showed up in Rock Melt. It is a shame that something like this can sneak into our computers and cause such problems. I hope you can get it solved without having to go to a pro.

more options

Spybot seems to be picking up the same cookie everytime it scans too. Something called Right Media or something like that. I'm not sure if it has anything to do with it.

EDIT: Tried registry edit and that didn't work either. I then tried Internet Options > General > Search. Babylon was there but the Disable and Remove buttons were blanked out to make sure I couldn't get rid of it that way.

Được chỉnh sửa bởi Fyreheart vào

  1. 1
  2. 2
  3. 3