X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Scrolling breaks/chops up embedded flash videos

Được đăng

I'm having an issue that started when I updated to FF13. When I scroll a page past (up or down) an embedded video (like youtube) the embedded video becomes chopped up, broken, distorted, and messes with the visual look of the site I am viewing.

If I scroll up and down a lot, I can actually get it to visually duplicate the site in the area where the embedded video is supposed to be. It's quite weird.

My video drivers have been fully updated since the issue and did not fix the problem.

I have tried FF in safemode and that did not fix the problem.

All of my add ons and plugins are fully up-to-date. Plugins I use are adblock and noscript (both disabled during the test and site allowed).

Anyone know what might be causing the issue since upgrading to FF13? I think it may have something to do with Flash.

I'm having an issue that started when I updated to FF13. When I scroll a page past (up or down) an embedded video (like youtube) the embedded video becomes chopped up, broken, distorted, and messes with the visual look of the site I am viewing. If I scroll up and down a lot, I can actually get it to visually duplicate the site in the area where the embedded video is supposed to be. It's quite weird. My video drivers have been fully updated since the issue and did not fix the problem. I have tried FF in safemode and that did not fix the problem. All of my add ons and plugins are fully up-to-date. Plugins I use are adblock and noscript (both disabled during the test and site allowed). Anyone know what might be causing the issue since upgrading to FF13? I think it may have something to do with Flash.

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

Noscript, Addblock plus

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

Thông tin chi tiết

Người tạo câu hỏi

I have a thread going here as well, and no one has been able to solve the problem for me.

http://forums.mozillazine.org/viewtopic.php?f=38&t=2488127

I'm attaching an image that shows some of the problem in action. The left is before scrolling, the right is what happens when I scroll the page up and down a few times.

I have a thread going here as well, and no one has been able to solve the problem for me. http://forums.mozillazine.org/viewtopic.php?f=38&t=2488127 I'm attaching an image that shows some of the problem in action. The left is before scrolling, the right is what happens when I scroll the page up and down a few times.
cor-el
  • Top 10 Contributor
  • Moderator
17527 giải pháp 158478 câu trả lời
Được đăng
Try to "disable the hardware acceleration" in the Flash Player. *http://helpx.adobe.com/flash-player/kb/video-playback-issues.html See also: * https://support.mozilla.org/en-US/kb/keep-flash-up-to-date-and-troubleshoot-problems Flash "Display settings" window: * http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html

Người tạo câu hỏi

Disabling hardware acceleration in flash and/or Firefox itself does not solve the problem.

None of the troubleshooting flash options helped.

Thanks, but none of those helped.

Additional Note: During playback of videos I have no issues.

I took a video of the problem in action: http://youtu.be/hRxSXoo3hpY

Disabling hardware acceleration in flash and/or Firefox itself does not solve the problem. None of the troubleshooting flash options helped. Thanks, but none of those helped. Additional Note: During playback of videos I have no issues. I took a video of the problem in action: http://youtu.be/hRxSXoo3hpY

Được chỉnh sửa bởi Dougyb vào

Câu trả lời hữu ích

I uninstalled the latest version of Flash with this uninstall utility: http://download.macromedia.com/pub/flashplayer/current/uninstall_flash_player_64bit.exe

Then reinstalled Flash 11.2 http://fpdownload.macromedia.com/pub/flashplayer/current/licensing/win/install_flash_player_11_plugin_32bit.exe

Problem went away. I guess the newest version of Flash is to blame?

I uninstalled the latest version of Flash with this uninstall utility: http://download.macromedia.com/pub/flashplayer/current/uninstall_flash_player_64bit.exe Then reinstalled Flash 11.2 http://fpdownload.macromedia.com/pub/flashplayer/current/licensing/win/install_flash_player_11_plugin_32bit.exe Problem went away. I guess the newest version of Flash is to blame?
dblatnik 1 giải pháp 19 câu trả lời
Được đăng

This only started with the maintenance upgrade to FF13. (13.0.1)

Upgraded my level of Flash Player. No Change. Verified drivers haven't changed.

No joy. Something in 13.0.1 has changed the way Flash (like YouTube) is embedded in the html is displayed. It isn't an improvement.

As you can see in the attached image the video bar is about 1 line in height, and the "play" button is disassociated from the video.

UPDATE: I don't think the newest version of Flash is to blame, since I had this issue with the older version. And continue to have it with the newer version.

This only started with the maintenance upgrade to FF13. (13.0.1) Upgraded my level of Flash Player. No Change. Verified drivers haven't changed. No joy. Something in 13.0.1 has changed the way Flash (like YouTube) is embedded in the html is displayed. It isn't an improvement. As you can see in the attached image the video bar is about 1 line in height, and the "play" button is disassociated from the video. UPDATE: I don't think the newest version of Flash is to blame, since I had this issue with the older version. And continue to have it with the newer version.

Được chỉnh sửa bởi dblatnik vào

cor-el
  • Top 10 Contributor
  • Moderator
17527 giải pháp 158478 câu trả lời
Được đăng

That is an iframe that embeds a YouTube page: src="http://www.youtube.com/embed/8RWEXNRyRmo"
The iframe seems to be sized incorrectly in your case.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

That is an iframe that embeds a YouTube page: src="http://www.youtube.com/embed/8RWEXNRyRmo"<br /> The iframe seems to be sized incorrectly in your case. Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
dblatnik 1 giải pháp 19 câu trả lời
Được đăng

changed the html to use object/embed in place of iframe. No change in behavior of FF 13.0.1

changed the html to use object/embed in place of iframe. No change in behavior of FF 13.0.1
Tristanva 0 giải pháp 1 câu trả lời
Được đăng

I have the same problem since updating to the latest flash version (including on youtube.com pages of video's which do not put the flash in an iframe) . I assume downgrading flash would solve the problem, but aren't there known vulnerabilities in the previous version? Would rather deal with this annoyance until it's solved then leave my pc vulnerable.

I have the same problem since updating to the latest flash version (including on youtube.com pages of video's which do not put the flash in an iframe) . I assume downgrading flash would solve the problem, but aren't there known vulnerabilities in the previous version? Would rather deal with this annoyance until it's solved then leave my pc vulnerable.

Được chỉnh sửa bởi Tristanva vào

dblatnik 1 giải pháp 19 câu trả lời
Được đăng

Funny, but the "it's not our fault, it's the other guy's fault" is what I always hear from software support. ALWAYS. Usually right before I give up and find an alternative product.

This worked fine last week.

I installed 13.0.1 - as recommended - and it doesn't work. And it is the other guy's problem?

Funny, but the "it's not our fault, it's the other guy's fault" is what I always hear from software support. ALWAYS. Usually right before I give up and find an alternative product. This worked fine last week. I installed 13.0.1 - as recommended - and it doesn't work. And it is the other guy's problem?
jscher2000
  • Top 10 Contributor
8758 giải pháp 71663 câu trả lời
Được đăng

Hi dblatnik, I visited http://wheelgun.blogspot.com/ and I do not see the problem. Have you gotten reports from a lot of other users?

If you haven't already, could you try disabling graphics hardware acceleration? Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You probably need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

Then restart Firefox.

Hi dblatnik, I visited http://wheelgun.blogspot.com/ and I do not see the problem. Have you gotten reports from a lot of other users? If you haven't already, could you try disabling graphics hardware acceleration? Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You probably need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). orange Firefox button ''or'' classic Tools menu > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" Then restart Firefox.
jscher2000
  • Top 10 Contributor
8758 giải pháp 71663 câu trả lời
Được đăng

Hi Tristanva, yes, there are known vulnerabilities in Flash 11.2. If you can't get Flash 11.3 to work (see Flash 11.3 doesn't load video in Firefox), you could drop back to Flash 10.3, which is up-to-date with security patches. I have to admit I don't know the differences between the "Debugger" and "Projector" versions available here: http://www.adobe.com/support/flashplayer/downloads.html#fp10.3

Hi Tristanva, yes, there are known vulnerabilities in Flash 11.2. If you can't get Flash 11.3 to work (see [[Flash 11.3 doesn't load video in Firefox]]), you could drop back to Flash 10.3, which is up-to-date with security patches. I have to admit I don't know the differences between the "Debugger" and "Projector" versions available here: http://www.adobe.com/support/flashplayer/downloads.html#fp10.3
dblatnik 1 giải pháp 19 câu trả lời
Được đăng

Well, after assuring me it was the other guy's problem, it turns out it was your problem after all.

Disabling hardware acceleration in settings/advanced/general seems to have solved the problem.

Well, after assuring me it was the other guy's problem, it turns out it was your problem after all. Disabling hardware acceleration in settings/advanced/general seems to have solved the problem.

Được chỉnh sửa bởi dblatnik vào

jscher2000
  • Top 10 Contributor
8758 giải pháp 71663 câu trả lời
Được đăng

Hi dblatnik, cor-el actually suggested this in the first reply above, but it was easy to miss amongst the suggestions. Sometimes updating graphics drivers helps, since the testers generally used the latest drivers they could get. However, if you aren't trying to render a lot of 3D, it's simpler just to disable the feature and not rock the boat at the system driver level.

Hi dblatnik, cor-el actually suggested this in the first reply above, but it was easy to miss amongst the suggestions. Sometimes updating graphics drivers helps, since the testers generally used the latest drivers they could get. However, if you aren't trying to render a lot of 3D, it's simpler just to disable the feature and not rock the boat at the system driver level.
cor-el
  • Top 10 Contributor
  • Moderator
17527 giải pháp 158478 câu trả lời
Được đăng

Giải pháp được chọn

See https://www.adobe.com/support/security/index.html#flashplayer
dblatnik 1 giải pháp 19 câu trả lời
Được đăng

No Cor-el suggested disabling hardware acceleration in Flash.

I had to disable hardware acceleration in Firefox.

These are NOT the same actions.

No Cor-el suggested disabling hardware acceleration in Flash. I had to disable hardware acceleration in Firefox. These are NOT the same actions.
jscher2000
  • Top 10 Contributor
8758 giải pháp 71663 câu trả lời
Được đăng

No Cor-el suggested disabling hardware acceleration in Flash.

Sorry for the confusion, I meant his first reply directly to you ("Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem").

Anyway, you're good now.

''No Cor-el suggested disabling hardware acceleration in Flash.'' Sorry for the confusion, I meant his first reply directly to you ("Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem"). Anyway, you're good now.
DaMorgue 0 giải pháp 1 câu trả lời
Được đăng

Câu trả lời hữu ích

I worked around this issue by adding query string ?wmode=opaque to the end of the URL in the iframe'd YouTube video. This will solve it for end-users whereas the workaround of disabling HWA cannot be done on the users behalf (obviously). Hope this helps

I worked around this issue by adding query string ?wmode=opaque to the end of the URL in the iframe'd YouTube video. This will solve it for end-users whereas the workaround of disabling HWA cannot be done on the users behalf (obviously). Hope this helps
Sudowudo 0 giải pháp 2 câu trả lời
Được đăng

I also have this problem, it seems to affect Youtube embedded videos more than anything else, other Flash video players like jwplayer are fine.

I have also noticed that it happens most often with autoscrolling enabled but it doesn't happen if you also enable smooth scrolling (which I cant stand so I'm not using that). It also doesn't happen with Flash 11.2 but does happen with Flash 11.3

There is definitely a problem between Firefox and Flash.

I also have this problem, it seems to affect Youtube embedded videos more than anything else, other Flash video players like jwplayer are fine. I have also noticed that it happens most often with autoscrolling enabled but it doesn't happen if you also enable smooth scrolling (which I cant stand so I'm not using that). It also doesn't happen with Flash 11.2 but does happen with Flash 11.3 There is definitely a problem between Firefox and Flash.
sterose 0 giải pháp 3 câu trả lời
Được đăng

I had this problem immediately after my update to FF 13.0.1, so I disabled hardware acceleration in Firefox. I also turned off auto scrolling and smooth scrolling. The problem was solved immediately.

Don't muck about with old versions of Flash: just change some options in the browser.

I had this problem immediately after my update to FF 13.0.1, so I disabled hardware acceleration in Firefox. I also turned off auto scrolling and smooth scrolling. The problem was solved immediately. Don't muck about with old versions of Flash: just change some options in the browser.

Được chỉnh sửa bởi sterose vào

El Mexicano 0 giải pháp 5 câu trả lời
Được đăng

Now I've tried the latest 11.3.300.265 version with the latest 14.0.1 FF version, and the problem is still present. I've also tried the 11.4... Beta of Flash Player, but nothing has changed. Now I'll try it disabling smooth scroll and let's see...

UPDATE: Disabling smooth scrolling hasn't helped either. Turned back to FP 11.2...

Now I've tried the latest 11.3.300.265 version with the latest 14.0.1 FF version, and the problem is still present. I've also tried the 11.4... Beta of Flash Player, but nothing has changed. Now I'll try it disabling smooth scroll and let's see... UPDATE: Disabling smooth scrolling hasn't helped either. Turned back to FP 11.2...

Được chỉnh sửa bởi El Mexicano vào