Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Stop Search Suggestions in the Awesome Bar

  • 4 trả lời
  • 1 gặp vấn đề này
  • 2186 lượt xem
  • Trả lời mới nhất được viết bởi Bulldogger

more options

Google is my default search engine. I followed the instructions to turn off Search Suggestions in Firefox 13. Unfortunately, this only seems to work if I search from the Search Bar. If I search from the Awesome Bar, which I prefer, Search Suggestions still appear. Can I prevent search suggestions from the Awesome Bar as well? I can do this in Google Chrome - please tell me I can do it in Firefox!

The way to do this in Chrome is enter the following URL as your default search engine:

https://www.google.com/search?hl=en&complete=0&site=webhp&q=%s&btnK=Google+Search

I don't see a way to do this in Firefox 13. BTW, the above URL also prevents Google Autocomplete and Google Instant.

Giải pháp được chọn

ok, thanks for clarifying - you can enter about:config into the locationbar and search for the preference named keyword.url. doubleclick & set it to https://www.google.com/search?hl=en&complete=0&site=webhp&q= - this should also redirect searches from the firefox location bar to the google version without suggestions.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (4)

more options

hello the suggestions on the awesomebar are suggestions by your bookmarks & history & shouldn't be provided by google. you can disable those in firefox/tools > options > privacy > location bar - suggest nothing...

more options

My Firefox options already include "Suggest nothing". What I am seeing does not come from my Bookmarks or History. These are Search Suggestions. Please see the attachment.

more options

Giải pháp được chọn

ok, thanks for clarifying - you can enter about:config into the locationbar and search for the preference named keyword.url. doubleclick & set it to https://www.google.com/search?hl=en&complete=0&site=webhp&q= - this should also redirect searches from the firefox location bar to the google version without suggestions.

Được chỉnh sửa bởi philipp vào

more options

That solved it. Thank you.