Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How do I get Firefox to quit on shut down on my Mac? At the moment I have to force shut down.

  • 6 trả lời
  • 14 gặp vấn đề này
  • 12 lượt xem
  • Trả lời mới nhất được viết bởi bluemuppet

more options

I have an iMac and I am running 10.4.6 I am running Firefox 3.6.26

My problem is, when I go to shut down my computer, Firefox will not quite, so I have to force Firefox to quit. It will not quit when I click on quit.


Before this problem started, Firefox would quit when I clicked on Shut down.

Any ideas on how to fix this problem.

Giải pháp được chọn

No problems, glad its all sorted.

Its a shame to lost your history, hopefully you recovered your bookmarks though. If not, I recommend trying something like FF built in sync, or for older versions an add-on like Xmarks to backup your bookmarks.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (6)

more options

Well, i'm no expert at this, so be careful when trying my advice.

  1. In your URL bar type 'about:config' (without the ' ')
  2. Click to agree
  3. Filter for browser.warnOnQuit and change the value to false.
  4. Filter for browser.showQuitWarning and change the value to false.
  5. Restart Firefox

I'm not sure if this will work for you, or if there is an easier way, but worth a try.

Được chỉnh sửa bởi bluemuppet vào

more options

Hi. 1. In your URL bar type 'about:config' (without the ' ') — This got me in OK. 2. Click to agree. — I was not asked to do this. 3. Filter for browser.warnOnQuit and change the value to false. I found this in the list ok, then went looking for No.4, before making any changes. 4. Filter for browser.showQuitWarning and change the value to false. — I could not find this in the list. 5. Restart Firefox. — Not being able to find No. 4 in the list, I did not make any changes, so I back-peddled instead of restarting.

Many thanks for your help. David.

more options

Additional info.

I spend quite a lot of time on the internet, and somehow that slows down my Apple iMac computer along with most of the programs that I have installed, especially AppleWorks 6, so around every 8 to 9 months I trash and reinstall both the system and AppleWorks 6. This always fixes the problem. Everything is back to running at full speed again, but this is the first time that Firefox has played up, so the problem could be in one of the updates Firefox has put out over the past 9 or so months. — Just a thought. David.

more options

Glad it all worked out in the end. Some of my instructions may not have applied because you are using an old version of FF and Mac OS X. I am on 10.7.3 and FF 10.0, so could only work with what i had :)

more options

Hi. After a few more hassells, I decided the best thing to do was to trash Friefox and reinstall. Lost all my history in doing so, but everything is working as it should now. Firefox closes now without any problems when I ask the computer to shut down.

Thanks for all the help. David.

more options

Giải pháp được chọn

No problems, glad its all sorted.

Its a shame to lost your history, hopefully you recovered your bookmarks though. If not, I recommend trying something like FF built in sync, or for older versions an add-on like Xmarks to backup your bookmarks.