Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

autocomplete not working

  • 3 trả lời
  • 19 gặp vấn đề này
  • 1226 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

Location bar autocomplete

As described at this link -


“The location bar is often called the Awesome Bar because it’s great at remembering websites you’ve been to and guessing where you are trying to go. Just type a few letters of a website’s name or address into the location bar and it will find it for you. And the more you use it, the better it gets. This article covers the details of how the location bar works and will have you using it like a pro in no time.”

This feature is not working at all. I’ve tried many domains that are in my history and bookmarks, and none will autocomplete and I always am forced to type out the full domain names every time.

An extra 5 minutes every day of typing the entire URLs is 1,800 minutes a year, which comes out to be 30 hours or the difference between a week of working or vacation.

Even if you spend 2 minutes a day typing out URLs, that's 12 hours a year - a full day and a half of work per year - and a week of work every 3 years.

It's actually more that typing in the domain. I have to type in the domain, then navigate to the page that I want within the site. For example, if I want a product page I was at at Amazon, instead of going right to it, I have to go to Amazon, then conduct a full search for the item, then scan to find it and then go to it.

Auto-complete normally should show all the pages at a site I've been to and I can click the one I want and go right there.

I’m going to have to stop using Firefox until auto-complete (sometimes called auto-fill, though I think autofill is actually for filling in forms). I can’t afford nearly a week a year in lost time.

I've done all the steps that the Firefox help pages say to do for turning it on in preferences options, and they don't work.

Tất cả các câu trả lời (3)

more options

Won't work if you don't retain your history

Additional references:

more options

Yes, I've retained my history and I also have bookmarks and it still doesn't work. It has not worked for quite some time, and I'm not using Safari, Sea Monkey and Chrome. If Firefox fixes the bug / problem, I will return to using it, but I can't lose about 2 days of time per year. I'd rather take a 4-day weekend instead, or do anything else with that time other than repetitively type domain names. It's not a cutting edge feature or anything, and it's such a basic, simple technology they really should get it to work.

more options

Make sure that the Location Bar is not set to "Nothing":

  • Firefox > Preferences > Privacy > Location Bar: When using the location bar, suggest: History, Bookmarks, History and Bookmarks

A possible cause is a problem with the file places.sqlite that stores the bookmarks and the history.

Được chỉnh sửa bởi cor-el vào