X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

rollovers not working in Firefox 7 on Lion OS

Được đăng

I have just installed Firefox 7 on my new iMac that is running on Lion OS 10.7.2 and found that all hover states (rollovers) do not work here at all, i dun get dropdown menus or css colour change on any of my own websites or on other websites. I did move some of my profile files from the old iMac into the new one and everything else works fine. it also works on my old iMac which is running on Snow Leopard OS. but i have notice that its really slow on my Snow Leopard iMac and often just hangs on random pages for no reason.

Can someone tell me what i should do? I have tried moving the whole profile folder for the old iMac, when that did work, i started a new profile and move the recommended files only as shown on here http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox. and it still doesn't work. Help please.

I have just installed Firefox 7 on my new iMac that is running on Lion OS 10.7.2 and found that all hover states (rollovers) do not work here at all, i dun get dropdown menus or css colour change on any of my own websites or on other websites. I did move some of my profile files from the old iMac into the new one and everything else works fine. it also works on my old iMac which is running on Snow Leopard OS. but i have notice that its really slow on my Snow Leopard iMac and often just hangs on random pages for no reason. Can someone tell me what i should do? I have tried moving the whole profile folder for the old iMac, when that did work, i started a new profile and move the recommended files only as shown on here http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox. and it still doesn't work. Help please.

Giải pháp được chọn

I am having this problem in OS/X Lion with all browsers, not just Firefox, can we do some testing some of you to confirm that you might be having the same issue in other browsers? I have tested this in Opera, Firefox, Safari, & Chrome... all four had the same problem when it cropped up. A computer restart fixes it for a time, seems to happen randomly in OS/X Lion.

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Điều này đã xảy ra

Bất cứ khi nào Firefox được mở lên

Điều này bắt đầu khi...

Since the beginning

Phần bổ trợ đã cài đặt

  • Shockwave Flash 11.0 r1
  • DivX VOD Helper Plug-in
  • DivX Web Player version 2.1.2.265
  • LogMeIn remote control components
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 4.0.60531.0
  • Microsoft Office for Mac SharePoint Browser Plug-in

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

Thông tin chi tiết

cor-el
  • Top 10 Contributor
  • Moderator
17580 giải pháp 159060 câu trả lời
Được đăng

Are that CSS hover states or are they done via JavaScript ?

Is any other content missing?

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).

Are that CSS hover states or are they done via JavaScript ? Is any other content missing? Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).

Người tạo câu hỏi

css and jquery... there's really no point in a screenshot coz there's no hover state happening at all - no cursor change, no hover state, no dropmenu.

attached is a screenshot of Firefox on the left and Safari on the right and how the hover state is suppose to look like, but i get nothing when i do the same on Firefox. Main menu items on the sample site has no links to another page, only hover states to drop the submenus down, which only happen when i click on them in Firefox 7. that's not the right behaviour, its suppose to happen on hover not on click.

I have no such problems on my old Mac which is running on the same Firefox 7 and Snow Leopard OS. My new 1-week-old mac is using Lion OS 10.7.2, and its only happening here. And its not just this sample website http://www.modahotel.ca/, its all the websites i build and even this mozilla site, eg. on the top of this page, the mozilla menu items has a underline for its hover state right? well, i don't see it on this new mac on FF, only on Safari, and on FF on my old mac.

I have tried everything from downloading a new copy of Firefox, deleting my profile and starting with a blank one, copying ALL the files from my old profile on my old mac, and replacing only recommended files only as shown on here http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox into the new profile. nothing works :(

css and jquery... there's really no point in a screenshot coz there's no hover state happening at all - no cursor change, no hover state, no dropmenu. attached is a screenshot of Firefox on the left and Safari on the right and how the hover state is suppose to look like, but i get nothing when i do the same on Firefox. Main menu items on the sample site has no links to another page, only hover states to drop the submenus down, which only happen when i click on them in Firefox 7. that's not the right behaviour, its suppose to happen on hover not on click. I have no such problems on my old Mac which is running on the same Firefox 7 and Snow Leopard OS. My new 1-week-old mac is using Lion OS 10.7.2, and its only happening here. And its not just this sample website http://www.modahotel.ca/, its all the websites i build and even this mozilla site, eg. on the top of this page, the mozilla menu items has a underline for its hover state right? well, i don't see it on this new mac on FF, only on Safari, and on FF on my old mac. I have tried everything from downloading a new copy of Firefox, deleting my profile and starting with a blank one, copying ALL the files from my old profile on my old mac, and replacing only recommended files only as shown on here http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox into the new profile. nothing works :(

Được chỉnh sửa bởi an_mew vào

Người tạo câu hỏi

help please

help please

Được chỉnh sửa bởi an_mew vào

cor-el
  • Top 10 Contributor
  • Moderator
17580 giải pháp 159060 câu trả lời
Được đăng

It looks that at least the imported CSS file stylesheets/menu.css isn't working.

Opening the menu is done via CSS, the coloring is done via JavaScript.

Does at least the hover work if you disable JavaScript after the page has loaded?


/* 2nd Menu */
ul#menu-main-menu ul a {
	margin: 0;
	padding: 5px 10px;
	display: block;
	color: #ffffff;
	text-transform: none;
	letter-spacing: 0;
	background: #000000;
	border-bottom: solid 1px #eceff4;
}

/* 2nd Menu Hover Persistence */
ul#menu-main-menu li:hover li a:hover,
ul#menu-main-menu li:hover li:hover a,
ul#menu-main-menu li.iehover li a:hover,
ul#menu-main-menu li.iehover li.iehover a {
	color: #ffffff;
	background: #9b0000 url(../images/bg_nav.gif) repeat 0 0;
}
It looks that at least the imported CSS file stylesheets/menu.css isn't working.<br /> *http://www.modahotel.ca/wp-content/themes/moda/stylesheets/menu.css Opening the menu is done via CSS, the coloring is done via JavaScript. Does at least the hover work if you disable JavaScript <u>after</u> the page has loaded? * https://support.mozilla.com/kb/JavaScript ---- <pre><nowiki>/* 2nd Menu */ ul#menu-main-menu ul a { margin: 0; padding: 5px 10px; display: block; color: #ffffff; text-transform: none; letter-spacing: 0; background: #000000; border-bottom: solid 1px #eceff4; } /* 2nd Menu Hover Persistence */ ul#menu-main-menu li:hover li a:hover, ul#menu-main-menu li:hover li:hover a, ul#menu-main-menu li.iehover li a:hover, ul#menu-main-menu li.iehover li.iehover a { color: #ffffff; background: #9b0000 url(../images/bg_nav.gif) repeat 0 0; }</nowiki></pre>

Người tạo câu hỏi

umm i don't think it has anything to do with css, imported or inline :(

as i mentioned earlier its not just the moda site (i'm just using that as a sample), its all the websites i built and every single website out there that's not working for me, even mozilla's site. none of the hover state work at all.

and nope... i tried disabling javascript in the preference like you said and there's no difference... sigh... this is so weird, never had this happen to me before :( so now i cant sell my old mac?? coz i do this for a living and i use Firefox as my main testing browser, i really need to get this fix. Anybody else out there has Firefox 7 on a mid-2011 iMac 3.4GHz Quad-Core Intel Core i7 running on Lion OS 10.7.2 that has a broken Firefox 7? or is it just me? can i downgrade to a 6? would that help? if so, where can i find the installer for the 6?

umm i don't think it has anything to do with css, imported or inline :( as i mentioned earlier its not just the moda site (i'm just using that as a sample), its all the websites i built and every single website out there that's not working for me, even mozilla's site. none of the hover state work at all. and nope... i tried disabling javascript in the preference like you said and there's no difference... sigh... this is so weird, never had this happen to me before :( so now i cant sell my old mac?? coz i do this for a living and i use Firefox as my main testing browser, i really need to get this fix. Anybody else out there has Firefox 7 on a mid-2011 iMac 3.4GHz Quad-Core Intel Core i7 running on Lion OS 10.7.2 that has a broken Firefox 7? or is it just me? can i downgrade to a 6? would that help? if so, where can i find the installer for the 6?

Người tạo câu hỏi

Cor-el thank you for taking the time to help me out here :P

Cor-el thank you for taking the time to help me out here :P
cor-el
  • Top 10 Contributor
  • Moderator
17580 giải pháp 159060 câu trả lời
Được đăng

You can try to use the DOM Inspector to see if the CSS files are loaded.

Left click the selector for the left panel > Stylesheets

You can try to use the DOM Inspector to see if the CSS files are loaded.<br /> * DOM Inspector: https://addons.mozilla.org/firefox/addon/dom-inspector-6622/ Left click the selector for the left panel > Stylesheets * https://developer.mozilla.org/En/DOM_Inspector * https://developer.mozilla.org/en/Introduction_to_DOM_Inspector

Người tạo câu hỏi

Yes they are loaded, i checked a couple of sites and they all appear to be in order and loaded. all css via "link type" or "import" are loaded when i check thru the inspector.

Yes they are loaded, i checked a couple of sites and they all appear to be in order and loaded. all css via "link type" or "import" are loaded when i check thru the inspector.

Người tạo câu hỏi

this guy is having the same problem too... https://support.mozilla.com/te/questions/885672

this guy is having the same problem too... https://support.mozilla.com/te/questions/885672
cor-el
  • Top 10 Contributor
  • Moderator
17580 giải pháp 159060 câu trả lời
Được đăng

Do you only have that mouse hover problem on those specific pages or on other pages as well?


Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

Do you only have that mouse hover problem on those specific pages or on other pages as well? ---- Create a new profile as a test to check if your current profile is causing the problems. See "Basic Troubleshooting: Make a new profile": *https://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files. See: *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Người tạo câu hỏi

all the pages on every website i go to not just my own, even mozilla site as i mentioned earlier. I have tried creating a new profile, and it also didn't work and i have also tried replacing only recommended files only as shown on here http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox into the new profile, as i mentioned in my earlier post, basically i have tried everything i can do before coming here to look for a solution, and i know it's not any of the websites that causing the problem, its Firefox 7 is not working properly on Lion OS. I'm a web designer and i know that all my css are working from before and its only the hover state that's not working on the combination of Firefox 7 and Lion OS. I don't even get a hand cursor when i mouse over any regular links (text links in the copy eg. <a href="#">text here</a>), not just css controlled ones.

I have tried submitting a feedback thru this link (http://input.mozilla.com/en-US/feedback#sad) and i couldn't even submit it as nothing happens when i click the "Submit Feedback" button.

Is there a way i can downgrade to Firefox 6 or something? i can't seem to find the installer anywhere on the Mozilla site.

all the pages on every website i go to not just my own, even mozilla site as i mentioned earlier. I have tried creating a new profile, and it also didn't work and i have also tried replacing only recommended files only as shown on here http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox into the new profile, as i mentioned in my earlier post, basically i have tried everything i can do before coming here to look for a solution, and i know it's not any of the websites that causing the problem, its Firefox 7 is not working properly on Lion OS. I'm a web designer and i know that all my css are working from before and its only the hover state that's not working on the combination of Firefox 7 and Lion OS. I don't even get a hand cursor when i mouse over any regular links (text links in the copy eg. <a href="#">text here</a>), not just css controlled ones. I have tried submitting a feedback thru this link (http://input.mozilla.com/en-US/feedback#sad) and i couldn't even submit it as nothing happens when i click the "Submit Feedback" button. Is there a way i can downgrade to Firefox 6 or something? i can't seem to find the installer anywhere on the Mozilla site.
cor-el
  • Top 10 Contributor
  • Moderator
17580 giải pháp 159060 câu trả lời
Được đăng

Submit on that page may not work if your message is too long.

Submit on that page may not work if your message is too long.

Người tạo câu hỏi

Hi Cor-el,

I have just tried re-installing Firefox by deleting it and re-downloading it, then without opening, i did as you suggest in creating a new profile, so its bare bones with no add-ons or extensions... it still broken, didn't work, i even restart the computer to make sure its not because of that. My other friend has a new Airbook with Lion as well and his Firefox 7 is bare bones but it works fine for him. So i really do not know what the issue is now.

back to my other question... is there a way i can downgrade? i cant seem to find a Firefox 6 installer on the Mozilla site. At least if everything works on FF 6 i can still use it for work until the problem with my 7 goes away, i just don't know how to make it go away!!

Thanks!

Hi Cor-el, I have just tried re-installing Firefox by deleting it and re-downloading it, then without opening, i did as you suggest in creating a new profile, so its bare bones with no add-ons or extensions... it still broken, didn't work, i even restart the computer to make sure its not because of that. My other friend has a new Airbook with Lion as well and his Firefox 7 is bare bones but it works fine for him. So i really do not know what the issue is now. back to my other question... is there a way i can downgrade? i cant seem to find a Firefox 6 installer on the Mozilla site. At least if everything works on FF 6 i can still use it for work until the problem with my 7 goes away, i just don't know how to make it go away!! Thanks!

Được chỉnh sửa bởi an_mew vào

[de.la.media] 1 giải pháp 2 câu trả lời
Được đăng

Giải pháp được chọn

I am having this problem in OS/X Lion with all browsers, not just Firefox, can we do some testing some of you to confirm that you might be having the same issue in other browsers? I have tested this in Opera, Firefox, Safari, & Chrome... all four had the same problem when it cropped up. A computer restart fixes it for a time, seems to happen randomly in OS/X Lion.

I am having this problem in OS/X Lion with all browsers, not just Firefox, can we do some testing some of you to confirm that you might be having the same issue in other browsers? I have tested this in Opera, Firefox, Safari, & Chrome... all four had the same problem when it cropped up. A computer restart fixes it for a time, seems to happen randomly in OS/X Lion.

Được chỉnh sửa bởi [de.la.media] vào

bk1231 0 giải pháp 1 câu trả lời
Được đăng

I am having this problem at work on an iMac that came pre-installed with Lion and I installed Firefox 7. I also have a Mini at home which was already running Firefox 7, then upgraded to Lion and Firefox does not have this problem. Not sure what this means but hopefully someone will find the info helpful.

I am having this problem at work on an iMac that came pre-installed with Lion and I installed Firefox 7. I also have a Mini at home which was already running Firefox 7, then upgraded to Lion and Firefox does not have this problem. Not sure what this means but hopefully someone will find the info helpful.