X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

how do i change the find feature search engine back to google. it's on search amazon.com at the moment.

Được đăng

when i highlight a word or sentance of text on a page, then right click ,a box pops up with copy, select all, search amazon.com for, view selection source,

i'd like to change back to" search google for" instead of amazon.com.... i don't recall changing it to amazon, but i could be wrong when i set up ff4 on my computer. thanks!

when i highlight a word or sentance of text on a page, then right click ,a box pops up with copy, select all, search amazon.com for, view selection source, i'd like to change back to" search google for" instead of amazon.com.... i don't recall changing it to amazon, but i could be wrong when i set up ff4 on my computer. thanks!

Được chỉnh sửa bởi ripjack13 vào

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Garmin Communicator Plug-In 2.9.3.0
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • 1.9.0042.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.6
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r159
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60310.0
  • Office Live Update v1.5
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 GTB5 (.NET CLR 3.5.30729) FBSMTWB

Thông tin chi tiết

Xircal 334 giải pháp 3835 câu trả lời
Được đăng

Câu trả lời hữu ích

To revert to Google as your preferred search engine, please do the following.

  • In the location bar, type about:config and hit Enter.

  • In the filter at the top, type: keyword.URL

  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the orange Firefox button and go to Options | Options | General (Firefox 4.0.x and above).

  • Go to Tools | Options | General (Previous version of Firefox).

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

To revert to Google as your preferred search engine, please do the following.<br><br> * In the location bar, type '''about:config''' and hit Enter.<br><br> * In the filter at the top, type: '''keyword.URL'''<br><br> * Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=<br><br> The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing. ---- '''To reset your home page, do the following'''.<br><br> * Go to the site you want to set as your homepage.<br><br> * Click the orange Firefox button and go to '''Options '''| '''Options '''| '''General''' (Firefox 4.0.x and above).<br><br> * Go to '''Tools '''| '''Options '''| '''General''' (Previous version of Firefox).<br><br> * Make sure it says "''Show My Homepage''" in the first dropdown menu.<br><br> * Click the button called "'''Use Current Pages'''" to set the homepage to the one you have on the screen.<br><br> After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

Người tạo câu hỏi

ok. i did all that.

i cut and pasted the "about:config" and it brought up a page that said... "this might void your warranty. changing these advanced settings can be harmful to the stability,security,and performance of this application. you should continue only if you are sure of what you are doing." then it has a box where it says.

ok, i'll be careful.

so i clicked it and it brought me to a page with "preference name, status, type, name" then in the filter i put "keyword.URL" hit enter and saw the word amazon.com and double clicked it and a box came up and in it i put..http://www.google.com/search?q= and hit enter and it still was the same... so i restarted FF and did the same until i got to the page where it says filter. it brought up the same page, but then i saw down below on the page " CT2418367>SearchEngine " so i clicked on that and it brought up the same "box" so i entered http://www.google.com/search?q= into the box hit enter clicked out and went to a page , highlighted some text, right clicked and it's still bringing up amazon.com.

am i doing it right? or am i missing something?

ok. i did all that. i cut and pasted the "about:config" and it brought up a page that said... "this might void your warranty. changing these advanced settings can be harmful to the stability,security,and performance of this application. you should continue only if you are sure of what you are doing." then it has a box where it says. ok, i'll be careful. so i clicked it and it brought me to a page with "preference name, status, type, name" then in the filter i put "keyword.URL" hit enter and saw the word amazon.com and double clicked it and a box came up and in it i put..http://www.google.com/search?q= and hit enter and it still was the same... so i restarted FF and did the same until i got to the page where it says filter. it brought up the same page, but then i saw down below on the page " CT2418367>SearchEngine " so i clicked on that and it brought up the same "box" so i entered http://www.google.com/search?q= into the box hit enter clicked out and went to a page , highlighted some text, right clicked and it's still bringing up amazon.com. am i doing it right? or am i missing something?

Được chỉnh sửa bởi ripjack13 vào

cor-el
  • Top 10 Contributor
  • Moderator
17691 giải pháp 160067 câu trả lời
Được đăng

Câu trả lời hữu ích

What is the default search engine?

You can check the pref browser.search.defaultenginename instead.

You can open the about:config page via the location bar and do a search for amazon via the Filter at the top of that page.
You can reset amazon related prefs via the right-click context menu to their default values.

What is the default search engine? You can check the pref browser.search.defaultenginename instead. You can open the <b>about:config</b> page via the location bar and do a search for <i>amazon</i> via the Filter at the top of that page.<br /> You can reset <i>amazon</i> related prefs via the right-click context menu to their default values.

Người tạo câu hỏi

you know when i you right click and hold it to highlight some text? then right click again and then it brings up a box that says copy, select all, search"....." for ..., view selection source

that's the box i'm talking about. it used to be "search google for" but since i updated firefox to the newest version it now says "search amazon.com for"

i pasted browser.search.defaultenginename into "filter" and it shows ask.com ..(that's wrong too i hate ask.com). so i'll see what happens when i put http://www.google.com/search?q= in it's place...

you know when i you right click and hold it to highlight some text? then right click again and then it brings up a box that says copy, select all, search"....." for ..., view selection source that's the box i'm talking about. it used to be "search google for" but since i updated firefox to the newest version it now says "search amazon.com for" i pasted browser.search.defaultenginename into "filter" and it shows ask.com ..(that's wrong too i hate ask.com). so i'll see what happens when i put http://www.google.com/search?q= in it's place...

Được chỉnh sửa bởi ripjack13 vào

Người tạo câu hỏi

hmmm.. still the same.

hmmm.. still the same.
cor-el
  • Top 10 Contributor
  • Moderator
17691 giải pháp 160067 câu trả lời
Được đăng

You only need to paste the name Google in that pref and not the URL to use.
Firefox looks for a search engine with that name and uses it.
Click the search engine icon on the search bar to see the names or open Manage Search Engines.

Are there any prefs that show if you filter for amazon ?

You only need to paste the name Google in that pref and not the URL to use.<br /> Firefox looks for a search engine with that name and uses it.<br /> Click the search engine icon on the search bar to see the names or open Manage Search Engines. Are there any prefs that show if you filter for amazon ?

Người tạo câu hỏi

yay!!! i didn't have the search bar on. so i dragged and dropped it up to the other bar. then did this...

"Click the search engine icon on the search bar to see the names or open Manage Search Engines. "

and that's where i saw amazon.com so i deleted it! then put google up top and tadah! all fixed. many thanx to you kind cor-el! +1 solution for you.

yay!!! i didn't have the search bar on. so i dragged and dropped it up to the other bar. then did this... "Click the search engine icon on the search bar to see the names or open Manage Search Engines. " and that's where i saw amazon.com so i deleted it! then put google up top and tadah! all fixed. many thanx to you kind cor-el! +1 solution for you.
cor-el
  • Top 10 Contributor
  • Moderator
17691 giải pháp 160067 câu trả lời
Được đăng

You're welcome

You're welcome
everett1a 0 giải pháp 3 câu trả lời
Được đăng

dont be afraid to do this, do it exactly as stated. it works. Thanks for the post.

dont be afraid to do this, do it exactly as stated. it works. Thanks for the post.