Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Who can fix the fact that an apostrophe does not render?

  • 14 trả lời
  • 34 gặp vấn đề này
  • 2105 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I have been bugged by this for years and finally decided to do something about it. According to my Google search, this is a well known problem for many of us, and I cannot figure why Firefox has not done something about it.

Using Firefox 3.6 on my PC, the apostrophe does not render consistently.

If I write text for my web page using the standard key to the right of the semicolon ( the apostrophe, i.e., ‘), I then upload to my website with FTP and view the result: The text at that point usually appears as the square with a question mark, indicating that the code does not exist. This also happens on other source’s pages, but here I think I know the source of the apostrophe.

The Google results suggest work-arounds, but Firefox’s inability to render the apostrophe simply should not happen. Reading the same page as above on Internet Explorer shows the apostrophe correctly. So this is clearly a Firefox problem. Who can fix it?

Tất cả các câu trả lời (14)

more options

Just because something works in Internet Explorer doesn't make it right. There is a specific character code to use for displaying the apostrophe character.
http://www.w3.org/MarkUp/html-spec/html-spec_13.html

more options

With all respect, I do not think that is the answer. First, look at common sites like http://en.wikipedia.org/wiki/Main_Page or http://finance.yahoo.com/?u. They do not use a special character for the apostrophe; yet it shows on my screen as desired. Second, it should not be incumbent on the author of a web page to give special treatment to such a common character as the apostrophe. Third, even though there IS a special code for the ampersand (&), using the symbol, &, instead of ∧ still renders & on my screen - - why should the apostrophe cause so much trouble?

more options

Can you post a link to a page where you see that problem?

Did you check the page source via "View > Page Source" or the (re)generated page via the right-click context menu after selecting the text?

Which encoding is used to create those pages and what is send by the server?

  • Tools > Page Info > General

Được chỉnh sửa bởi cor-el vào

more options

The annoying thing is that the problem is not consistent. A page giving me the square with a question mark yesterday now renders the apostrophe. But I’m not dreaming. Look for example at these contributions: (1) http://css-tricks.com/forums/discussion/7137/apostrophe-doesn-t-render/p1 The response in that forum was: use the special character; that is, “replace the apostrophe in your html with &_ # 3 9;” [where I’ve added space to see the symbols, not the transcription] which again throws the responsibility for the problem onto the web site author.

And this general problem about rendering in Firefox; (2) http://superuser.com/questions/59734/why-does-firefox-not-render-some-characters

And this problem in SharePoint, likewise inconsistent: (3) http://social.msdn.microsoft.com/Forums/en/sharepoint2010general/thread/466532d6-952d-4ad2-bdfb-8956da69224d

And here is someone with the problem in Google Voice: (4) http://www.google.com/support/forum/p/voice/thread?tid=572bfc08a52b8567&hl=en

. . . The problem seems to relate to character sets. Does Firefox assume some character set if the web page does not specify one? Just as a wild guess, the assumed character set might change according to browsing history. But that is wild. I presume that Firefox has not fixed the problem because it is so difficult.

more options

Some pages may use special Unicode quotes: http://en.wikipedia.org/wiki/Quotation_mark

more options

As of today, PART of this web page shows the despised ?-square in place of the apostrophe:

http://www.electricscotland.com/webclans/m/montgom2.html

To elaborate, as I read the “page source,” no character set is specified for the page. Part way down, there is a contribution [additional information] using "< span lang="en-gb" >" in which the apostrophe does not render.

more options

And I just looked at the same page with Internet Explorer. The apostrophes render correctly where Firefox breaks down. If IE can do it, why can't FF?

more options

I assume that you mean: “Montgomerie”

That are Unicode quotes: &#x201c;Montgomerie&#x201d; - &ldquo;Montgomerie&rdquo;
They display for me although the page is send as ISO-8859-1

Được chỉnh sửa bởi cor-el vào

more options

OK, cor-el, so even if they are Unicode, should not Firefox work?

more options

Are they working on this page? “Montgomerie”

If they aren't working then there is a problem with the font that is used on that particular website.
As a test you can also try to disable the website fonts and if that still doesn't work then try a different default font like Verdana.

  • Tools > Options > Content : Fonts & Colors > Advanced > [ ] "Allow pages to choose their own fonts, instead of my selections above"
more options

I’m afraid we are on different wave lengths. It is not just my problem As illustrated by my quoting web sites, many others see the apostrophe problem. As I said in my first post, there are work-arounds for the problem. My point is that the inconsistent rendering of the apostrophe is a 'Firefox problem' and Firefox should do something about it. I just do not know how to reach the technical staff of Firefox who should fix it. As I’ve said, Internet Explorer seems to overcome the apostrophe problem; so the inconsistencies in how web pages are written should not create an insurmountable obstacle. My question is who within Firefox can fix it.

more options

You didn't answer if you see the quotes on this page: (‘ ’ “ ”)

If you do not see them then you definitely have a font problem and you should check your fonts.

more options

I see all your quotes, cor-el, and that is not the point.

more options

If you can see them here, but not on other websites then that would suggest a problem with the font that is used on the other website(s).

As a test you can try to disable the website fonts and if that still doesn't work then try a different default font like Verdana or Arial.

  • Tools > Options > Content : Fonts & Colors > Advanced > [ ] "Allow pages to choose their own fonts, instead of my selections above"