Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Youtube videos are blank black screen only on my firefox browser.

  • 91 trả lời
  • 2911 gặp vấn đề này
  • 342634 lượt xem
  • Trả lời mới nhất được viết bởi amplifier12

more options

I can't play any youtube videos on my firefox. All my programs are update to date. Also youtube videos are working for my internet explorer but not on my firefox. I have the latest version 3.6.13

I'm on a PC 32 bit home basic vista.

Được chỉnh sửa bởi helpthisgame vào

Giải pháp được chọn

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
Đọc câu trả lời này trong ngữ cảnh 👍 18

Tất cả các câu trả lời (20)

more options

From your Start Menu....go to your Windows Control Panel.

Find the Display Settings and click on it.

Now click on the Setting Tab.

Now click on the Advanced setting.

Click on the Troubleshoot Tab.

Move the Hardware Acceleration Bar to None.

Click on Apply and then Okay.

Your videos should play now.

more options

Youtube addresses the problem with this web page.

It worked for me.

http://www.google.com/support/youtube/bin/answer.py?&answer=1209379&src=svpromo

Được chỉnh sửa bởi letheaqua vào

more options

Come on, guys!

Deleting / blocking cookies doesn't allow us to log in.

Disabling hardware acceleration is just unacceptable, as it slows down the entire machine.

Why is Mozilla not fixing this problem they caused?

more options

Here is my particular variation on this problem. I have the 64 bit Namoroka version: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100405 Namoroka/3.6.3

The Adobe Flash Player 32 bit Plug-in will not install in Win 7 SP1 64 bit. I get the FireFox nag to download it for a YouTube video, it installs without errors, and then loops back to the Firefox install plugin prompt when I try to open the video. A Death loop.

This is a clean install of Win 7 . I already tried using the Adobe uninstaller, and reinstalling the plug in .exe setup file. All other add-on cookie and script blockers were disabled to be sure they were not the problem. Windows Firewall is not complaining about it. Installing offline and disabling Avira anti-virus did not solve this as well.

However, I could install the program without problems, and run the player in IE8 32 bit. After I did that, it put the getplusplus plug in Firefox too, but still not the Flash player plugin. Firefox is my enforced default browser.

I also tried the Adobe Square beta 64 bit for non-IE browsers. No go. It will open the file and play for 5-10 seconds, then crash. The plugin checker shows it's up to date.

This is the error log when it crashes with the 64 bit shockwave Flash plugin: Problem signature:

 Problem Event Name:	APPCRASH
 Application Name:	firefox.exe
 Application Version:	1.9.2.3666
 Application Timestamp:	4bb9c897
 Fault Module Name:	mozjs.dll
 Fault Module Version:	0.0.0.0
 Fault Module Timestamp:	4bb9b5a9
 Exception Code:	c0000005
 Exception Offset:	000000000001d87d
 OS Version:	6.1.7601.2.1.0.256.48
 Locale ID:	1033
 Additional Information 1:	16a1
 Additional Information 2:	16a1e757e85f03766a6af90b47947fc2
 Additional Information 3:	525d
 Additional Information 4:	525d9485194e3a07785d0363d0c86a65

Note: it also installed the getplusadobe plugin

File: np_gp.dll    Version: 1.6.2.99    getplusplusadobe16299

Blocking cookies and implementing the other suggestions made here did not work for me. I don't need to log in to youtube, and I'm not going to turn off hardware acceleration, as long as I can still download the video, which I can.

If this is not going to be fixed soon, I may try the Firefox 32 bit version if it can run over Win 7 SP1 64 bit

more options

Michael, clearly this problem is a lot more pervasive. I wouldn't try the effort of reverting when you know so many others have been continuing to have this annoying problem across platforms and installations.

I see we're about to hit "500 people have this problem too"

more options

I deleted my Profile file for Firefox and fixed it.

Look for it in C:\Users\<your name>\AppData\Local\Mozilla\Firefox\Profiles

more options

I had this same problem - Youtube videos would not load. I uninstalled and reinstalled Firefox, Adobe Flash, and Shockwave. Videos worked fine on IE but not Firefox. All I got was a blank black screen. Safemode and messing with extensions and plug-ins did nothing for me. Finally the fix was deleting my browsing history and cookies. This is so weird. Why did that work?

more options

I've been dealing with this problem for about a month now or at least what I believe is part of the problem. For a while now videos on YouTube have been being resized from 16:9 to 3:4, usually over toward the left of the player. But now it's going black and whenever I open a YouTube page I get a literal cascade of .css errors on my error console. But I've also found, although it may just be a coincidence, that with my error console open I have a better chance of having the video work. But as I type a comment on Youtube the insertion point is totally missing and each keystroke brings up another error, I can just sit there and watch them build up. I hope this gets fixed soon :(

more options

Hey guys, looks like the problem is in the required update that firefox had us make to Flash!

While it looked like a firefox problem alone, it's the update of flash which really screwed things up.

I reverted to flash 10.1 r53 and things started working again. Be sure to use the flash uninstaller to wipe your old flash out.

By no means is this a "solution" to the problem, but at least it identifies where the problem lies and gives the best workaround available, to date.

I still wish mozilla would get with adobe to ensure when a "suggested update" is made, it doesn't cause more problems than it cures. I also wish we could beat down adobe's website to let them know how many of us are having this problem, but at least we have some way to make it work, for now.

more options

I have the same problem yesterday morning (black screen, no play/stop buttons, no audio). It happened to all of my three browsers (Firefox 3.6.15, Chrome and IE8). I reinstalled Flash and Shockwave in BOTH Firefox and IE8, then REBOOT my PC. After that, I was able to play all YouTube videos again and still have no problem as of now. I haven't done any changes in my hardware acceleration, nor Adblock plus and noscript add-ons, My Shockwave Flash is 10.2r152.

If any of you still have this problems, you might try my procedures to see if that helps.

more options

I've had this problem for ages, and I finally solved it with the help of: http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-....

This solution will reset your settings to which sites you allow or deny to set cookies, display images, open popup windows and initiate extensions installation.

1. Close Firefox

2. Start >> Run >> firefox.exe -p

3. Create Profile >> Next >> Finish >> Start Firefox

4. Close Firefox

5. Go to C:\Documents and Settings\[Your User]\Application Data\Mozilla\Firefox\Profiles

6. Copy the file permissions.sqlite from the new profile folder to the original profile folder

7. Start Firefox

more options

(edit: accidental post)

Được chỉnh sửa bởi Guy... vào

more options

(edit: accidental post)

Được chỉnh sửa bởi Guy... vào

more options

Guy, I don't think that will work for most of those who have this problem.

We just have to wait for a Flash update which fixes it.

more options

Hey! The new 10.2.153.1 Flash seems to have fixed this problem! Yay!

I upgraded it and things ran, so I allowed Firefox to upgrade to 3.6.16, and it STILL WORKED!

So, at long last, problem solved! (Until the next upgrade which screws it up again - lol)

more options

1. Right-click on the video player and select setting.

2. Uncheck Hardware acceleration and refresh the page.

This is only a temporary fix until development publishes an update to fix this issue.

more options

The only useful way to solve this problem is Delete cookies & cache = = or You can browse youtube in private browsing ... I don't know why the cookies bother so much ...

more options

Was a change to the youtube source, i have Fx 5.0 the latest flash and a hardware acceleration enabled and play all videos fine. Today only get a black screen, if i change the protocol to htpps almost all videos plays.

more options

I downloaded mozilla firefox again then restarted my computer right after.

I also downloaded safari so i could watch youtube videos if that makes a difference in the outcome.

more options

None of the solutions posted worked for me but they surely consumed a lot of my time.....

I read on another forum that adding s after the http would work. It did. I can now see the videos on YouTube.com instead of the solid black box.

I have no idea why the problem arose as I'd changed nothing.

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5