Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How do I restore tab behavior back to the way it was in FF 3.5??

  • 5 trả lời
  • 43 gặp vấn đề này
  • 163 lượt xem
  • Trả lời mới nhất được viết bởi Helper7677

more options

I just upgraded to FF 3.6.13, I generally wait to upgrade until any new bugs have been identified and corrected. In FF 3.5, when I opened a new tab from a link, the new tab appeared to the right of the current tab (NOT at the very end of the tab bar) and the focus STAYED ON THE CURRENT TAB. If I opened multiple new tabs, they each opened to the right of the previously opened new tab, as in <original tab sequence> Yahoo Facebook GMail MyBlog <New tab sequence after opening links> Yahoo Facebook NewFBLink1 NewFBLink2 NewFBLink3 NewFBLink4 GMail MyBlog, with the focus remaining on the CURRENT TAB (in this example Facebook, from which I was opening the links). In 3.6.13, the tabs SOMETIMES open to the right of the current tab, sometimes at the end of the tab bar, and no matter how I fiddle the settings, I cannot make them CONSISTENT. Have tried the extensions 'Tab Mix Plus' and 'New Tab at End' - these do not give me consistent behavior - sometimes they do as I wish, sometimes not. In addition, sometimes the focus stays on the current tab (which is what I want) - sometimes the focus changes to the new tab just opened, sometimes it stays on the current tab until I've opened 3 or 4 new tabs, then jumps to one of the new ones. In the 'options', I do NOT have 'when I open a link in a new tab, switch to it immediately' checked; yet sometimes it does, sometimes it doesn't. HOW do I achieve consistent behavior?? This is why I don't upgrade often. Very frustrating. I have not changed any plugins, other than trying Tab Mix Plus and New Tabs at End after upgrading to 3.6.13, once I realized that the tab behavior was not consistent. How can I go back to FF 3.5 ???

Tất cả các câu trả lời (5)

more options

First of all, sometimes Extensions can interfere with one another. That MAY be the case with your using both Tab Mix Plus and New Tabs at End. They both have a function that you can set for where new tabs appear. TMP has options concerning focus on new tabs.

My suggestions are:

  1. Un-install New Tabs at End (Tools > Add-ons > Extensions, click New Tabs at End, click Uninstall, then exit and restart Firefox).
    • If using no other extension that affect where tabs appear (to the right of current tab or at end of all open tabs), a simple preference change can affect that change for you, and you have one less extension to be concerned with. I have also made this change as TMP did not have the Focus options to do this when the "new tab at end" feature first appeared or when I first started using the version of Firefox in which this feature appeared:
      1. Type about:config in the URL bar and press the Enter key.
      2. If you see the warning, accept it (promise to be careful).
      3. Filter = browser.tabs.insertRelatedAfterCurrent
      4. Look at the "Value" column (false=open at end, true=open after current tab); Value = true is the default.
      5. Double-click that preference to toggle the value from true to false, or false to true
      6. Restart Firefox (File > Restart Firefox)
      7. See: http://www.mydigitallife.info/2010/02/01/change-firefox-to-open-new-tab-at-far-right-end-of-tabbar-disable-insert-next-to-current-active-tab/
  2. Tab Mix Plus settings
    • Open the Tab Mix Plus Options (Tools > Add-ons > Extensions, click Tab Mix Plus, click Options)
    • Click on Events > Tab Opening
      1. Place a check mark before "Open new tabs next to current one"
      2. I have checked "Open other tabs next to current one"
        1. I have un-checked "Only if related to current tab"
        2. I have un-checked "Change opening order"
      3. I have checked "Open duplicated tabs next to original"
    • Click Events > Tab Focus
      1. If you ALWAYS want to stay on the current tab and let the new tabs open in the background, un-check everything. These selections will/should over-ride Tools > Options > Tabs, "When I open a link in a new tab, switch to it immediately"

See if the above changes give you the results you are seeking. Tab Mix Plus has lots of options. You may need to change one or two settings at a time until it behaves the way you desire. Keep track of the changes you make so that you can easily re-trace/re-set when the results are not what you want.

more options

Hmm, I think I have it working correctly !! I had already uninstalled the 'New Tabs at End' extension, since that was the opposite of what I wanted (but figured I'd try anyway, maybe there was an 'uncheck' box).

I think the way I had the Tab Mix Plus settings was screwing it up - I had 'Open new tabs next to current one' unchecked, thinking that the next option 'Open other tabs next to current one' and it's sub-options would do it....but that didn't work. I changed the settings to exactly what you suggested, and it seems (fingers crossed!!) to be working now the way I want it to.

I had all the 'Tab Focus' options unchecked orginally, so that was fine.

Now that it seems to be working, the name or title of each new tab is red (was black before) - not sure why, but I guess I can live with it.

Thank you very much !!!!!

more options

TMP has so many options, I had to "play" with them a bit to get things working as I wanted.

You can change tab text/background coloration in TMP options on Display > Tab >Highlight Color > Customize.

  • I have Current Tab set "Black" text, "Green" background for easy visual identification.
  • I believe the default for Unread Tabs is "Italic" (may be my setting), "Red" text, no background color. Tells you which tabs you have opened but not yet viewed.

To repeat what I said above: You may need to change one or two settings at a time until it behaves the way you desire. Keep track of the changes you make so that you can easily re-trace/re-set when the results are not what you want.

TMP support forum: http://tmp.garyr.net/forum/

Được chỉnh sửa bởi Helper7677 vào

more options

Found the tab color settings; changed one, now my tabs are back to opening crazily, and when I open them using my bookmarks (as I do all the time), they overlay each other. Sigh. Disabled TMP for the day; gotta get something done other than futzing with this. Why oh why did I upgrade??? Thanks for the link to the support forum

more options

Sorry you are having problems. Changing the color should not have affected the other settings; sounds like there is some kind of conflict somewhere in your system/setup. Did you check the other settings in TMP after changing the colors to be sure the settings are "sticking"? Have you tried exiting Firefox and restarting to see if some of the settings are changing or if the changes you intended are taking place?

Has nothing to do with the Firefox upgrade. I have successfully used TMP through upgrade after upgrade from Firefox 3.0 forward without a glitch. When updating TMP, you need to carefully review for any changes TMP made to their Extension and look for any new setting(s) they might have added.

It took me quite some time to get my settings just right. It is really difficult to diagnose a problem like this at a distance; if I could sit in front of your computer, I might be able to determine the cause(s), but that would cost you way to much.

Try posting on the TMP forum (I gave you that link above) where the "experts" on TMP might be able to assist you. The more detail you give about the problem(s) you are having in your initial post, the more likely you will get a quick resolution to the problem. You can also give them a link to this forum post for reference.

Good luck.

Được chỉnh sửa bởi Helper7677 vào