X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

do this automatically for files... not working

Được đăng

For many file types, when I click to open/download a file and I select the option "Open with: application.exe" and also select "do this automatically for files like this from now on" the open with dialog box still appears every time. If I select "Save file" and "do this automatically for files like this from now on" the dialog does not appear again and the files are automatically saved. Why am I still asked every time what I want to do when I select the "Open with: " option? How can I fix this so that the dialog does not appear and the files are automatically opened with the selected application?

For many file types, when I click to open/download a file and I select the option "Open with: application.exe" and also select "do this automatically for files like this from now on" the open with dialog box still appears every time. If I select "Save file" and "do this automatically for files like this from now on" the dialog does not appear again and the files are automatically saved. Why am I still asked every time what I want to do when I select the "Open with: " option? How can I fix this so that the dialog does not appear and the files are automatically opened with the selected application?

Chi tiết hệ thống bổ sung

Điều này đã xảy ra

Bất cứ khi nào Firefox được mở lên

Điều này bắt đầu khi...

I installed Firefox versions 3.6 to 3.6.12

Phần bổ trợ đã cài đặt

  • np-mswmp
  • Winamp Application Detector
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.1 r102
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.50917.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

Thông tin chi tiết

currently using 3.6.12

the-edmeister
  • Top 25 Contributor
  • Moderator
5420 giải pháp 40431 câu trả lời
Được đăng

http://support.mozilla.com/en-US/kb/Managing+file+types
When you click a link to download a file, the MIME type determines what action Firefox will take.

If the MIME type is mis-configured on the server where that file is being downloaded from, or is absent and a generic MIME type is being sent - Firefox will default to asking you how you want to handle that download. Firefox won't guess based on the file extension, like other browsers might (IE), Firefox lets you determine how that file is to be handled.

http://support.mozilla.com/en-US/kb/Managing+file+types <br /> '''When you click a link to download a file, the MIME type determines what action Firefox will take.''' If the MIME type is mis-configured on the server where that file is being downloaded from, or is absent and a generic MIME type is being sent - Firefox will default to asking you how you want to handle that download. Firefox won't guess based on the file extension, like other browsers might ''('''IE''')'', Firefox lets you determine how that file is to be handled.

Người tạo câu hỏi

I understand what you have said, but that is not the problem I am facing. Please re-read my post.

I understand what you have said, but that is not the problem I am facing. Please re-read my post.
the-edmeister
  • Top 25 Contributor
  • Moderator
5420 giải pháp 40431 câu trả lời
Được đăng

Do you have an example web page and download hyperlink where you have that problem?
What file types are involved?

It's far easier to see what causes a problem with a specific download link or action than it is to speculate about a general situation.

Do you have an example web page and download hyperlink where you have that problem? <br /> What file types are involved? It's far easier to see what causes a problem with a specific download link or action than it is to speculate about a general situation.

Người tạo câu hỏi

It happens with every .torrent file and every .nzb file from any site.

It happens with every .torrent file and every .nzb file from any site.
BigglesPiP 0 giải pháp 1 câu trả lời
Được đăng

Câu trả lời hữu ích

I understand that FF relies on the MIME-type on the site, but this is rarely used as far as I can tell, and it's annoying.

Is there a way I can force FF to just use the file extension like maybe IE. It's a type of guessing I'd call function.

I understand that FF relies on the MIME-type on the site, but this is rarely used as far as I can tell, and it's annoying. Is there a way I can force FF to just use the file extension like maybe IE. It's a type of guessing I'd call function.

Người tạo câu hỏi

I agree with Biggles, how can we make Firefox use extensions?

Obviously there are many flaws when relying on MIME-types.

I agree with Biggles, how can we make Firefox use extensions? Obviously there are many flaws when relying on MIME-types.
kassy 0 giải pháp 1 câu trả lời
Được đăng

I have this same problem every time I try to open a word, excel, and pdf document. I agree that FF needs to use extensions, not MIME-types.

I have this same problem every time I try to open a word, excel, and pdf document. I agree that FF needs to use extensions, not MIME-types.
anupam233 0 giải pháp 1 câu trả lời
Được đăng
http://revision3.com/filmriot/episodes large. mp4
pino1976 0 giải pháp 7 câu trả lời
Được đăng

I have finally found a solution! Just download and install this addon named mime_edit-0.601004242000.xpi and add your MIME types, e.g. RAR, AVI, WMV.... http://space.geocities.yahoo.co.jp/gl/alice0775/view/20080912/1221150790 This one is compatible with Firefox 4

I have finally found a solution! Just download and install this addon named mime_edit-0.601004242000.xpi and add your MIME types, e.g. RAR, AVI, WMV.... http://space.geocities.yahoo.co.jp/gl/alice0775/view/20080912/1221150790 This one is compatible with Firefox 4

Được chỉnh sửa bởi pino1976 vào

ZillaChilla 0 giải pháp 7 câu trả lời
Được đăng

The site: http://space.geocities.yahoo.co.jp/gl/alice0775/view/20080912/1221150790 is completely down, or at least I cannot access it.

I have FF 3.5 and would love to get hold of the MIME Edit add-on somehow.

The-Edmeister have you still got a copy of the one for FF 3.0.* + 3.7.* ?? If so could you or anyone else that still has a copy upload it to a bitlocker and send the link here?

I would also like to try this out on the latest FF 4 but am not sure if alice0775 did have one up for that version. If he/she indeed had an MIME edit FF add-on for 4.* would you The-Edmeister or anyone else that has this great add-on upload it to a bitlocker and post the link here as well?

That would be tremendously appreciated. Unfortunately the site seems to have gone off-line completely just recently and this MIME edit add-on for FF seems a real hard to find gem.

Thanks for any help towards this. Tried editing the .rdf file manually but not sure what to write exactly. Any ways, thanks for any help.

The site: http://space.geocities.yahoo.co.jp/gl/alice0775/view/20080912/1221150790 is completely down, or at least I cannot access it. I have FF 3.5 and would love to get hold of the MIME Edit add-on somehow. The-Edmeister have you still got a copy of the one for FF 3.0.* + 3.7.* ?? If so could you or anyone else that still has a copy upload it to a bitlocker and send the link here? I would also like to try this out on the latest FF 4 but am not sure if alice0775 did have one up for that version. If he/she indeed had an MIME edit FF add-on for 4.* would you The-Edmeister or anyone else that has this great add-on upload it to a bitlocker and post the link here as well? That would be tremendously appreciated. Unfortunately the site seems to have gone off-line completely just recently and this MIME edit add-on for FF seems a real hard to find gem. Thanks for any help towards this. Tried editing the .rdf file manually but not sure what to write exactly. Any ways, thanks for any help.
ZillaChilla 0 giải pháp 7 câu trả lời
Được đăng

Well if anyone has it upload it please. Thanks, that would help a lot.

Well if anyone has it upload it please. Thanks, that would help a lot.
Anand 0 giải pháp 1 câu trả lời
Được đăng

Câu trả lời hữu ích

I've stumbled upon an extension that fixes this bug. Here's the site: Fixing Firefox's "Do automatically checkbox"

And here's the extension (it's still experimental but it should work). Tested on Firefox 5.0.0.1. Win7 x64

https://addons.mozilla.org/en-US/firefox/addon/web-page-fixer/

I hope it works for you too. ^^

I've stumbled upon an ''extension that fixes this bug''. Here's the site: [http://www.ubuntuhq.com/content/fixing-firefox039s-quotdo-automatically-files-now-onquot-checkbox Fixing Firefox's "Do automatically checkbox"] And here's the extension (it's ''still experimental but it should work''). ''Tested on Firefox 5.0.0.1. Win7 x64'' [https://addons.mozilla.org/en-US/firefox/addon/web-page-fixer/ https://addons.mozilla.org/en-US/firefox/addon/web-page-fixer/] I hope it works for you too. ^^
snapz 0 giải pháp 4 câu trả lời
Được đăng

I haven't tried the above add-on but the InlineDisposition add-on was created exclusively to fix the "do this automatically..." problem.

https://addons.mozilla.org/en-US/firefox/addon/inlinedisposition/

I haven't tried the above add-on but the InlineDisposition add-on was created exclusively to fix the "do this automatically..." problem. https://addons.mozilla.org/en-US/firefox/addon/inlinedisposition/
tshann 0 giải pháp 2 câu trả lời
Được đăng

Bummer that this stupid annoying problem still persists. The good news is there are two solutions, fixes, or workarounds. The addon Webpage fixer: web page fixer Totally solves it for me. Another one, that seems to work as well or perhaps better is inline disposition Webpage fixer gives additional options besides fixing this annoying issue. Inline simply tries to force Firefox to render whatever it can in the browser first, if that fails, it automatically opens the file in an external program (as designated in the preferences/applications tab.

I've tested them both on firefox 12.0 in Linux Debian x64 (Crunchbang - modded to use Xfce 4.8) and they both remove this rather annoying little chronic firefox bug.

Peace

Bummer that this stupid annoying problem still persists. The good news is there are two solutions, fixes, or workarounds. The addon Webpage fixer: [http://webpagefixer.sourceforge.net/ web page fixer] Totally solves it for me. Another one, that seems to work as well or perhaps better is [http://code.kliu.org/misc/inlinedisposition/ inline disposition] Webpage fixer gives additional options besides fixing this annoying issue. Inline simply tries to force Firefox to render whatever it can in the browser first, if that fails, it automatically opens the file in an external program (as designated in the preferences/applications tab. I've tested them both on firefox 12.0 in Linux Debian x64 (Crunchbang - modded to use Xfce 4.8) and they both remove this rather annoying little chronic firefox bug. Peace

Được chỉnh sửa bởi tshann vào