Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Typing gets very slow in Firefox 3.6.11 in Safe Mode with All extensions and plugins disabled.

  • 3 trả lời
  • 80 gặp vấn đề này
  • 66 lượt xem
  • Trả lời mới nhất được viết bởi Izra

more options

When I first start Firefox everything is fine. And everything remains fine as long as I don't type into any web page's text boxes. I can type into the address or search bar all day long without any problems.

But, for example, just typing into the edit box to ask this question on this site will result in the problem after I type in over say 150 characters. After that typing ANYWHERE in Firefox will be painfully slow, even the address bar or the search bar. It doesn't seem to matter which site I use to type in text. All cause the problem to occur after typing in enough keystrokes.

Browsing & mouse clicking remains fast -- it's only typing that seems to be affected. In order to recover I have to restart Firefox.

If I look at the Firefox.exe cpu usage in Process Explorer I can see that once the problem occurs, the cpu usage starts spiking every time I type a key. In fact Firefox maxes out one of my dual cores so the cpu is at 50%! It drops down to 0% again once I stop typing.

As mentioned in the subject this is in Safe Mode with all extensions & plugins disabled. I am running on Windows XP SP3 with an old AMD Athlon 64 X2 Dual Core Processor 3800+ (1.81Ghz) with 2.00GB of RAM.

I think this started to noticeably happen with Firefox 3.6 (it's amazing how long I can browse without typing) but it used to happen occasionally with earlier versions. Now it is annoyingly repeatable.

I have to use "-no-remote -P ForTyping" to start up a separate Firefox session that I just use to type into text boxes so I can restart it at will. I also compose messages in an external editor and just paste them into Firefox to avoid typing as much as possible.

Giải pháp được chọn

This can be a problem with session restore. Firefox stores session data every 10 seconds to make it possible to restore a crashed session.

This can be a problem with the file sessionstore.js in the Profile Folder

Delete the files sessionstore.js and sessionstore.bak and any existing files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js .

See http://kb.mozillazine.org/Session_Restore

Đọc câu trả lời này trong ngữ cảnh 👍 3

Tất cả các câu trả lời (3)

more options

Giải pháp được chọn

This can be a problem with session restore. Firefox stores session data every 10 seconds to make it possible to restore a crashed session.

This can be a problem with the file sessionstore.js in the Profile Folder

Delete the files sessionstore.js and sessionstore.bak and any existing files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js .

See http://kb.mozillazine.org/Session_Restore

more options

The link you mentioned http://kb.mozillazine.org/Session_Restore has instructions for "Completely disabling session store". I followed those and the problem seems to have gone away on this special ForTyping profile I set up.

My default profile didn't have a sessionstore.js file for some reason. I do have the Tab Mix Plus installed in that profile and it has its own "Enable Session Manager" and "Enable Crash Recovery" settings. I've left those on.

It seems that the fix works for my default profile as well! Thanks for pointing me in the right direction.

more options

I can comment that the only routine I had to block in the latest version, was plugin-container.exe. It seem to isolate other plugins, but its connected to the internet and makes a backdoor that my firewall didnt understand. the isolation must be ment to protect the browser from crashing plugins like Adobe Flash, Apple Quicktime and more, but in fact I never experienced a crash in them. Sålunda, I made a small program that blocks plugin-container.exe from starting. The backdoor once started a heavy activity, 80% of my total cpu-power (wich is very much for a quadruple of potential cpu) and I noticed it exactly that way -typing got slower.

Who wants such backdoors? Suddenly Microsoft crawels in to it :)

Được chỉnh sửa bởi Izra vào