Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Downloads corrupt when saved to remote share

  • 10 trả lời
  • 97 gặp vấn đề này
  • 82 lượt xem
  • Trả lời mới nhất được viết bởi Steve10

more options

I'm Using Firefox 3.6.10 on Windows 7 x64 Ultimate. I am trying to save files to a remote Windows 2008 R2 x64 Server File Share. On larger files a few MB... For example i downloaded the June DirectX SDK ( http://download.microsoft.com/download/A/E/7/AE743F1F-632B-4809-87A9-AA1BB3458E31/DXSDK_Jun10.exe ) and not only was the file cut off (missing almost 1MB) it was also corrupt (different to valid local download) after 2.81 MB. I know the local download was OK since the signature was verified (file is signed by Microsoft). I know this is not a problem with the share because i then copied a ~5GB ISO File that i had a SH256 Hash of to that share and the hash matched when verified there. To make absolutely certain that it was not a problem from either my computer, the server, or the download provider, i created my own little VB.Net Console download client that downloads and saves directly to the remote server destination in 4kb chunks and it worked perfectly!

Tất cả các câu trả lời (10)

more options

I just tried downloading ESXI V3.5 ISO using Firefox 3.6.12 under 32bit Windoze 7 Ultimate, saving to a CIFS share on an old fedora 7 server. 5 seperate attempts from firefox gave 5 differnet MD5 values. The 6th attempt used IE8, and this gave the correct MD5. All the files are the same byte size according to ls -l (not sure how well this will display on the forum) :

[rkelland@orac esxi]$ ls -l *3.5* -rwxr--r-- 1 rkelland rkelland 266371072 2010-11-08 16:49 VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.2.iso -rwxr--r-- 1 rkelland rkelland 266371072 2010-11-08 17:14 VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.3.iso -rwxr--r-- 1 rkelland rkelland 266371072 2010-11-08 17:37 VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.4.iso -rwxr--r-- 1 rkelland rkelland 266371072 2010-11-08 17:37 VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.5.iso -rwxr--r-- 1 rkelland rkelland 266371072 2010-11-08 17:39 VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.6.iso -rwxr--r-- 1 rkelland rkelland 266371072 2010-11-08 16:45 VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.iso [rkelland@orac esxi]$ md5sum *3.5* fdf1309980052101d58454d6a15880db VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.2.iso db93233734bd988b774c48b39f3666d4 VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.3.iso a89e8b1cee1363790142cc4191f2c699 VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.4.iso 07df80fa903e4187fe254e309c5b1122 VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.5.iso e0c6e77fccb9c46394da6a9b86a3e4bf VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.6.iso 8713c149614ea680c1b65d21740efff2 VMware-VMvisor-InstallerCD-3.5.0_Update_5-207095.i386.iso [rkelland@orac esxi]$

more options

Have experienced this issue on both Firefox 3.6.13 as well as 4.0b10 on Windows 7 64bit.

Only seems to happen when writing to Windows Server 2008 R2 file share. Have had no problems writing to Windows Server 2003 or SAMBA hosted on FreeBSD 7.2 with either version.

Được chỉnh sửa bởi aogden vào

more options

I have the same issue when trying to download directly to a Windows 2008 R2 network share. Nearly all larger file downloads will become corrupted. With a video, the corruption will be at a different place(s) each time in the file. If I save to a local drive, I never experience corruption no matter how large the file is. I can then copy it to the network share just fine without corruption.

Just to rule memory issues out, I ran MemTest86+ on both my workstation and server. No problems.

Seeing as the previous poster also experienced the same issue with 4.0b10, this is certainly not limited to certain versions. This really needs to get fixed, as it is a pain to have to download every file to a local drive then copy over.

more options

I love firefox but this problem's got to get fixed. I have resorted to using IE9 to download files to my Windows 2008 R2 shares.

I already seeing this being a problem at work as we move servers over to R2 as well.

more options

I agree, this seriously needs to be fixed, it's been around for ages and ages. I was hoping it would be fixed in 4.0 RTM, but not so (just tested and failed).

more options

I have submitted a patch for this problem. The fix should show up in the nighlty builds soon.

Thanks, Steve

more options

Hi,

I have experianced this problem with Firefox 4.0 today.

I have downloaded the 100Mb file from http://speedtest.qsc.de/

When using Firefox 4.0 and store to Windows 7 share drive all downloaded files are corupt. But when storing to a Solaris CIFS share the downloaded files are correct. Same when using IE9.

It seems to be a explicit problem of Firefox and Windows shares.

/Oliver

more options

Oliver,

You can download a version of firefox that contains the fix here

Please note that this build is only intended for testing purposes. Firefox 5 is the next stable release that will contain this fix.

Thanks, Steve

Được chỉnh sửa bởi Steve10 vào

more options

I've had this problem too, for years. Client pcs: from Windows XP x86 to Windows 7 x64 Server: Windows Server 2003 to Server 2008 R2

I had to resort to IE to download files, which is far from desirable...

I'll try the minefield verion.

more options

Fixed in Firefox 5 release