Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

firefox 3.6.8 doesn't recognize java 1.6 plugin

  • 3 trả lời
  • 171 gặp vấn đề này
  • 357 lượt xem
  • Trả lời mới nhất được viết bởi mv

more options

I am running firefox 3.6.8 on linux. I have also installed jre 1.6. When accessing one intranet website, firefox keeps saying "this feature requires jva 1.6 to be installed on your system...". I have installed java 1.6. I have made following symbolic links already: 1. /usr/local/mozilla/firefox/plugins/libjavaplugin_oji.so to /usr/local/jre1.6.0_21/plugin/i386/ns7/libjavaplugin_oji.so.

2. /usr/lib/mozilla/plugins/libjavaplugin_oji.so to /usr/local/jre1.6.0_21/plugin/i386/ns7/libjavaplugin_oji.so.

Emptied the cache. Restarted firefox. But getting same error message " this feature requires java 1.6 to be installed..."

Tất cả các câu trả lời (3)

more options

Which disto of Linux?

Please post your browser string (in Help > About Mozilla/5.0 (X11; U; Linux i686.....

Does this site confirm you have java 1.6?

http://browserspy.dk/java.php

Does Java work in most places?

more options

That is not the correct Java plugin: libjavaplugin_oji.so

In Firefox 3.6 and later versions you need the Next-Generation Java™ Plug-In present in Java 6 U10 and later (Linux: libnpjp2.so; Windows: npjp2.dll).

ln -s /usr/local/java/jre1.6.0_20/lib/i386/libnpjp2.so libnpjp2.so
ln -s /usr/lib/jvm/jre/lib/i386/libnpjp2.so /usr/lib/mozilla/plugins/libnpjp2.so (java-1_6_0-sun-plugin)
more options

This worked for me (on xubuntu):

sudo update-java-alternatives -s java-6-sun

It used to work before. Probably some update messed up the settings? I also completely removed that *$#&! useless OpenJDK. But donno if that made a difference.