Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox does not open with the tabs I had open when I use the quit and save function. Firefox opens with my home page only. how to fix?

  • 6 trả lời
  • 73 gặp vấn đề này
  • 442 lượt xem
  • Trả lời mới nhất được viết bởi jwh7

more options

When I use the "Save and Quit" function it has no effect. The next time I open Firefox it goes to my home page only.

This happened

Every time Firefox opened

== 3 days ago

Giải pháp được chọn

If you use Delete browsing, search and download history on Firefox in Firefox 3.5/6 or Clear Private Data in Firefox 3 to clear the 'Browsing History' when Firefox is closed then restoring tabs from the last session (e.g. "Save & Quit" or "Show my windows and tabs from last time") doesn't work.

Đọc câu trả lời này trong ngữ cảnh 👍 3

Tất cả các câu trả lời (6)

more options

Giải pháp được chọn

If you use Delete browsing, search and download history on Firefox in Firefox 3.5/6 or Clear Private Data in Firefox 3 to clear the 'Browsing History' when Firefox is closed then restoring tabs from the last session (e.g. "Save & Quit" or "Show my windows and tabs from last time") doesn't work.

more options

How do I fix this?

more options

You can try if it works if you use File > Exit

You need to remove the check mark to clear the Browser History in the Delete browsing, search and download history on Firefox settings.

Tools > Options > Privacy : History: [X] Clear history when Firefox closes > Settings

more options

Go to Tools, then select Options, select Privacy, check Clear History & look at Settings & make sure to uncheck Active Logins and Browsing History . Or just leave the Clear History unchecked.

more options

This is not a solution, nor a work-around. The only thing this points out is where the problem lies. Settings are meant to be used in all sessions, barring exceptions and the fact that Firefox asks if you'd rather SAVE and then quit, makes it an exception. The user has elected to skip the clear browsing history step.

However, if the settings are permanently changed as you suggest, then the history will always be remembered for eternity when Firefox is closed. You then have to manually clear your history first at every session before closing.

Older versions of Firefox never behaved in such manner and recognized that the Save and Quit superseded the setting to Clear History.

more options

I've had this issue (or similar) several times, in FF3.6 and also 3.5 and 3.0. All the typical suggestions were no help; deleting the session, checking tabs options and about:config, private browse settings, and un-/re-installing FF. I forgot now if the specific issue was that the 'Save and Quit' dialog doesn't popup; or if it does, but 'Save and Quit' would not save the tabs for the next session. Anyway, hopefully this will help some of you.

The thing that fixed my issue (and this has occurred several times), I found in a couple obscure google searches. Instead of using the upper-right-corner 'X' to close the window; instead go to File (alt-F if you have your menu hidden) -> 'Exit'. Sounds ridiculous, I know; seems like it was related to upgrading b/t major versions (and I've seen a bunch of these posts popup relating to FF4 upgrades now). I've only done fresh installs of FF4 beta, and not seen the issue. Looks like FF4 has added a new config option: browser.showQuitWarning, that would be something else to check.

I thought I'd sent in a mozilla bug report on it, along w/ replying to a few support forum entries, but now I can't find anything relating to it.

To summarize the various things to check with this issue:

1. Check the Options -> Tabs for 'Warn me when closing multiple tab'

2. Check about:config for the above and similar entries (search for 'warn' and 'quit')

3. Check the Options -> Privacy that Private Browsing isn't enabled (or just select 'Remember History' [note-I think this selection doesn't stay; it just changes the underlying options; can be confusing]

4. Simply go to File -> Exit, instead of the upper-right corner 'X' to close

5. Un-/Re-install FF

6. Delete your sessions file [search elsewhere for details]

I'll be copying this to other forum entries...

Được chỉnh sửa bởi jwh7 vào