Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Linux - 121 update changed cursor

  • 6 trả lời
  • 0 gặp vấn đề này
  • 220 lượt xem
  • Trả lời mới nhất được viết bởi April22

more options

After updating to version 121, the cursor theme, while having it on the window, changes from the default one (Breeze) to Adwaita while also getting like 2x bigger. How do I change it back to default theme and size?

After updating to version 121, the cursor theme, while having it on the window, changes from the default one (Breeze) to Adwaita while also getting like 2x bigger. How do I change it back to default theme and size?

Giải pháp được chọn

Alright, since the Garuda-dedicated Firefox also got updated to 121, I had to find a solution again. Through many other posts on different sites, I found this: https://wiki.archlinux.org/title/Cursor_themes and there specifically this: "KDE (Wayland) xdg-desktop-portal-gtk must be installed for GTK/Gnome applications to correctly apply cursor themeing on Wayland." And so I installed xdg-desktop-portal-gtk through Octopi, relogged and now cursor is normally themed and sized.

Đọc câu trả lời này trong ngữ cảnh 👍 3

Tất cả các câu trả lời (6)

more options

For me on KDE, it's in Settings >> Appearance >> Cursors. see screenshot

Hữu ích?

more options

No, no. I meant that it's only happening in the Firefox window, it's normal outside of it. I've also noticed that, now, Firefox's alert windows look like the ones that run in Wine... Could it be because of the autoupdate installing a windows version or something?

Hữu ích?

more options

It's still an OS or Desktop theme issue, not a browser issue. Play with the themes and see if it works. What OS? What Desktop? X11 or Wayland? I've seen this issue before in KDE and after playing with either the theme and or cursor size it was okay.

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

I have latest Garuda Linux with Wayland, I don't know what do you mean by the desktop though?

I decided to remove it altogether (I installed it manually) and then reinstall it with a package manager which rolled me back to version 120 but for Garuda Linux and everything is back to normal. I'll leave it like that for now cuz everything works.

Hữu ích?

more options

Missing out on critical security fixes is not a solution. Try setting the environment variable MOZ_ENABLE_WAYLAND=0.

Hữu ích?

more options

Giải pháp được chọn

Alright, since the Garuda-dedicated Firefox also got updated to 121, I had to find a solution again. Through many other posts on different sites, I found this: https://wiki.archlinux.org/title/Cursor_themes and there specifically this: "KDE (Wayland) xdg-desktop-portal-gtk must be installed for GTK/Gnome applications to correctly apply cursor themeing on Wayland." And so I installed xdg-desktop-portal-gtk through Octopi, relogged and now cursor is normally themed and sized.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.