Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

FF version 120.0.1 has double spaced lines again. Fix?

  • 8 trả lời
  • 1 gặp vấn đề này
  • 83 lượt xem
  • Trả lời mới nhất được viết bởi doninwn

more options

New computer, Win 11 and FF 120.0.1 all fresh installed and updated with latest versions. The double line spacing in bookmarks and all other menus is back. There was a fix for ver. 89 with the css file trick, but that DOES NOT WORK with this version. All other options I've run across don't work either. Why do the Mozilla software engineers think it's a good idea to break their flagship application every few years? Rhetorical question, I know.

Does anyone have a user fix that actually works with this FF 120.0.1 version? Something an experienced user can do that is not a programmer. analyst or engineer? I've been using FF since it first came out to challenge Microsoft's IE. Late '90s? I'd like to keep using it but this is too annoying to tolerate.

If anyone can help with step by step instructions, I would be eternally grateful.

New computer, Win 11 and FF 120.0.1 all fresh installed and updated with latest versions. The double line spacing in bookmarks and all other menus is back. There was a fix for ver. 89 with the css file trick, but that DOES NOT WORK with this version. All other options I've run across don't work either. Why do the Mozilla software engineers think it's a good idea to break their flagship application every few years? Rhetorical question, I know. Does anyone have a user fix that actually works with this FF 120.0.1 version? Something an experienced user can do that is not a programmer. analyst or engineer? I've been using FF since it first came out to challenge Microsoft's IE. Late '90s? I'd like to keep using it but this is too annoying to tolerate. If anyone can help with step by step instructions, I would be eternally grateful.

Giải pháp được chọn

After all of the profile edits and other hacks I went back into the userChrome file and tried this again:

/* Disable new Proton UI and Restore Old Classic Theme in Mozilla Firefox - Start */ .tab-background{ border-radius: 0px 0px !important; margin-bottom: 0px !important; } .tabbrowser-tab:not([selected=true]):not([multiselected=true]) .tab-background{ background-color: color-mix(in srgb, currentColor 5%, transparent); } menupopup > menu, menupopup > menuitem{ padding-block: 2px !important; min-height: 0px !important; }

root{

--arrowpanel-menuitem-padding: 2px !important; } /* Disable new Proton UI and Restore Old Classic Theme in Mozilla Firefox - End */


It worked! Now I don't have to scroll 2 pages in order to get one page of bookmarks.

These are the tweaks to about:config but don't know which helped the css file actually work.

about:config - toolkit.legacyUserProfileCustomizations.stylesheets = TRUE Browser.Proton.Contextmenus.enabled = FALSE browser.compactmode.show = TRUE browser.uidensity = 1 svg.context-properties.content.enabled. = TRUE

I hope others can benefit from this and that it will work for them. I further hope Mozilla gets its act together and doesn't continue to rely on user hacks to make their applications useable.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (8)

more options

You may need to update your css. Check the site where you got the code.

Hữu ích?

more options

I've tried 3 or 4 'solutions' including one from a forum moderator to no avail. The same gap issue is also in the new install of Thunderbird. Anything with a list is double spaced. I've found 4 different 'userChrome' fixes as well as some others like, 'change your font'.

Why doesn't Mozzilla put out an 'official' fix? They created the problem.

Hữu ích?

more options

You appear to have toolkit.legacyUserProfileCustomizations.stylesheets = true , but do not have a userChrome.css in the chrome folder.

In Firefox 93 and later releases support to reduce the menu spacing via "Density: Compact" on the Customize page has been added. Note that "Compact" is no longer present by default as a Density choice in Customize.

Hữu ích?

more options

Been trying to find a solution for several days to an issue that's been present for several years. It was running after the mods in the original version that broke. New version loaded a couple days ago broke again.


about:config - toolkit.legacyUserProfileCustomizations.stylesheets = TRUE Browser.Proton.Contextmenus.enabled = FALSE browser.compactmode.show = TRUE browser.uidensity = 1 svg.context-properties.content.enabled. = TRUE browser.compactmode.show=TRUE then tried to change density to Compact (not supported)

 but it would not accept (dead click) and reverted to NORMAL

profile located at C:\Users\user\AppData\Roaming\Mozilla\Firefox\Profiles\6jbjl14e.default-release - Created a chrome folder installed userChrome.css and userContent.css from github


other options tried in userChrome.css at different attempts

/* Minimize height of sidebar items */ .sidebar-placesTreechildren::-moz-tree-row {

   min-height: 18px !important;
   height: 18px !important;
   max-height: 18px !important;

}


and this

/* Use Normal top and bottom padding for Compact */

  1. PlacesToolbarItems .bookmark-item {
 padding-top: 2px !important;
 padding-bottom: 2px !important;

}

and this

menupopup > menuitem, menupopup > menu {

 padding-block: 4px !important;

}

root {
 --arrowpanel-menuitem-padding: 4px 8px !important;

}

and this

/* Bookmark menu */

  1. PlacesToolbarItems .bookmark-item {
 padding-top: 0px !important;
 padding-bottom: 0px !important;

}

/* Right-click menu */ menupopup#contentAreaContextMenu menu, menupopup#contentAreaContextMenu menuitem {

 padding-top:0px !important;
 padding-bottom:0px !important;

}

and this

/* Disable new Proton UI and Restore Old Classic Theme in Mozilla Firefox - Start */ .tab-background{ border-radius: 0px 0px !important; margin-bottom: 0px !important; } .tabbrowser-tab:not([selected=true]):not([multiselected=true]) .tab-background{ background-color: color-mix(in srgb, currentColor 5%, transparent); } menupopup > menu, menupopup > menuitem{ padding-block: 2px !important; min-height: 0px !important; }

root{

--arrowpanel-menuitem-padding: 2px !important; } /* Disable new Proton UI and Restore Old Classic Theme in Mozilla Firefox - End */



I'm sure there are other suggestions scattered about the interwebs but figured someone at Moz Support would have a solution.

Hữu ích?

more options

Did you try to open userChrome.css in a Firefox tab and made sure that there isn't a hidden .txt or .css file extension appended (userChrome.css.txt or userChrome.css.css)

Hữu ích?

more options

Note that you can check the LegacyUserStylesheets section on the "Help -> More Troubleshooting Information" (about:support) page to see if userChrome.css is detected.

Hữu ích?

more options

The userChrome.css did in fact show as double .css when looked up with FF. I edited the file and removed the extra css. When looking up the support page, the css files show up, both the chrome and content files found on github. But everything is still double spaced.

The userChrome.css file contains this:

/* Line height for treechildren */

is(#bookmarks-view, #historyTree, #editBMPanel_folderTree, #placesList, #placeContent)

treechildren::-moz-tree-row {

 margin-top: 0px !important;
 min-height: 20px !important;
 height: 20px !important;

}

/** Import Lepton stylesheet (Chrome) *****************************************/ @import url("css/leptonChrome.css");


/** Add your custom styles below **********************************************/

/* Enable option to edit bookmark URLs under Add Bookmark (blue star) menu */ /* .editBMPanel_locationRow {

 display: initial !important;

}

  • /

/* Disable Email Image/Audio/Video and Set as Desktop Background context menu items */ /*

  1. context-sendimage,
  2. context-sendvideo,
  3. context-sendaudio,
  4. context-sep-setbackground,
  5. context-setDesktopBackground {
 display: none !important;

}

  • /

Hữu ích?

more options

Giải pháp được chọn

After all of the profile edits and other hacks I went back into the userChrome file and tried this again:

/* Disable new Proton UI and Restore Old Classic Theme in Mozilla Firefox - Start */ .tab-background{ border-radius: 0px 0px !important; margin-bottom: 0px !important; } .tabbrowser-tab:not([selected=true]):not([multiselected=true]) .tab-background{ background-color: color-mix(in srgb, currentColor 5%, transparent); } menupopup > menu, menupopup > menuitem{ padding-block: 2px !important; min-height: 0px !important; }

root{

--arrowpanel-menuitem-padding: 2px !important; } /* Disable new Proton UI and Restore Old Classic Theme in Mozilla Firefox - End */


It worked! Now I don't have to scroll 2 pages in order to get one page of bookmarks.

These are the tweaks to about:config but don't know which helped the css file actually work.

about:config - toolkit.legacyUserProfileCustomizations.stylesheets = TRUE Browser.Proton.Contextmenus.enabled = FALSE browser.compactmode.show = TRUE browser.uidensity = 1 svg.context-properties.content.enabled. = TRUE

I hope others can benefit from this and that it will work for them. I further hope Mozilla gets its act together and doesn't continue to rely on user hacks to make their applications useable.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.