Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How can I block the drop down minipalyer?

  • 8 trả lời
  • 0 gặp vấn đề này
  • 18 lượt xem
  • Trả lời mới nhất được viết bởi br5491

more options

How can I block the dropdown video miniplayer in Firefox 120.0.1 on Windows 11? It doesn't happen in MS Edge.

I've already set the following with no results:

media.autoplay.default = 5 media.autoplay.blocking_policy = 2 media.autoplay.allow-extension-background-pages = false media.autoplay.block-event.enabled = true media.block-autoplay-until-in-foreground = false

Is there a setting that I've missed? Can the miniplayer somehow be blocked using userContent.css? Can the miniplayer be totally removed from Firefox?

How can I block the dropdown video miniplayer in Firefox 120.0.1 on Windows 11? It doesn't happen in MS Edge. I've already set the following with no results: media.autoplay.default = 5 media.autoplay.blocking_policy = 2 media.autoplay.allow-extension-background-pages = false media.autoplay.block-event.enabled = true media.block-autoplay-until-in-foreground = false Is there a setting that I've missed? Can the miniplayer somehow be blocked using userContent.css? Can the miniplayer be totally removed from Firefox?

Giải pháp được chọn

Though I'm not a coder and I don't know what I'm doing, I got it to work via trial and error. The first entry works so I added the other domains. Thanks for pointing me in the right direction.

@-moz-document domain(foxnews.com){

.featured.featured-video.video-ct.sticky-video .contain {
 display: none !important;
}

}

@-moz-document domain(foxbusinessnews.com){

.featured.featured-video.video-ct.sticky-video .contain {
 display: none !important;
}

}

@-moz-document domain(foxbusiness.com){

.featured.featured-video.video-ct.sticky-video .contain {
 display: none !important;
}

}

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (8)

more options

What website do you see this miniplayer on? An extension could possibly be blocking it on Edge.

Firefox has a Picture-in-Picture player but it must be opened manually by clicking the button on videos or pressing Ctrl+Shift+].

Does it still appear in Troubleshoot Mode?

Hữu ích?

more options

I guess it could be media.hardwaremediakeys.enabled.

Hữu ích?

more options

The dropdown video happens in troubleshooting mode too. The media.hardwaremediakeys.enabled was already set to false. Toggling it had no effect.

Hữu ích?

more options

Is this about the mini player that some websites display if you scroll the page to keep the video in view ? If the video isn't started then you shouldn't get this mini player.

Can you post a link to a page where the media prefs aren't blocking the player ?

You can check the player in the Inspector to get its selector (#id or .classname), you would have to scroll up in the DOM to find the outer element that contains the player and add a rule to your current userContent.css to hide this player. Enclose this rule in a @-moz-document domain(){} block to apply the rule only to this domain.

Hữu ích?

more options

The issue seems to be only with Fox website videos such as https://www.foxnews.com/video/6342556974112 and https://www.foxbusiness.com/lifestyle/video-shows-michigan-mom-punching-store-clerk-front-1-year-old-daughter-police.

media.videocontrols.picture-in-picture.enabled is set to false but picture-in-picture still pops up.

Hữu ích?

more options

This is not about the Firefox PiP features, but is done by the website via JavaScript and CSS. There is the main .video-container DIV element and within that a DIV .sticky-wrapper that gets an extra .sticky-player once you scroll down. You can hide the .sticky-player DIV, but that leaves the .video-container DIV that has a padding-bottom property which is scrollable. I don't know hide to hide the .video-container DIV via CSS only when there is .sticky-player DIV present. This looks a bit ugly depending on the width of the window.

@-moz-document
 domain(www.foxbusiness.com),
 domain(www.foxnews.com) {
  .video-container .sticky-player {
    display:none!important;
  }
}

Hữu ích?

more options

You can use an extension like Kill Sticky or AlwaysKillSticky to hide sticky parts of the page like miniplayers.

Hữu ích?

more options

Giải pháp được chọn

Though I'm not a coder and I don't know what I'm doing, I got it to work via trial and error. The first entry works so I added the other domains. Thanks for pointing me in the right direction.

@-moz-document domain(foxnews.com){

.featured.featured-video.video-ct.sticky-video .contain {
 display: none !important;
}

}

@-moz-document domain(foxbusinessnews.com){

.featured.featured-video.video-ct.sticky-video .contain {
 display: none !important;
}

}

@-moz-document domain(foxbusiness.com){

.featured.featured-video.video-ct.sticky-video .contain {
 display: none !important;
}

}

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.