Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox (118) does not play certain audio files

  • 9 trả lời
  • 1 gặp vấn đề này
  • 12 lượt xem
  • Trả lời mới nhất được viết bởi Kaj

more options

I have found that Firefox does not play some audio files, for instance on Wikipedia and WaniKani, such as the audio on https://en.wikipedia.org/wiki/Erhu and https://www.wanikani.com/vocabulary/%E9%9F%B3. When inspecting network activity I can see that an attempt is made to load the audio on Wikipedia, but it does not play. On WaniKani however, no attempt is made. (WaniKani uses .webm for sound, maybe that has something to do with it?) The problem appeared after the update to Firefox 118 and persists in private browsing and troubleshooting mode, but does not occur in GNOME Web.

I have found that Firefox does not play some audio files, for instance on Wikipedia and WaniKani, such as the audio on https://en.wikipedia.org/wiki/Erhu and https://www.wanikani.com/vocabulary/%E9%9F%B3. When inspecting network activity I can see that an attempt is made to load the audio on Wikipedia, but it does not play. On WaniKani however, no attempt is made. (WaniKani uses .webm for sound, maybe that has something to do with it?) The problem appeared after the update to Firefox 118 and persists in private browsing and troubleshooting mode, but does not occur in GNOME Web.

Giải pháp được chọn

Update: I have fixed the issue myself. Switching media.ffvpx.enabled in about:config back on fixed the issue. I honestly have no clue as to why a toggle related to VP8/9 video codecs affects audio, but it fixed the issue.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (9)

more options

They both work for me on Ubuntu 23.04 (ogg and webm respectively).

Install ffmpeg:

sudo apt install ffmpeg

or

flatpak install org.freedesktop.Platform.ffmpeg-full

Pick the flatpak runtime that matches firefox (flathub currently uses 22.08).

Hữu ích?

more options

Update to 118.0.2 since there was a fix related to these formats.

Hữu ích?

more options

zeroknight said

Update to 118.0.2 since there was a fix related to these formats.

Looks like 118.0.2 has not yet made its way to the Fedora repos. Well, now I know it'll be fine, thank you!

Hữu ích?

more options

Update: 188.0.2 landed in the Fedora repos, sadly the issue still persists...

Hữu ích?

more options

Can you play the file in a tab using a data URI:

data:text/html,<audio src="https%3A%2F%2Ffiles.wanikani.com%2Fmin88pyizg5vgfiyyyf9y4cmce0y" controls>

Hữu ích?

more options

cor-el said

Can you play the file in a tab using a data URI: data:text/html,<audio src="https%3A%2F%2Ffiles.wanikani.com%2Fmin88pyizg5vgfiyyyf9y4cmce0y" controls>

Going to https://files.wanikani.com/2Fmin88pyizg5vgfiyyyf9y4cmce0y only gives an xml file without any style information in both Firefox as well as GNOME Web:

<Error> AccessDenied <Message>Access Denied</Message> <RequestId>D13GCF481VJVW3ZJ</RequestId> <HostId> ePG84W7jh9Cd4RCyUs1/jw3yTyYdTu28Lct5gtLDLIRWLX+D3VCnT6zPuSN9aDfV7cD60VOqy70= </HostId> </Error>

If I go to https://upload.wikimedia.org/wikipedia/commons/3/30/%E6%B1%9F%E6%B2%B3%E6%B0%B4.ogg it does load the file, as the bar is buffering, however it simply does not play.

Hữu ích?

more options

The point is to paste the full text starting with data: in the location bar and not the URL.

data:text/html,<audio src="https%3A%2F%2Ffiles.wanikani.com%2Fmin88pyizg5vgfiyyyf9y4cmce0y" controls>

This should give you an audio element with a player control.

Hữu ích?

more options

cor-el said

The point is to paste the full text starting with data: in the location bar and not the URL. data:text/html,<audio src="https%3A%2F%2Ffiles.wanikani.com%2Fmin88pyizg5vgfiyyyf9y4cmce0y" controls> This should give you an audio element with a player control.

Okay thank you for the clarification. Now it gets interesting: this does play fine...

Hữu ích?

more options

Giải pháp được chọn

Update: I have fixed the issue myself. Switching media.ffvpx.enabled in about:config back on fixed the issue. I honestly have no clue as to why a toggle related to VP8/9 video codecs affects audio, but it fixed the issue.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.