Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

print PDF with internal links instead of (full) external links

  • 1 trả lời
  • 1 gặp vấn đề này
  • 14 lượt xem
  • Trả lời mới nhất được viết bởi kornelis

more options

When I print to a PDF file, Firefox changes internal links (#go-there) to full external links (either https://the.website.tld/paper.html#go-there or file://home/me/paper.html#go-there).

This is obviously wrong, since the links are internal to the document.

How to I change this behavior?

Thanks.

When I print to a PDF file, Firefox changes internal links (#go-there) to full external links (either https://the.website.tld/paper.html#go-there or file://home/me/paper.html#go-there). This is obviously wrong, since the links are internal to the document. How to I change this behavior? Thanks.

Tất cả các câu trả lời (1)

more options

If internal links can’t be fixed, a solution to hide the fact that there are links in the document would help.

I tried the latter by adding to the stylesheet:


@media print {

   a, a:visited { color: black !important; cursor: not-allowed !important; }

}


The color works, but the cursor remains grab shape and depending on the PDF viewer a link will be displayed somewhere.