Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox Windows displays Monofont not as monofont

  • 3 trả lời
  • 0 gặp vấn đề này
  • 1 lượt xem
  • Trả lời mới nhất được viết bởi lennart.kurzweg.lk

more options

Since `monospace` means something diffrent on every device, and I need consistency between clients I use `Roboto Mono` on my Website as ASCII-Art font. For some reason Firefox on Windows cannot render the font properly (view image). What can i do to fix this? The problem presists across my desktop and Laptop. See for yourself https://nx2.site/my-ascii-art (I cannot guarantee this is always up + In the future it's hopefully fixed?)

Since `monospace` means something diffrent on every device, and I need consistency between clients I use `Roboto Mono` on my Website as ASCII-Art font. For some reason Firefox on Windows cannot render the font properly (view image). What can i do to fix this? The problem presists across my desktop and Laptop. See for yourself https://nx2.site/my-ascii-art (I cannot guarantee this is always up + In the future it's hopefully fixed?)
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Thanks for the help, the problem unfortunately remains in troubleshoot-mode aswell. I can also not really imagine that it's a "my machine" problem, since it occurs on 2 of my devices and on the Desktop of a freind aswell (again just Firefox, not Opera or Chrome)

The Issue only occures with the bold Font, thats becasue Roboto mono doesn't supprt my choosen weight of 700. So I switched to Source Code Pro (which does support it), now it works. (view image)

I'd still argue that it's weird that it worked on every OS-Browser Combo exept Windows+Firefox.

Resolved.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (3)

more options

Did you make sure to include the space characters in the same element as the monospace characters because otherwise you may end up with normal spaces that have a different length than monospace space characters. A recent thread you can look at:

  • /questions/1412335 1, Strange formatting of <B> inside <PRE>, and 2, Unexpected formatting of bogus <D> element

Được chỉnh sửa bởi cor-el vào

more options

OK, I tested it and it looks fine for me. Are you using extensions that can block remote fonts ?

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

more options

Giải pháp được chọn

Thanks for the help, the problem unfortunately remains in troubleshoot-mode aswell. I can also not really imagine that it's a "my machine" problem, since it occurs on 2 of my devices and on the Desktop of a freind aswell (again just Firefox, not Opera or Chrome)

The Issue only occures with the bold Font, thats becasue Roboto mono doesn't supprt my choosen weight of 700. So I switched to Source Code Pro (which does support it), now it works. (view image)

I'd still argue that it's weird that it worked on every OS-Browser Combo exept Windows+Firefox.

Resolved.