Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox won't stay my default browser. Every time I sign on after rebooting MS changes the default

  • 5 trả lời
  • 1 gặp vấn đề này
  • 3 lượt xem
  • Trả lời mới nhất được viết bởi AliceWyman

more options

Firefox won't stay my default browser. Every time I sign on after rebooting MS changes the default to I don't know what. It doesn't say what is the default. It wants edge I guess but I deleted the entire edge app and all its dlls. So how do I make the choice through the "set defaults" settings permanent?

Firefox won't stay my default browser. Every time I sign on after rebooting MS changes the default to I don't know what. It doesn't say what is the default. It wants edge I guess but I deleted the entire edge app and all its dlls. So how do I make the choice through the "set defaults" settings permanent?

Tất cả các câu trả lời (5)

more options

To make Firefox your default browser in Windows, follow these steps:

  1. Open Firefox and click on the menu button (three horizontal lines) in the top-right corner of the window.
  2. Click on "Options"
  3. In the left-side menu, click on "General"
  4. Under the "System Defaults" section, click on "Make Default"
  5. Windows should then prompt you to confirm that you want to set Firefox as your default browser. Click "Yes."

This should make Firefox your default browser permanently, even after rebooting your computer.

If you continue to have issues, you can try resetting the default program settings in Windows. To do this, follow these steps:

  1. Go to the Start menu and type "default apps" in the search bar.
  2. Click on "Default apps" in the search results.
  3. Scroll down to the "Web browser" section and click on the current default browser.
  4. Select "Firefox" from the list of options.

This should set Firefox as your default browser and prevent other programs from changing it.

To make Firefox your default browser permanently using the registry, follow these steps:

  1. Press the Windows key + R on your keyboard to open the Run dialog box.
  2. Type "regedit" and press Enter to open the Registry Editor.
  3. Navigate to the following key: HKEY_CLASSES_ROOT\HTTP\shell\open\command
  4. Right-click on the "command" key and select "Modify."
  5. Change the value data to the following: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -osint -url "%1"
  6. Close the Registry Editor and restart your computer.

This should set Firefox as the default browser permanently, and it should no longer change to another browser after rebooting. Note that the path to the Firefox executable may be different on your computer, so be sure to use the correct path for your system.

You can find references to this information online in various technical support forums and websites. Here are a few links where you can find more information about making Firefox the default browser using the registry:

[https://www.tenforums.com/tutorials/112235-default-programs-set-default-...] https://www.howtogeek.com/howto/17260/how-to-change-the-default-program-a-file-opens-with-in-windows-7/ https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser

You can also find more information about the Windows Registry and how to edit it in various online resources, such as the Microsoft Developer Network (MSDN) or other technical support websites.

more options

None of this works.

1. There is no key: "HKEY_CLASSES_ROOT\HTTP\shell\open\command" in the registry.

2. Went through the registry and changed the values of the following keys: .htm, .html, .ttt, .htw, .htx and hxx and every entry to their reference to: "C:\Program Files\Mozilla Firefox\firefox.exe" then rebooted.

3. After each registry edit and reboot windows10 took a long time to come up with lots of disk activity. This tell me the windows changes all this back!

4. So, how do you fix this??????

more options

None of this works.

1. There is no key: "HKEY_CLASSES_ROOT\HTTP\shell\open\command" in the registry.

2. Went through the registry and changed the values of the following keys: .htm, .html, .ttt, .htw, .htx and hxx and every entry to their reference to: "C:\Program Files\Mozilla Firefox\firefox.exe" then rebooted.

3. After each registry edit and reboot windows10 took a long time to come up with lots of disk activity. This tell me the windows changes all this back!

4. So, how do you fix this??????

more options

You can tell what browser is your system default browser by running a web search from the Start menu search box.

more options

See these Mozilla Support articles, in case it helps: Make Firefox your default browser Make Firefox your default browser on Windows