Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

google maps layers>more>labels toggle button not working

  • 9 trả lời
  • 1 gặp vấn đề này
  • 62 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

the labels toggle button on google maps is unresponsive in both satellite and maps views. where do i find a setting to allow this button to become active? can i program the button to become active? thanks for any help.

i'm on windows 11 and use firefox web browser. both are up to date. i tried it on the microsoft edge browser and it works.

i've tried disabling all addons, restarted firefox, and problem still exists.

next i went through all of my firefox settings and toggled those that might apply. problem still exists.

next went into about:config and checked all settings not set at default. toggled any that might apply. problem still there.

any other suggestions in the community? is there a particular area of firefox i should look into closer. i would prefer not to have to reinstall or reconfigure firefox on a wholesale level. i have it highly customized and it would take multiple hours over a number of days to get everything back to where it is. this is the only site giving me a problem, and only this function on the site.

under layers/more the globe view toggle works fine, only the labels view toggle is not working.

i inspected the button element in 'firefox inspect' and found the attribute disabled="false". google maps is not honouring the attribute. when i remove the attribute, the button works. i cannot apply this across sessions though.

the labels toggle button on google maps is unresponsive in both satellite and maps views. where do i find a setting to allow this button to become active? can i program the button to become active? thanks for any help. i'm on windows 11 and use firefox web browser. both are up to date. i tried it on the microsoft edge browser and it works. i've tried disabling all addons, restarted firefox, and problem still exists. next i went through all of my firefox settings and toggled those that might apply. problem still exists. next went into about:config and checked all settings not set at default. toggled any that might apply. problem still there. any other suggestions in the community? is there a particular area of firefox i should look into closer. i would prefer not to have to reinstall or reconfigure firefox on a wholesale level. i have it highly customized and it would take multiple hours over a number of days to get everything back to where it is. this is the only site giving me a problem, and only this function on the site. under layers/more the globe view toggle works fine, only the labels view toggle is not working. i inspected the button element in 'firefox inspect' and found the attribute disabled="false". google maps is not honouring the attribute. when i remove the attribute, the button works. i cannot apply this across sessions though.
Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (9)

more options

Url of the google map your using so others can test if they get the same issue on Firefox with google maps?

Hữu ích?

more options

it happens an all maps. it has to do with firefox not honouring the labels 'disabled="false"' attribute in google maps. here is the url of the last map i was on: https://www.google.com/maps/place/Taiwan/@23.6297778,117.6271166,834922m/data=!3m1!1e3!4m6!3m5!1s0x346ef3065c07572f:0xe711f004bf9c5469!8m2!3d23.69781!4d120.960515!16zL20vMDZmMzI

Hữu ích?

more options

This came up in another thread (https://support.mozilla.org/questions/1391340) and we didn't find a workaround at that time.

I suspect Google needs to fix it because their script connects the form control to what appears in the map.

Hữu ích?

more options

thanks jscher2000. this appears as if it will be a circle jerk. the guys over at google maps are saying its a firefox issue because it works with microsoft edge. but edge isn't firefox, so don't know how we get them to fix it for firefox.

Hữu ích?

more options

Google is fingerpointing to Firefox...

"https://support.google.com/maps/thread/181851811/i-cant-untick-labels-on-google-maps?hl=en&pli=1#redirected=true"

It would be a tremendous help for us as users if some big boss from Firefox would take this up at Google HQ.

Seems Google is purposely blocking functionality on their products. Should the EU commission look into it?

Hữu ích?

more options

So, a Firefox problem, or a Google problem?

Hữu ích?

more options

No one has any better idea of whether this is a Firefox problem or a Google problem?

Hữu ích?

more options

I'm sorry I didn't think of this before, but you can use a little script to un-disable the button and click it:

var btn=document.querySelector('button[jsaction="layerswitcher.intent.labels"]');
btn.removeAttribute('disabled');
btn.click();


Although you can execute that in the Web Console (Ctrl+Shift+K), the most convenient way to run it is to assign it to a bookmark on your Bookmarks Toolbar and click the bookmark to execute the script against the page (i.e., a bookmarklet). The syntax has a little extra at the beginning and end:

javascript:var btn=document.querySelector('button[jsaction=%22layerswitcher.intent.labels%22]');btn.removeAttribute('disabled');btn.click();void 0;

I added it to my collection here for easier installation:

https://www.jeffersonscher.com/res/sumomarklets.html#GMapLabels

Hữu ích?

more options

This variant removes the disabled attribute and toggles the Label checkbox, so you can possible invoke the bookmarklet another time to re-enable the labels.

javascript:/*GoogleMaps=>Labels:Toggle*/void(document.querySelectorAll('button[jsaction="layerswitcher.intent.labels"]').forEach((e)=>{e.removeAttribute('disabled');e.click()}))

(sorry Jefferson, misunderstood that the bookmaklet works like a toggle)

Được chỉnh sửa bởi cor-el vào

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.