Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Windows 10: Alt-tabbing sometimes causes Firefox to freeze momentarily

  • 2 trả lời
  • 0 gặp vấn đề này
  • 1 lượt xem
  • Trả lời mới nhất được viết bởi Arcotash

more options

As far as I can tell, this has something to do with Firefox aggressively offloading stuff from memory to storage. When I alt-tab at times, Firefox completely freezes. Every Firefox window hangs on a single image and I am unable to interact with anything for a few seconds. During these seconds, I can see the memory % in the Windows Task Manager slowly climbing until Firefox unfreezes itself, so it seems to be loading stuff back into memory. For example, it'll climb from 55% to 70%, taking its sweet sweet time. I also see some disk usage with 'System' during this time.

This behavior occurs even when I'm active on the browser and at 50% memory. It seems to occur more often once I hit the 60% memory mark.

I'm almost certain that this is a Firefox-specific issue, because I can interact with any other program during this period. It is only Firefox that stops dead in its track.

Is there a way to make this behavior less aggressive? I'd rather not have my alt-tabs freeze every few minutes.

As far as I can tell, this has something to do with Firefox aggressively offloading stuff from memory to storage. When I alt-tab at times, Firefox completely freezes. Every Firefox window hangs on a single image and I am unable to interact with anything for a few seconds. During these seconds, I can see the memory % in the Windows Task Manager slowly climbing until Firefox unfreezes itself, so it seems to be loading stuff back into memory. For example, it'll climb from 55% to 70%, taking its sweet sweet time. I also see some disk usage with 'System' during this time. This behavior occurs even when I'm active on the browser and at 50% memory. It seems to occur more often once I hit the 60% memory mark. I'm almost certain that this is a Firefox-specific issue, because I can interact with any other program during this period. It is only Firefox that stops dead in its track. Is there a way to make this behavior less aggressive? I'd rather not have my alt-tabs freeze every few minutes.

Giải pháp được chọn

I've narrowed the problem down to my integrated GPU. Turning hardware acceleration off fixes the problem of freezing, but now I lose the benefits of my GPU. Regardless, it's better than having it freeze all the time. It's not an ideal solution, but I suppose it supposes the title of this post.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (2)

more options

And I forgot to mention that this occurs on a laptop (Acer Swift X SFX14-41G), and it's unlikely to be an addon problem (Dark Reader, uBlock Origin, Youtube Enhancer, & LocalCDN). I've had this problem for a while, and it's occurred even while on a (relatively) fresh windows 10 install.

Given that I don't see this problem elsewhere on the forum, perhaps it's related to my hardware?

Another thingy is that I often use Firefox as a PDF reader or to browse online textbooks, and I use OneNote to take notes. This means that my focused window is almost always OneNote, even though I'm interacting with Firefox using the scrollwheel.

Được chỉnh sửa bởi Arcotash vào

Hữu ích?

more options

Giải pháp được chọn

I've narrowed the problem down to my integrated GPU. Turning hardware acceleration off fixes the problem of freezing, but now I lose the benefits of my GPU. Regardless, it's better than having it freeze all the time. It's not an ideal solution, but I suppose it supposes the title of this post.

Được chỉnh sửa bởi Arcotash vào

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.