Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

no sound after installing latest version (104)

  • 22 trả lời
  • 0 gặp vấn đề này
  • 7 lượt xem
  • Trả lời mới nhất được viết bởi jonzn4SUSE

more options

I'm running Debian Stretch and the packaged version of Firefox (91) runs fine but seems a bit dated. I installed ver. 104 manually and everything is fine except that there is no audio. I changed the setup Privacy and Security Autoplay to 'Allow Audio and Video' -- no audio. I've restarted in troubleshoot mode -- no audio. Other browsers, including ver. 91 of Firefox have no trouble with audio. Any ideas? On quitting I get these messages:

3 /opt/firefox 0 $ firefox [GFX1-]: glxtest: libEGL missing methods for GL test [GFX1-]: glxtest: libEGL missing eglGetDisplayDriverName

3 /opt/firefox 0 $ [GFX1-]: glxtest: libEGL missing methods for GL test 12:03PM Tue 6 [GFX1-]: glxtest: libEGL missing eglGetDisplayDriverName [2022-09-06T19:03:40Z ERROR mp4parse] Found 2 nul bytes in "\0\0" [2022-09-06T19:03:40Z ERROR mp4parse] Found 2 nul bytes in "\0\0" [2022-09-06T19:03:40Z ERROR mp4parse] Found 2 nul bytes in "\0\0" [2022-09-06T19:03:40Z ERROR mp4parse] Found 2 nul bytes in "\0\0" [Child 4452, MediaDecoderStateMachine #1] WARNING: 7f1908378700 OpenCubeb() failed to init cubeb: file /builds/worker/checkouts/gecko/dom/media/AudioStream.cpp:281 [Child 4452, MediaDecoderStateMachine #1] WARNING: Decoder=7f1909b8ac00 [OnMediaSinkAudioError]: file /builds/worker/checkouts/gecko/dom/media/MediaDecoderStateMachine.cpp:3979 [2022-09-06T19:05:39Z ERROR viaduct::backend::ffi] Missing HTTP status [2022-09-06T19:05:39Z ERROR viaduct::backend::ffi] Missing HTTP status

I'm running Debian Stretch and the packaged version of Firefox (91) runs fine but seems a bit dated. I installed ver. 104 manually and everything is fine except that there is no audio. I changed the setup Privacy and Security Autoplay to 'Allow Audio and Video' -- no audio. I've restarted in troubleshoot mode -- no audio. Other browsers, including ver. 91 of Firefox have no trouble with audio. Any ideas? On quitting I get these messages: 3 /opt/firefox 0 $ firefox [GFX1-]: glxtest: libEGL missing methods for GL test [GFX1-]: glxtest: libEGL missing eglGetDisplayDriverName 3 /opt/firefox 0 $ [GFX1-]: glxtest: libEGL missing methods for GL test 12:03PM Tue 6 [GFX1-]: glxtest: libEGL missing eglGetDisplayDriverName [2022-09-06T19:03:40Z ERROR mp4parse] Found 2 nul bytes in "\0\0" [2022-09-06T19:03:40Z ERROR mp4parse] Found 2 nul bytes in "\0\0" [2022-09-06T19:03:40Z ERROR mp4parse] Found 2 nul bytes in "\0\0" [2022-09-06T19:03:40Z ERROR mp4parse] Found 2 nul bytes in "\0\0" [Child 4452, MediaDecoderStateMachine #1] WARNING: 7f1908378700 OpenCubeb() failed to init cubeb: file /builds/worker/checkouts/gecko/dom/media/AudioStream.cpp:281 [Child 4452, MediaDecoderStateMachine #1] WARNING: Decoder=7f1909b8ac00 [OnMediaSinkAudioError]: file /builds/worker/checkouts/gecko/dom/media/MediaDecoderStateMachine.cpp:3979 [2022-09-06T19:05:39Z ERROR viaduct::backend::ffi] Missing HTTP status [2022-09-06T19:05:39Z ERROR viaduct::backend::ffi] Missing HTTP status

Tất cả các câu trả lời (20)

more options

What is your sound setup? I have external speaker plugged into my headphone jack on my laptop. see screenshot


Operating System: openSUSE Tumbleweed 20220906 KDE Plasma Version: 5.25.4 KDE Frameworks Version: 5.97.0 Qt Version: 5.15.5 Kernel Version: 5.19.7-1-default (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Xeon® CPU E3-1535M v5 @ 2.90GHz Memory: 62.7 GiB of RAM Graphics Processor: Mesa Intel® HD Graphics P530 Product Name: HP ZBook 17 G3

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

Are you running Firefox as the root user ?

Hữu ích?

more options

I get similar message when opening Firefox via konsole / terminal (something I rarely do) and then closing.

ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs [2022-09-08T09:57:38Z ERROR viaduct::backend::ffi] Missing HTTP status [2022-09-08T09:57:38Z ERROR viaduct::backend::ffi] Missing HTTP status

Hữu ích?

more options

"What is your sound setup? I have external speaker plugged into my headphone jack on my laptop. see screenshot"

The same. Should that matter tho? Again, Firefox 91 works fine.

"Are you running Firefox as the root user ?"

Yes! Fact is I do everything as root, have for ten years. Why that would let me play a video, but kill the sound is beyond me tho. Some strange permission involved?

Hữu ích?

more options

Just tried running as a normal user -- no change, still no sound.

Hữu ích?

more options

Have you tried uninstalling and reinstalling pulseaudio and pipewire?

Hữu ích?

more options

Hữu ích?

more options

I use alsa, pulse never did work on this machine. Maybe Firefox dropped support for alsa? Anyway even the latest chrome gives me sound just fine. BTW this is under xfce4, I wonder if the desktop has anything to do with it.

Hữu ích?

more options

I would try another desktop to test.

Hữu ích?

more options

ALSA support has been dropped since Firefox 52 when the switch to PulseAudio has been made (bug 47056).

  • 1247056 - Require PulseAudio to play sound on Linux

Make sure you have the latest FFmpeg and libavcodec packages installed.

Hữu ích?

more options

"ALSA support has been dropped since Firefox 52"

But my version 91 works fine. Anyway that's a hot tip. I'll try again to get Pulse working.

Hữu ích?

more options

The latest Chromium has no problem with sound either.

Hữu ích?

more options

So I upgraded my Debian from stretch to bullseye where Firefox is version 104 stock. No change. All other browsers work fine, but Firefox is silent. I had thought perhaps the 'official' Firefox from Debian might be better than the install from Mozilla, but no change.

Hữu ích?

more options

Maybe I missed it, but did you try downloading Firefox from Mozilla? Run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Hữu ích?

more options

Yeah, my first problem was with the download from Mozilla, I was having some issues with ver. 91 so thought I'd do an upgrade beyond what Debian had on offer. I ran it direct from the directory and ... no sound. Tried safe mode, tried everything ... no sound.

Hữu ích?

more options

What does your settings look like? see screenshot

Hữu ích?

more options

Nothing like 'audio' here with xfce.

Hữu ích?

more options

XFCE...

Can you create a usb boot stick with a live OS and see if you have any sound issues. I'm not installing xfce again.

https://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-KDE-Live-x86_64-Current.iso

Hữu ích?

more options

don't like xfce? How come? I haven't used anything else for many years, but when I switched I sure preferred it to KDE or gnome.

Hữu ích?

more options

Correct if I'm wrong, but it looks like you never downloaded Firefox from Mozilla.

Hữu ích?

  1. 1
  2. 2
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.