Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

'Import from a File' button in the Passwords tab does not work

  • 2 trả lời
  • 0 gặp vấn đề này
  • 20 lượt xem
  • Trả lời mới nhất được viết bởi Fuzzy

more options

I have my saved login and password details from another browser in a CSV and would like to import them to Firefox. I initially did not have the 'Import from a File' option in the drop down menu of the Logins and Passwords tab. After following a guide that instructed to set signon.management.page.fileImport.enabled to true in the about:config page, the option appeared. However, the said option is unresponsive to any clicks. The drop down menu simply closes once the option is selected, without any other reaction.

I'm not sure if this is a related problem but I am also unable to use the Import Wizard that appears on performing Alt+F and choosing 'Import From Another Browser...' The Import Wizard window only appears with a message that says "No programs that contain bookmarks, history or password data could be found."

Firefox browser version: 103.0.2 (64-bit) OS: Ubuntu 22.04 (64-bit) Windowing System: Wayland

Funnily enough, the 'Browse..' button for adding images under this support question doesn't work either.

I have my saved login and password details from another browser in a CSV and would like to import them to Firefox. I initially did not have the 'Import from a File' option in the drop down menu of the Logins and Passwords tab. After following a guide that instructed to set ''signon.management.page.fileImport.enabled'' to ''true'' in the about:config page, the option appeared. However, the said option is unresponsive to any clicks. The drop down menu simply closes once the option is selected, without any other reaction. I'm not sure if this is a related problem but I am also unable to use the Import Wizard that appears on performing Alt+F and choosing 'Import From Another Browser...' The Import Wizard window only appears with a message that says "No programs that contain bookmarks, history or password data could be found." Firefox browser version: 103.0.2 (64-bit) OS: Ubuntu 22.04 (64-bit) Windowing System: Wayland Funnily enough, the 'Browse..' button for adding images under this support question doesn't work either.

Giải pháp được chọn

Your last line strengthens my suspicion that the problem is due to a recent configuration change in Linux builds of Firefox. I don't know which versions of Linux are affected, but some users need to make either of these two changes to make the file/directory picker appear. As a Windows user, I can't verify this myself

(A) Install xdg-desktop-portal

This would be from your package manager, I think.

(B) Turn off auto-detection of the GTK portal

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste widget.use-xdg-desktop-portal.file-picker and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change. For reference, these are the valid values:

  • 0 => Never
  • 1 => Always
  • 2 => Auto-detect

Now... there are a bunch of other preferences starting with widget.use-xdg-desktop-portal. and I have no idea what those do. If your distribution has a support site with a Firefox board or active Firefox discussions, you might search there for more tips.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (2)

more options

Giải pháp được chọn

Your last line strengthens my suspicion that the problem is due to a recent configuration change in Linux builds of Firefox. I don't know which versions of Linux are affected, but some users need to make either of these two changes to make the file/directory picker appear. As a Windows user, I can't verify this myself

(A) Install xdg-desktop-portal

This would be from your package manager, I think.

(B) Turn off auto-detection of the GTK portal

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste widget.use-xdg-desktop-portal.file-picker and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change. For reference, these are the valid values:

  • 0 => Never
  • 1 => Always
  • 2 => Auto-detect

Now... there are a bunch of other preferences starting with widget.use-xdg-desktop-portal. and I have no idea what those do. If your distribution has a support site with a Firefox board or active Firefox discussions, you might search there for more tips.

Hữu ích?

more options

Many thanks to jscher2000! Their solution worked perfectly and took only 2 minutes. My browse button works as well now so they were right on the money.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.