Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Just upgraded 100 → 103 : how to disable <Ctrl><W> now ?

  • 2 trả lời
  • 0 gặp vấn đề này
  • 26 lượt xem
  • Trả lời mới nhất được viết bởi chentaocredungtao

more options

Until FF100, I used to disable <Ctrl><W> (close tab) by modifying browser/omni.ja, commenting the following line out in chrome/browser/content/browser/browser.xhtml :

<key id="key_close" data-l10n-id="close-shortcut" command="cmd_close" modifiers="accel" reserved="true"/>

It worked until FF100, but doesn't work anymore in FF103 : commenting that line out seems to have no effect on <Ctrl><W>.

Does anybody know why ? Or does anybody know a way to disable <Ctrl><W> ?

Background : on French keyboards, the <W> key is right next to <X>, so when I try to do a cut/paste (<Ctrl><X> → <Ctrl><V>) I sometimes end up doing <Ctrl><W> by mistake, thus closing the tab. Re-opening the tab doesn't always do the trick, sometimes the latest work is lost.

Until FF100, I used to disable <Ctrl><W> (close tab) by modifying browser/omni.ja, commenting the following line out in chrome/browser/content/browser/browser.xhtml : <key id="key_close" data-l10n-id="close-shortcut" command="cmd_close" modifiers="accel" reserved="true"/> It worked until FF100, but doesn't work anymore in FF103 : commenting that line out seems to have no effect on <Ctrl><W>. Does anybody know why ? Or does anybody know a way to disable <Ctrl><W> ? Background : on French keyboards, the <W> key is right next to <X>, so when I try to do a cut/paste (<Ctrl><X> → <Ctrl><V>) I sometimes end up doing <Ctrl><W> by mistake, thus closing the tab. Re-opening the tab doesn't always do the trick, sometimes the latest work is lost.

Tất cả các câu trả lời (2)

more options

Giải pháp được chọn

Hữu ích?

more options

Many thanks, it worked !

Still, I think there should be an easier way to disable some of those shortcuts, not everyone is used to mess with js scripts. <Ctrl><W> can be quite annoying on some keyboards, I lost some text in the past, and reopening the closed tab doesn't always get everything back.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.