Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox Font Issues DIsplay

  • 7 trả lời
  • 1 gặp vấn đề này
  • 34 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

Hi Guys,

For a couple of weeks now, and since the last update (102.0.1 64-bit), my Firefox displays odd characters in some pages and in all emails.

This issue doesn't happen in safari or Chrome.

I've cleared all cookies, and browsing data multiple times and re-installed Firefox and the issue comes back every time.

See attached a couple of samples

Hi Guys, For a couple of weeks now, and since the last update (102.0.1 64-bit), my Firefox displays odd characters in some pages and in all emails. This issue doesn't happen in safari or Chrome. I've cleared all cookies, and browsing data multiple times and re-installed Firefox and the issue comes back every time. See attached a couple of samples

Giải pháp được chọn

Just solved it by UN-ticking the option to allow pages to display their own fonts

Thank you

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (7)

more options

See screen captures attached

Hữu ích?

more options

This can happen when Firefox has a problem to access locally installed fonts because of sandbox security issues.

https://wiki.mozilla.org/Security/Sandbox You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

security.sandbox.content.level = 1

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

http://kb.mozillazine.org/about:config If you also have this problem on the about:config page then try to boot the computer in Safe Mode

Được chỉnh sửa bởi Chris Ilias vào

Hữu ích?

more options

This could be a problem with one or more fonts. You can check in Font Book for font issues like corrupted and duplicate fonts.

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Hữu ích?

more options

Thank you for the help.

Unfortunately the problem still continues.

I did change the sandbox settings and restarted but the issue continues.

However it is clearly a font issue. when I inspect and change the weight of some fonts, some of the characters get fixed. Just wondering how i can get a permanent solution, as I cannot be inspecting every sigle page i browse :(

Thank you

Được chỉnh sửa bởi skyjoker vào

Hữu ích?

more options

Font issue partially solved

Hữu ích?

more options

Giải pháp được chọn

Just solved it by UN-ticking the option to allow pages to display their own fonts

Thank you

Hữu ích?

more options

Note that the label name shouldn't include a value ( = 0) like in the screenshot and this is a number pref.

  • Name: security.sandbox.content.level
    Value: 1

You can click the Trash icon to reset/remove this security.sandbox.content.level = 0 pref.

Note that if you disable "Allow pages to choose their own fonts, instead of your selections above" you disable special icon fonts downloaded from internet that websites use to display small images (you may see little boxes with the hex code).

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.