Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Can't open/download PDF attached to a yahoo email.

  • 5 trả lời
  • 1 gặp vấn đề này
  • 15 lượt xem
  • Trả lời mới nhất được viết bởi mschrock72

more options

Hi guys. I'm on a Lenovo laptop, using Windows 11. Was NOT experiencing this issue (or any other issues) till today. That is, I've been able to download PDFs attached to Yahoo email for years, including recently (till today).

Trying to get Firefox to be DEFAULT instead of MS Edge, I changed some 'Apps associated with File Types', selecting Firefox as default for all file types that seemed appropriate, BUT, this issue then began.

Feeling I went too far, and should go step at a time, I reset All File Type settings back to default (MS recommended settings). Still can't open attached PDFs. I tried an Excel attachment and it opened fine.

Error I get is: "Firefox Can’t Open This Page To protect your security, dl-mail.ymail.com will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window."

The emails I used to recreate the error, were sending an email to myself, and attaching a PDF.

Other things I tried: I used Firefox with gmail email and the PDF attachment downloaded fine. I used MS Edge with Yahoo email and PDF attachment downloaded fine. Also, btw, CAN view a PDF attachment with Yahoo email. Just now download.

I CAN "open it in a new window" as the error suggests, than print to PDF, but don't want to live the rest of my life doing that.

Thanks in advance for any help that can be offered!!

Hi guys. I'm on a Lenovo laptop, using Windows 11. Was NOT experiencing this issue (or any other issues) till today. That is, I've been able to download PDFs attached to Yahoo email for years, including recently (till today). Trying to get Firefox to be DEFAULT instead of MS Edge, I changed some 'Apps associated with File Types', selecting Firefox as default for all file types that seemed appropriate, BUT, this issue then began. Feeling I went too far, and should go step at a time, I reset All File Type settings back to default (MS recommended settings). Still can't open attached PDFs. I tried an Excel attachment and it opened fine. Error I get is: "Firefox Can’t Open This Page To protect your security, dl-mail.ymail.com will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window." The emails I used to recreate the error, were sending an email to myself, and attaching a PDF. Other things I tried: I used Firefox with gmail email and the PDF attachment downloaded fine. I used MS Edge with Yahoo email and PDF attachment downloaded fine. Also, btw, CAN view a PDF attachment with Yahoo email. Just now download. I CAN "open it in a new window" as the error suggests, than print to PDF, but don't want to live the rest of my life doing that. Thanks in advance for any help that can be offered!!

Giải pháp được chọn

You could experiment with Firefox's PDF settings and see whether any of them help with this problem (or maybe you already tried this):

View PDF files in Firefox or choose another viewer

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (5)

more options

I can't understand why one Yahoo site won't allow itself to be embedded in a different Yahoo site. It seems like a design error, but other users have reported it for a week or two now, so I guess Yahoo doesn't consider it an emergency.

Does Edge display the PDF in a frame (like Firefox), or does it save the file without a preview?

Hữu ích?

more options

Thanks for the quick reply.

Edge shows the attachment (as .pdf) in upper right of the window, allowing you to select it, and it comes up fine in Adobe PDF software. Just like it would using Firefox prior to today.

I'm thinking it's not a coincidence that this started when I attempted to stop MS from imposing it's products on me, and wanting to go to Firefox. I have to believe my issue it tied to this laptop only. BUT, I'm at a loss to know what setting I need to change to get back where I was. I'd been able to set Firefox as the default browser, and it worked for 'most things', but too often MS Edge came up instead. That's why I went fishing for where I could put a stop to that.

Hữu ích?

more options

Well, indeed, I just tried to recreate this using my friend's Chromebook, and again it works fine. I can't try it on my desktop, cause not at home.

Some combination of settings is making the attached PDFs (I've tried several to make sure it wasn't just that single PDF that was an issue). Again, the settings I changed on my laptop were in Windows 11's "File Types", where I selected Firefox for more File Types than I should have, I'm thinking. Yet, when I then Restored All File Type back to their original defaults (MS recommended defaults of course)---on this laptop, the issue didn't go away. Ugh.

Hữu ích?

more options

Giải pháp được chọn

You could experiment with Firefox's PDF settings and see whether any of them help with this problem (or maybe you already tried this):

View PDF files in Firefox or choose another viewer

Hữu ích?

more options

BINGO ! That link helped me find where Firefox sets 'how you handle downloaded files'. It was set to open in Firefox. Simply changing it to 'Save', allowed it to be downloaded as a PDF, where Adobe is the default viewer, and it opened as I wished (in Adobe)

Before changing this, I'm now thinking I fell into that pile of recent issues you mention:

You said: "I can't understand why one Yahoo site won't allow itself to be embedded in a different Yahoo site. It seems like a design error, but other users have reported it for a week or two now"

So that was me, too--while this setting was set to open attached PDFs in Firefox itself (which I never wanted all along). I'm now cut free of that one.

So, I'm good, and now can sleep soundly tonite. Thanks so much for your prompt replies !!!!!!

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.