On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Impossible to delete a website from autofill function in Firefox for Mac version 101.0.1

  • 4 trả lời
  • 1 gặp vấn đề này
  • 13 lượt xem
  • Trả lời mới nhất được viết bởi srhitchcock

more options

I have tried all of the suggested solutions here at Mozilla for how to delete a website URL from being autofilled: whenever I type 'pre', the autofill function fills in the rest of the website 'www.preply.com'. It was a horrible ESL teaching scam website, I only taught through it for a month last November then quit when they ripped me off. But now since last November, any time I type in 'pre'–I invariably see their annoying, shitty website :-( It is very annoying because it was a bad employer experience–and now I cannot ever remove them from Firefox :-(

I tried deleting it in the address bar with shift + delete, then also went into some obscure Firefox folder and deleted some file with Firefox closed (this was the supposed "solution"–it did NOT work).

Is there any way to solve this incredibly annoying issue? Or should I just switch to Chrome or Safari and give up? Very disappointed in how impossible Firefox makes deleting autofill URLS, really, REALLY BAD software programming. Any helpful or solution greatly appreciated thx :-)

I have tried all of the suggested solutions here at Mozilla for how to delete a website URL from being autofilled: whenever I type 'pre', the autofill function fills in the rest of the website 'www.preply.com'. It was a horrible ESL teaching scam website, I only taught through it for a month last November then quit when they ripped me off. But now since last November, any time I type in 'pre'–I invariably see their annoying, shitty website :-( It is very annoying because it was a bad employer experience–and now I cannot ever remove them from Firefox :-( I tried deleting it in the address bar with shift + delete, then also went into some obscure Firefox folder and deleted some file with Firefox closed (this was the supposed "solution"–it did NOT work). Is there any way to solve this incredibly annoying issue? Or should I just switch to Chrome or Safari and give up? Very disappointed in how impossible Firefox makes deleting autofill URLS, really, REALLY BAD software programming. Any helpful or solution greatly appreciated thx :-)

Giải pháp được chọn

Hi, It's possible that Firefox is fetching it from your browsing history. Here's how to remove a single site: 1. Open the History menu and choose Show All History. 2. Search for the website you want to remove by typing its name in the Search History field. 3. In the search results, control-click on the site you want to remove, and select Forget About This Site

If you still have the issue, please let us know.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (4)

more options

Giải pháp được chọn

Hi, It's possible that Firefox is fetching it from your browsing history. Here's how to remove a single site: 1. Open the History menu and choose Show All History. 2. Search for the website you want to remove by typing its name in the Search History field. 3. In the search results, control-click on the site you want to remove, and select Forget About This Site

If you still have the issue, please let us know.

Hữu ích?

more options

Thank you so much Chris! It worked!!!  :o))))))))

Best thing that happened to me all day today! :o))))))

Hữu ích?

more options

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

This could be a problem with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use the "Places Database" -> "Verify Integrity" button on the "Help -> More Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox or reboot and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder with Firefox closed. Firefox will rebuild places.sqlite and restore the bookmarks from the most recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created
  • you lose the history when a new places.sqlite is created

You may have to restore an older bookmarks backup in the bookmarkbackups folder via the Bookmarks Manager (Library).

See also:

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Hữu ích?

more options

Thanks cor-el for your suggestion, but Chris Ilias' solution solved the issue. Cheers

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.