On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Autoplay is blocked when opening link in New Tab without switching to it

  • 18 trả lời
  • 1 gặp vấn đề này
  • 29 lượt xem
  • Trả lời mới nhất được viết bởi icywiddow

more options

So, despite selecting "Allow Audio and Video" in the Site Preferences, "AUTOPLAY BLOCKED" continues to show on a tab, and it only goes away once I access the tab. This particularly happens on Youtube media.

You may find attached to this question an image of my about:config settings.

What further can be done to fix this?

So, despite selecting "Allow Audio and Video" in the Site Preferences, "AUTOPLAY BLOCKED" continues to show on a tab, and it only goes away once I access the tab. This particularly happens on Youtube media. You may find attached to this question an image of my about:config settings. What further can be done to fix this?
Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (18)

more options

What youtube link is doing this? Link so others can verify what your getting.

Hữu ích?

more options

For a specific website you can check the autoplay setting in "Tools -> Page Info -> Permissions".

Hữu ích?

more options

Dropa said

What youtube link is doing this? Link so others can verify what your getting.

It's every video on YouTube. Attached is the little notice that appears on EVERY tab under the video title.

Hữu ích?

more options

cor-el said

For a specific website you can check the autoplay setting in "Tools -> Page Info -> Permissions".

Did that. It had the settings I already enabled.

Hữu ích?

more options

What if you set media.autoplay.allow-extension-background-pages = true ?

Hữu ích?

more options

cor-el said

What if you set media.autoplay.allow-extension-background-pages = true ?

Set it. Still didn't work.

Hữu ích?

more options

icywiddow said

Dropa said

What youtube link is doing this? Link so others can verify what your getting.

It's every video on YouTube. Attached is the little notice that appears on EVERY tab under the video title.

Where is that image showing in your browser. I have YT set to not autoplay and I've never seen that. Please provide a better screenshot.

Hữu ích?

more options

Isn't it by design that even with autoplay enabled, if you open a page with media in a new tab then the media won't start autoplaying until the tab is first focussed?

This avoids the situation where if you open say a bunch of google results by ctrl+clicking items in the search results page, then any media on these pages starts playing all at once?

Or so you can open a folder of youtube videos in your bookmarks library without them all starting playing at once? Each video will only start autoplaying when you first switch to its tab?

Sorry, can't be more helpful as I don't know how to change this behaviour, just saying that I believe it is intentional and not a question of the settings not working as intended?

Someone can correct me if I am wrong here.

Được chỉnh sửa bởi TechHorse vào

Hữu ích?

more options

I just want to see where it shows "AUTOPLAY BLOCKED" for him because this is all I've ever seen. see screenshot His screenshot looks like an add-on.

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

The screenshot looks as though it's from about:config.

Hữu ích?

more options

jonzn4SUSE said

I just want to see where it shows "AUTOPLAY BLOCKED" for him because this is all I've ever seen. see screenshot His screenshot looks like an add-on.

Just using some videos on the front page of Youtube, I accessed them using "Open Link in New Tab." They don't play in the background, hence the "AUTOPLAY BLOCKED" below the tab title. Only plays once I access the tab. My autoplay permission is showed.

My only add-on is uBlock Origin.

Hữu ích?

more options

Much better screenshots!!!  ;-)) Have you tried with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#search That AUTOPLAY BLOCKED is something I've never seen before in any version of Firefox.

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

OMG!!! I guess because of the amount of tabs I have open I couldn't see it, but now I do.  ;-))

I also just noticed that when I click on the tab that message goes away.

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

Okay, sorry it took a minute, but because of the number of tabs I run I never saw that message. I am able to replicate his issue in Nightly. I set YT to allow autoplay, but still see the blocked message. When I click on the tab the video does auto play.

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

Too much coffee!!!  ;-))

Hữu ích?

more options

jonzn4SUSE said

Much better screenshots!!!  ;-)) Have you tried with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#search That AUTOPLAY BLOCKED is something I've never seen before in any version of Firefox.

Problem continued in Troubleshoot Mode.

Hữu ích?

more options

With Allow Audio & Video Set - media.block-autoplay-until-in-foreground = false

Hữu ích?

more options

RobertJ said

With Allow Audio & Video Set - media.block-autoplay-until-in-foreground = false

This worked! Problem solved.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.