On Monday September 25th from 10PM EDT - 12AM EDT (2AM UTC - 4AM UTC on September 26th), we will be performing system maintenance on the Firefox Accounts databases for two hours. During the maintenance window, there will be brief periods of a few minutes where users will not be able to login to their accounts. Please try again at a later time.

Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Cannot click on links in Firefox.

more options

Every time I click a link in Firefox it gets denied. I get notifications like You don't have permission to access this site. Works in Microsoft Edge. Have already tried emptying cookies and caches.

Every time I click a link in Firefox it gets denied. I get notifications like You don't have permission to access this site. Works in Microsoft Edge. Have already tried emptying cookies and caches.

Tất cả các câu trả lời (9)

more options

What are the sites and error screenshot compared to Edge screenshot? That might give people more to see what is happening. Also make sure no Addons are active when doing this to verify it's not a Addon issue.

more options

Okay... It is not an add on issue. I've had Firefox since the early 2000's. I really haven't added or changed anything for about 5 years now. Earlier this year, everything was working fine. One day whilst I was trying to check for an upcoming doctor's appt, I kept getting denied entrance onto the hospital site. I knew my password was correct so I kept trying to get in until I was locked out. I had to call some number and I was able to get in with help of a customer service rep. Later, I tried to pay a credit card and kept getting this notification. (Access Denied You don't have permission to access "http://consumercenter.mysynchrony.com/consumercenter/login/?" on this server. Reference #18.909b3e17.1655568108.3b221080) This kept happening. I tried to delete Firefox and then re-install it. I went to the internet. I followed the delete cookies and cache advise. I changed the proxys. None of these worked to resolve my issue. One day I again had to get into my hospital patient site and ran into the same issue as before. Wrong password. On a fluke, I tried using Microsoft Edge and was granted access immediately. I tried using it for my credit card accounts and once again, access granted. Since I have not made any modifications to Firefox since I first installed it many years ago, I can only assume this must be a result of an update made by Mozilla earlier this year. Can anyone help me since I would rather not use Microsoft Edge but it's looking like I may have to since it is seemingly more reliable.

more options

Can you post a error screenshot when using firefox minus or blackout private info so others can see what is happening. And since this is a login account that makes it harder to determine where the issue is coming from as well. And until another member that is on that same system does the same steps your doing they could verify what could be at issue as well if firefox browser is having issue accessing the site.

Được chỉnh sửa bởi Dropa vào

more options

So apparently I can't upload a screenshot. I've been trying to but this window just keeps saying uploading... with no progress being made. I'm not really sure how seeing the screenshot would've helped anyway. It is literally a white screen with the text I already detailed previously.

Access Denied You don't have permission to access "http://consumercenter.mysynchrony.com/consumercenter/login/?" on this server.

Reference #18.8a9b3e17.1655585598.45442f7e

The only thing that changes is the website or link I'm trying to access and the reference numbers.

more options

Also, I'm not too sure if you understand what is happening, from your last response. Firefox is not having trouble accessing sites. It is not accessing links within sites. If I open my email and then click on a link someone sends me, it will give me the error message. If I go to my credit card site and then try to pay the bill, it will give me the error message. If I go to my hospital site and try to check or make appointments, it will say my password is wrong. The problem is it is not allowing me to click on links anymore.

more options

Are you using a proxy or VPN?

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

more options

I must apologize... I have actually tried changing the proxies and deleting the history. Every time I post a response in these boxes I am having issues which necessitates me having to re-type answers over and over. I don't know if this is connected to my other problems with Firefox or just a problem with this messaging app. I meant to include this info in my initial post when I explained I had already tried the cookies and caches solution I found elsewhere on this website. In any case I only did it for one site. If this were a viable solution, I would've had to do it for every site I visit which seems kind of strange. I am by no means an expert in this but it seems to me this problem lies in some sort security feature I am not aware of that is not allowing any site to open a hyperlink.

more options

The link you posted opens fine for me, so this is likely a problem on your side.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

hold down the Shift key and left-click the Reload button press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) press "Command + Shift + R" (Mac) Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

Options/Preferences -> Privacy & Security Cookies and Site Data -> Manage Data "Clear the Cache":

Options/Preferences -> Privacy & Security Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes do NOT click the "Refresh Firefox" button on the Safe Mode start window https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Read this answer in context

more options

I tried your link to consumercenter and got a firewall notice.