Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

cannot fast forward or back while playing mp3 file

  • 9 trả lời
  • 1 gặp vấn đề này
  • 36 lượt xem
  • Trả lời mới nhất được viết bởi jonzn4SUSE

more options

Using Firefox 100.0.1. Debian Linux. Dell 1525 with 4G ram.

When playing a certain mp3 file in the browser, if I use the arrow keys, or the mouse, to skip forward or back, there is no response, but the audio stops playing for a period of time, then, finally it starts playing again at the spot it was before.

This does not happen with this file in Chrome, or in VLC. Also, with other mp3s it does not happen in Firefox.

I finally got it to work by converting the file to ogg vorbis, but this is not something I want to make a practice of..

I imported the file back into Audacity, and re-exported it as an mp3. Same result.

Weird... Any ideas?

Thanks,

Using Firefox 100.0.1. Debian Linux. Dell 1525 with 4G ram. When playing a certain mp3 file in the browser, if I use the arrow keys, or the mouse, to skip forward or back, there is no response, but the audio stops playing for a period of time, then, finally it starts playing again at the spot it was before. This does not happen with this file in Chrome, or in VLC. Also, with other mp3s it does not happen in Firefox. I finally got it to work by converting the file to ogg vorbis, but this is not something I want to make a practice of.. I imported the file back into Audacity, and re-exported it as an mp3. Same result. Weird... Any ideas? Thanks,

Giải pháp được chọn

Mark it resolved and enjoy. ;-)

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (9)

more options

Can you provide an example that we can test? Try downloading Firefox from Mozilla, run it from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release


Operating System: openSUSE Tumbleweed 20220525 KDE Plasma Version: 5.24.5 KDE Frameworks Version: 5.94.0 Qt Version: 5.15.2 Kernel Version: 5.17.9-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa Intel® HD Graphics 4600

Hữu ích?

more options

Thanks for the quick reply!

I downloaded firefox ( latest version - 100.0.2 ) using your link and ran it in from the unzip folder. Same result.

I can send you the mp3 is you want to try it yourself - nothing private in it.

I fixed the situation temporarily by converting the mp3 to am Ogg Vorbis format. This one fast forwards/back normally. But the mp3 format is more common and more desirable.

PLMK if you want the file...

Thanks,

Phil

Hữu ích?

more options

Send a link. I can use the arrow keys in Windows with no issues.

Hữu ích?

more options

Here's a link to the mp3 that is having the issue.

https://wetransfer.com/downloads/1a78.../c06d74?utm_campaign=WT_email_tracking&utm_content=general&utm_medium=download_button&utm_source=notify_recipient_email

file is called DickD-interview.mp3

Thanks for your help...

Phil

Hữu ích?

more options

On openSUSE, I'm having the same issue with your file with a bitrate of 117 (lower quality). When I tried one of my files with a 192 biterate, I was able to use the arrow keys with no issue.

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

I would try a higher quality file and see if it makes a difference for you. The lowest I have is 128 bitrate and it works for me.

Also, download Firefox from Mozilla to see if it has the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

If I go beyond about 9 minutes then the file plays properly when I go forward and backward. Before 9 minutes it takes a while before I hear sound if I move the position, but I see play indicator moving so only the sound is missing. Looks that Firefox isn't able to decode the MP3 file to seek to the new position.

Hữu ích?

more options

OK. I found what seems to be the solution, though not completely sure why.

The export settings on the file were "preset" ( Lame preset ), with a bitrate of 170-? kbps - this sounds like a variable br..

When I changed this to "Constant" and a bit rate of 128, the arrow keys work as expected. Probably all of our mp3 files are encoded that way, but somehow this one had the "preset" clicked.

I also tried VBR, quality level 5 - that did not work either.

Anyway, FWIW, there it is! Thanks for pointing me in the right direction.

Phil

Hữu ích?

more options

Giải pháp được chọn

Mark it resolved and enjoy. ;-)

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.