Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Thunderbird: attachments not opening (No yellow accept permission bar) since update

  • 13 trả lời
  • 1 gặp vấn đề này
  • 37 lượt xem
  • Trả lời mới nhất được viết bởi joycembrett

more options

Since latest update:

If I receive an Excel spreadsheet (either .xls or .xlsx) or a Word document (.docx) as an attachment in Thunderbird it will only open in Read Only mode. There is no way to give permission to open/view. I can save it & then open and it is fine but I cannot simply open the attachment directly without it being in Read only mode. I cannot uncheck the Properties "Read Only" check box because it is greyed out.

Similar problem applies to jpegs where you can't rotate the opened attachment (ie this opens in a kind of non-editing mode too)

The yellow security "Permission" bar that one clicked to "accept/view" is no longer appearing. (Sorry I don't know what to call this function or how to properly describe it)

Something seems to be preventing this yellow bar showing so I cannot click to "give permission to edit" or "accept the content" or whatever the appropriate permission/acceptance is

Is this a config issue ?

This problem does not occur if opening from webmail or Windows Live Mail, it applies only on Thunderbird.

Same issue on Windows 7 (yes I know it is not supported) and Windows 10. I have Thunderbird 91.9.0 (release update channel) on both (Two laptops).

I have several email accounts and the issue occurs with any email account and whether POP3 or IMAP. Also with Word/Excel/jpeg attachments to emails stored in Local Folders which used to open fine.

This problem has only arisen following latest update (91.9.0).

I have tried opening in Troubleshoot (Safe) Mode with add-ons disabled and the problem still exists.

Can anyone tell me what to do about this please ? How can I make Thunderbird allow direct opening of an attachment in normal editing mode as it used to do ? How do I get the yellow bar back please ?

What, if anything, do I change in config editor to make the yellow bar reappear ?

Would appreciate help please as this is giving me a major headache & upset

Thanks

Since latest update: If I receive an Excel spreadsheet (either .xls or .xlsx) or a Word document (.docx) as an attachment in Thunderbird it will only open in Read Only mode. There is no way to give permission to open/view. I can save it & then open and it is fine but I cannot simply open the attachment directly without it being in Read only mode. I cannot uncheck the Properties "Read Only" check box because it is greyed out. Similar problem applies to jpegs where you can't rotate the opened attachment (ie this opens in a kind of non-editing mode too) The yellow security "Permission" bar that one clicked to "accept/view" is no longer appearing. (Sorry I don't know what to call this function or how to properly describe it) Something seems to be preventing this yellow bar showing so I cannot click to "give permission to edit" or "accept the content" or whatever the appropriate permission/acceptance is Is this a config issue ? This problem does not occur if opening from webmail or Windows Live Mail, it applies only on Thunderbird. Same issue on Windows 7 (yes I know it is not supported) and Windows 10. I have Thunderbird 91.9.0 (release update channel) on both (Two laptops). I have several email accounts and the issue occurs with any email account and whether POP3 or IMAP. Also with Word/Excel/jpeg attachments to emails stored in Local Folders which used to open fine. This problem has only arisen following latest update (91.9.0). I have tried opening in Troubleshoot (Safe) Mode with add-ons disabled and the problem still exists. Can anyone tell me what to do about this please ? How can I make Thunderbird allow direct opening of an attachment in normal editing mode as it used to do ? How do I get the yellow bar back please ? What, if anything, do I change in config editor to make the yellow bar reappear ? Would appreciate help please as this is giving me a major headache & upset Thanks

Được chỉnh sửa bởi joycembrett vào

Tất cả các câu trả lời (13)

more options

Thunderbird is not opening it - it is opening in whatever program is set up for that attachment extension. Which in your case is Microsoft Office suit of programs. As it is an attachment and not a saved document, it sounds like it has opened in a sandbox type of environment - a protected view.

I did find some info: Protected View is a security feature of Word, Excel and PowerPoint which is separate from Outlook's Attachments Security (blocking) feature.

When a Word document, Excel sheet or PowerPoint slide deck is opened from an untrusted source, such as the Internet or from an email, then the document will be opened in Protected View.

This is basically a sandbox environment where no code can be executed so any included malware will be harmless and can't affect your system just by opening the attachment

So this would explain your problem, but it is not caused by Thunderbird per se, it is purely because the document has originated as an attachment to an email downloaded over internet.

Read info at link: https://windowsreport.com/disable-word-protected-view/

Hữu ích?

more options

Thank you for your response.

Yes I am clicking the attachment and then clicking on the "What should Thunderbird do with this file? Open with Microsoft Excel" (or Microsoft Word or Windows Photo Viewer or whatever program is appropriate) option and yes it has come via the internet.

I may or may not have had the yellow bar to allow remote content in the email itself.

What the operating system is now doing is putting the attachment into a pid-xxxx folder in C:\Users<Username>\AppData\Local\Temp Therefore it opens in "Read Only" mode

The only attachment this doesn't happen with is a pdf (Presumably because Thunderbird comes with its own inherent pdf viewer)

Surely this is a change to the way Thunderbird used to deal with attachments? Why is there no yellow bar/flash option to "Open & edit in ......" (or similar kind of option) ?

The pid folder in Temp does not autodelete on exit/close of viewing the Read Only so one can end up with hundreds of these folders in Temp

What is the point of "Open with ...." if it is always going to open in Read Only mode. One might just as well only have the "Save/Save As" (or Detach) option if one is going to be compelled to save the file anyway.

Why does the pid-xxxx folder not auto-delete from temp folder when the "Read Only" document or picture is closed ?

I don't have Outlook on any of my computers and I don't quite see what significance Outlook has in the issue.

Why has Thunderbird not got something similar to whatever this "Outlook's Attachments Security (blocking) feature." is and which presumably gives one the option to unblock an attachment ?

I tried unchecking the "Enable Protected View for files originating from the internet" in Microsoft Word Trust Centre (and unchecking the other two options in Trust Centre) on my Microsoft Office 2013 on Windows 10 laptop (the same options don't exist on Microsoft Office 2007 on my Windows 7 laptop) but it makes no difference.

Incidentally I can't work out how to put words into italics in my reply as you do. Can you tell me how to please (or provide a link to explanation of how to do this) ?

Thanks again

Hữu ích?

more options

re :I may or may not have had the yellow bar to allow remote content in the email itself.

Remote Content in email itself is a different question all together :) It has nothing to opening attachments.

But perhaps there used to be a yellow bar at the top of the Excel document which said 'protected view' and had a 'enable editing' button.

re :I don't have Outlook on any of my computers and I don't quite see what significance Outlook has in the issue.

There is no significance. I'm not talking about Outlook email program. It depends upon what you have purchased. Some Microsoft Office suits include Outlook. The quote that I mentioned was from a Microsoft website, so naturally they are going to talk about their own products, but the net result is the same - you are using Microsoft Excel to open .xls or .xlsx attachments and MSWord to open the docx documents.

When you open an attachment right from the e-mail message, it is opened as a temporary file in Windows temporary directory and you only have read-rights on it. This is handled this way by Windows. The Operating System first saves the document to a temporary location (In Windows, C://Users/User Name/Appdata/Local/Temp) which causes it to be marked as read-only.

I did locate this info: read-only mode. Try to disable this option to see if that helps you resolve the problem. https://www.makeuseof.com/microsoft-word-opens-files-read-only-mode-windows/ For MSWord type of docs:

  • Launch the MS Word program on your PC.
  • Click on File and select Options.
  • In the General tab, scroll down to Start up options.
  • Next, uncheck the Open e-mail attachments and other uneditable files in the reading view option.
  • Click OK to save the changes.
  • If you open an attachment file in MS Word, it should now open in default mode.


re:Incidentally I can't work out how to put words into italics in my reply as you do. Can you tell me how to please (or provide a link to explanation of how to do this) ? Highlight the line of text and click on the italic icon. It puts around the text which convert to italic format when you post the comment.

Hữu ích?

more options

Thank you for your further response

Yes I realise the "Remote Content" is a different matter. I just thought perhaps I should clarify that I might have already allowed remote content in messages from the same sender as the attachment came from in case this information was helpful.

I believe there used to be some kind of yellow bar or flash which had an "enable editing" but I thought it was in the Thunderbird attachment area not on the document itself. Wherever it was it has now disappeared.

Thank you for the explanation about Outlook. I have Microsoft Office 2007 & 2013 and neither include Outlook.

Yes as you say the net result is I am using Microsoft Excel to open .xls or .xlsx, Microsoft Word to open .doc or .docx and appropriate programs to open jpegs

The suggestion you made about 'Word Options - Startup options' doesn't apply to Office 2007 (There is no General tab in that version of Office) but in my Office 2013 the "Open e-mail attachments and other uneditable files in the reading view option" is unchecked already so unfortunately this doesn't make any difference.

It is not possible to uncheck the Properties "Read Only" check box because it is greyed out.

Not only does this issue cause me problems in incoming email attachments but I find that my own attachments to my own emails in my Thunderbird Sent folder will also only open as Read Only.

This problem does not happen with attachments sent or received using Windows Live Mail so why is it happening on Thunderbird ?

Is there anything which can be done to resolve this in future Thunderbird updates ?

I hadn't realised that when highlighting & clicking the italic button and nothing changed that I could see, it might change when I posted the message

Thank you again

Hữu ích?

more options

Further to previous post:

This problem does not happen with attachments sent or received using Windows Live Mail so why is it happening on Thunderbird ?

I have also now checked again what happens when I send direct from one webmail account to another (using a web browser - both Edge and Firefox - sending from a gmail account to an AOL account &/or vice versa). There is no problem with this either. The attachment opens normally and not in Read Only (or Protected) view.

The only situation that I can find where this issue with the attachment being put into a temp file and thus opening in Read only is when one is using Thunderbird

This issue applies not only to Microsoft Office files but jpegs & other types of files too. All of these file types incoming or outgoing as attachments, when one attempts to open rather than Save, are put into a pid-xxxx folder in C:\Users<Username>\AppData\Local\Temp and thus open in some kind of non-editable format (eg one cannot rotate jpeg photos any more than one can edit a document).

Pdfs however are NOT put into a pid-xxxx folder in the temp directory and these open normally.

Of course this whole issue affects all the mail with attachments that I have stored in Local Folders too - these attachments have now also changed to become Read Only if opened.

This has only happened recently. I did not have pid folders in temp in the past. Nor did I have this "Read Only" situation.

Can anything be done to resolve this in future Thunderbird updates please ?

Am I posting this request in the correct place to try & get this resolved please ?

Thanks

Hữu ích?

more options

re :I believe there used to be some kind of yellow bar or flash which had an "enable editing" but I thought it was in the Thunderbird attachment area not on the document itself. Wherever it was it has now disappeared.

Your problem is not caused by Thunderbird. So this is not the forum to find solutions to do with Microsoft Word etc.

The yellow banner which should appear in the MSWord app which has the 'Enable Editing' button is nothing to do with Thunderbird. I did locate this info which is worth checking out to see if something has been set to remove it. https://support.microsoft.com/en-us/topic/enable-or-disable-security-alerts-on-the-message-bar-adbf15d9-9195-4498-bdc3-5cb0dfe93852

The standard info regarding removing the Protected View is to disable all three checkboxes in the Trust Center. https://www.supportrix.com/kb/how-to-disable-protected-view-when-opening-email-attachments-or-downloaded-files-in-microsoft-office/

re:The pid folder in Temp does not autodelete on exit/close of viewing the Read Only so one can end up with hundreds of these folders in Temp

check this setting: In Thunderbird Menu app icon > Preferences > General scroll to bottom and click on 'Config Editor' in search type : helperapp look for: browser.helperApps.deleteTempFileOnExit It should be set to 'true' by default.

But MSWord always creates a temp file when opening any MSWord document. If document is saved to a specific folder and opened, a temp file is still auto created, but because it is already saved to a folder then the temp file will also be in folder until document is saved and closed. As email attachment is not saved anywhere then Windows OS will open in Protected view in the sandboxed Appdata/Local/Temp folder.

Hữu ích?

more options

It is simply untrue that my "problem is not caused by Thunderbird".

It IS caused by something within Thunderbird

It is not an issue with Microsoft Office.

This is indicated by .......

1 It applies to non-MSOffice files such as jpgs, jpegs, pngs, bmps, gifs, wpds, etc., etc.

2 It does NOT apply OUTSIDE Thunderbird. I can send to/from Windows Live Mail and to/from the webmail clients directly (using either Firefox or Edge to test the process) and the attachments open normally & directly in editable mode.

I did not have this issue prior to applying recent Thunderbird Updates on my laptops.

The issue applies purely when sending or receiving using Thunderbird and attempting to utilise the "What should Thunderbird do with this file? Open with ....." function

It applies to both my laptops with totally separate Thunderbird installations & profiles but both with the same updates installed.

It applies to all my saved emails in Local Folders (and it certainly didn't before I applied these last updates)

I cannot enable editing on these opened attachments as per method you indicated (https://www.supportrix.com/kb/how-to-disable-protected-view-when-opening-email-attachments-or-downloaded-files-in-microsoft-office/) because when I open them by using the THUNDERBIRD "What should Thunderbird do with this file? Open with ....." there is no Protected View option nor is there any possibility of unchecking the Properties-Read Only box because it is greyed out. This ONLY applies when I'm opening from THUNDERBIRD. It does NOT apply when I use any other email application. In other email applications when I open the attachment the file opens normally (editable) or I get the "Enable Editing" flash where appropriate.

I checked the information in https://support.microsoft.com/en-us/topic/enable-or-disable-security-alerts-on-the-message-bar-adbf15d9-9195-4498-bdc3-5cb0dfe93852 as you suggested and my settings are as they should be. This is naturally going to be the case because, as I have already said, it is only opening the document from Thunderbird using Thunderbird's "Open with ... " function where the issue lies. If opened from any other email application everything happens normally (and I get a security alert if appropriate).

Similarly when I open a jpeg attachment by using the THUNDERBIRD "What should Thunderbird do with this file? Open with ....." I cannot rotate it (for example) whereas if I open the attachment from Windows Live Mail or webmail applications I can rotate it. So again Thunderbird's "Open with" function has opened the attachment in some kind of mode which is not as it used to be, nor as it is with other email applications.

Also, prior to these latest updates Thunderbird did not create these pid-xxxx folders in the C:\Users<Username>\AppData\Local\Temp folder and leave them there forever. It simply opened a normal temp file.

This is all a new phenomenon in Thunderbird and ONLY applies to how my THUNDERBIRD is dealing with attachments and not how other email applications handle the attachments.

It applies to all types of files in an attachment (except pdfs) when using Thunderbird's "What should Thunderbird do with this file? Open with ....."

I checked the setting you specify and browser.helperApps.deleteTempFileOnExit is set to 'true'

In case it has any significance I will just mention (because this is outside my understanding completely) that the other two similar settings browser.helperApps.neverAsk.openFile and browser.helperApps.neverAsk.savetoDisk have nothing at all showing next to them (ie they neither say true nor false)

Further, in case it helps, I attach scans of the latest Thunderbird Error Console from each of my two laptops in case this enlightens the picture on what is causing this issue.

Could it perhaps be something to do with the item shown next to the red warning and starting "Exception ..... Component returned failure code ......" ?

If it isn't that it must be something else within the configuration of my Thunderbird

Yes I know that MSWord always creates a temp file when opening any MSWord document (and with Excel & so on) but this issue I am describing is an entirely different scenario.

The file (or actually in this case a Folder) which Thunderbird is creating when I try to open any attachment using "Open with ...." - regardless whether it is an Office document, a jpeg, or any other kind of attachment other than pdf - is a pid-xxxx No other application creates these pid folders and they do not auto-delete on exit (or following Save)

If I use the option/function "What should Thunderbird do with this file? Save As ....." instead of "What should Thunderbird do with this file? Open with ....." then I don't get this pid-xxxx folder. This function behaves as it should and how both "Open with" and "Save as" USED to do.

There has to be some kind of configuration or registry or settings error somewhere in either Thunderbird itself or my installed Thunderbirds which is causing this problem. As I say, it only applies to Thunderbird.

Thanks again

Được chỉnh sửa bởi joycembrett vào

Hữu ích?

more options

Please can you tell me why I'm getting my images attached to the wrong messages. The images I uploaded to this question 1376172 appeared in question 1375983. So I removed from 1375983 and they were removed from 1376172 to which they actually belong. So I added them back in to 1376172. Now they are in both questions.

How do I get the images to attach to the correct message and only that message.

How do I delete images only from the message they shouldn't be in ?

The images of Thunderbird error consoles should be here in 1376172 and not in 1375983

Được chỉnh sửa bởi joycembrett vào

Hữu ích?

more options

I posted a long reply to Toad Hall's post of 0450 today. Then it lost its images. Then I did a new post with just the images. Then I tried to edit my long reply (to which the images belonged) by adding the images back in to the actual message. Then the long reply disappeared and had to be approved by a Moderator.

To Toad Hall: Please don't lose patience with me. I am an elderly woman and am not technically proficient. I'm trying my best to explain things in a comprehensive & intelligible manner.

I appreciate the help you are giving. I am grateful to you & to all the volunteers & moderators working on here who are trying to assist me.

Thanks

Được chỉnh sửa bởi joycembrett vào

Hữu ích?

more options

The biggest problem with this situation overall is that opening attachments to view them creates a pid-xxxx FOLDER. These pid-xxxx FOLDERS do not now ever autodelete from C:\Users<Username>\AppData\Local\Temp folder at any time, so one ends up with a proliferation of these unwanted temp folders within the temp directory.

I have thousands of stored emails in Local Folders Storage Folders and many of these have attachments which I have to view for comparison purposes.

I can deal with not being able to "enable editing" on anything (except for pdfs using "Preview with Thunderbird") - although I would very much PREFER to be able to do so and cannot understand why it is no longer possible since the introduction of Thunderbird 91. Why was it necessary to make the change? Why is there no "Preview with Thunderbird" option for files other than pdfs - COULD THIS BE INTRODUCED ?

What I fail to understand is why the temporary pid folders do not EVER autodelete either when closing/saving the read-only attachment or when closing Thunderbird or as a result of any other action. The only way of removing them is manually deleting from C:\Users<Username>\AppData\Local\Temp

Many users who don't have "View hidden files & folders" activated wouldn't even be aware these folders were proliferating on their C drive.

Surely this retaining the pid folders in AppData temp isn't what is intended to happen. It certainly didn't used to.

Hữu ích?

more options

Thanks for further info, so I've also checked out my 'Temp' folder. I agree there seems to be the creation of 'pid-xxxxx' folders which contain actual copies of the opened attachment files. The oldest date of my 'pid-xxxxx' folders seems to correspond with appearing after the update of 91.6.2

These 'pid-xxxxx' folders look like they are saving actual copies of opened files, which is undesirable. The xxxxx number also corresponds with thunderbird.exe when I check the Taskbar Manager.

I'm not certain whether they have a correlation with the 'read-only' mode not offering an 'edit' option as you used previously, but it is worth trying to find out what has occurred.

I have discovered that if I access the 'pid-xxxxx' folder and open one of the *.jpg files the 'rotation' option is greyed - close image - right click on image icon/file and choose 'properties' allows me to uncheck the 'read-only' anc click on 'Apply'. I can then open that image and the eg@ 'rotation' option is now available. However, why should anyone need to locate hidden Temp folders just to locate the attachment they want to open. Sounds crazy to me especially when you have not selected to save any file at that point.

I'm creating a bug report to see if we can get some feedback/information from the developers. https://bugzilla.mozilla.org/show_bug.cgi?id=1769423

Hữu ích?

more options

Thank you

What you describe is happening to you is the same as is happening to me (and other folk I've checked with).

The pid-xxxx folders do indeed contain copies of the opened attachment files (in "read only" or equivalent format such as having 'rotation' option greyed out).

Each pid folder will contain as many full copies of documents/photos as have been opened from attachments during the current Thunderbird session (and can contain multiples of the same file if the attachment has been opened several times). A new pid folder will be created when a new session of Thunderbird is started and a new 'Open ...' is instigated.

As you say, if one accesses the pid-xxxx folder and opens any of its contents, the option to change from 'read only' or its equivalent can be unchecked. Thus one can edit/rotate and save.

However this doesn't help if I simply want to 'view' the attachment to check which version of a document/photo etc the attachment is (particularly in my Local Folders - Storage Folders where I have several thousand emails, mainly with attachments which I have to keep referring back to for comparisons)

Pid folders are not created when using either 'Save As ....' or (for a PDF) 'Preview in Thunderbird'

I can confirm that for me the introduction of a recent update seems to have had a direct correlation with the 'read-only' mode not offering an 'edit' option (although I cannot be certain that it wasn't an update slightly earlier or later than the number you quote because the Thunderbird on one of my laptops is a recent totally new installation & the one on the other laptop is not in frequent use, so I don't know when exactly it changed it's 'edit' option, only that it is recent).

My Thunderbird version is 91.9.0. In case it helps, one thing I tried recently was uninstalling Thunderbird and re-installing 91.8.0 but it made no difference so I conclude the update which affected 'read only' and started this pid folder creation is likely to be around the date/update you suggest

Thank you so much for creating your most helpful and comprehensive bug report which I trust will enable resolution of these issues in due course. Your help is much appreciated.

Hữu ích?

more options

To Toad Hall:

Further to this issue: I have now downloaded Thunderbird 91.5.1 onto a friend's computer (and set to 'Check for updates but let me choose whether to install them')

I have tested opening attachments (using 'Open with ....')

This does not create pid-xxxx folders

So far from what I have tested this opens all documents & spreadsheets in editable mode without the "Enable editing" flash.

In the case of opening any .xls or .doc attachment a standard .tmp file is created in C:\Users<Username>\AppData\Local\Temp folder as one would expect and this autodeletes on closure (or save) of the document. This is as one would hope and expect of course.

However in the case of .xlsx or .docx then what is created within C:\Users<Username>\AppData\Local\Temp folder is a complete copy of the actual document itself (with the suffix .docx or .xlsx and not with the suffix .tmp) and this does not autodelete on exit/closure. This is similar to the files which appear in the pid folders created by version 91.6.2 & later - except these are NOT read-only but subsequently editable as those within pid folders are - these are straightforward filename.docx or filename.xlsx in editable mode, exact copies of the document/spreadsheet itself.

So I feel that part of the problem might be more involved and might go a bit further back than Thunderbird 91.6.0 or 91.6.2

Having established that full copies of .xlsx and .docx were being placed in the C:\Users<Username>\AppData\Local\Temp folder and not being deleted on exit/closure, I did a "Disk Clean-Up" to test what happens from this.

Disk Clean-Up does not have any effect (ie it does not delete) on either pid- folders or their contents as created on Thunderbird 91.6.2, nor on the full copies of .docx or .xlsx as created on Thunderbird 91.5.1

So the outcome is that in either case (depending whether one is using version 91.6.2 onwards or 91.5.1) the pid folders OR the full copies of .docx or .xlsx remain forever in the C:\Users<Username>\AppData\Local\Temp folder unless manually deleted.

I hope I have explained this clearly and you can add this information to your bug report in the hope that the developers will be able to trace this further.

I am very grateful for your help on this.

What I hope will be the end result is that the developers create an update which enables the following outcomes for Thunderbird users: i) one will be able to open an attachment and it will create a standard .tmp file in C:\Users<Username>\AppData\Local\Temp which autodeletes on closure/exit ii) the "enable editing" flash will resume and thus one will once again be able to edit and then save the document locally on 'My Documents' folder on C drive

I believe that others are not flagging any of this up as an issue because: i) they don't have hidden files & folders displayed so they don't see this accumulation of undeleted files or folders ii) they don't regularly have to open loads of Word or Excel documents (or almost anything else except pdfs) from email attachments for comparison purposes as I have to.

Until this issue is sorted out, I would be grateful if someone could tell me which version of Thunderbird I need to go back to for the moment in order to be able to: a) open an attachment and create a standard .tmp file which autodeletes on closure/exit b) get back the "enable editing" flash and thus be able to edit and then save the document locally on 'My Documents' folder on C drive

My thanks to anyone taking note and action on this problem

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.