Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

My Javascript seems to have failed... FF 99.0.2 Win 7

more options

Javascript appears not to be working in my FF -- V 98.0.2 (32-bit). Running on Win-7 (last updates before support ended!!) In particular, the comments for Washington Post articles will not display [first detected problem]. After research, no Javascript will output. FF shows enabled, and it remains enabled. It just doesn't seem to work. The Chrome browser on the same Dell laptop works correctly and displays comments. But I prefer FF to Chrome. The fact that Chrome works suggests to me that the issue is with FF. I'm suspecting that version 98 isn't compatible with Win-7...

The problem was not occurring a year ago. Covid restricted my travel and thus use of the laptop. When I refreshed the laptop with the latest antivirus [Norton] and FF, it no longer worked., I don't remember what version of FF I was using back when it worked.. I know Windows hasn't changed, and I ran without Norton or plugins and the problem persisted...

Any suggestions? Any way to restore an old -- over 1 year -- version of FF so I can try that?

PS:: I'm running FF 99.0.1 (64-bit) on a Dell desktop right next to me and the W-7 laptop at the moment. I works fine. No issue with jS or any other FF function.

Javascript appears not to be working in my FF -- V 98.0.2 (32-bit). Running on Win-7 (last updates before support ended!!) In particular, the comments for Washington Post articles will not display [first detected problem]. After research, no Javascript will output. FF shows enabled, and it remains enabled. It just doesn't seem to work. The Chrome browser on the same Dell laptop works correctly and displays comments. But I prefer FF to Chrome. The fact that Chrome works suggests to me that the issue is with FF. I'm suspecting that version 98 isn't compatible with Win-7... The problem was not occurring a year ago. Covid restricted my travel and thus use of the laptop. When I refreshed the laptop with the latest antivirus [Norton] and FF, it no longer worked., I don't remember what version of FF I was using back when it worked.. I know Windows hasn't changed, and I ran without Norton or plugins and the problem persisted... Any suggestions? Any way to restore an old -- over 1 year -- version of FF so I can try that? PS:: I'm running FF 99.0.1 (64-bit) on a Dell desktop right next to me and the W-7 laptop at the moment. I works fine. No issue with jS or any other FF function.

Tất cả các câu trả lời (1)

more options

Some commenting providers might be blocked by privacy and anti-tracking features. If you haven't already, could you try "the usual":

Double-check content blockers: Firefox's Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) The shield icon toward the left end of the address bar usually turns a bit purplish when content is blocked. Click the icon to learn more or make an exception. See: Enhanced Tracking Protection in Firefox for desktop.

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix usually provide a toolbar button to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you sometimes need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe/Troubleshoot Mode: In this mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?