Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

eBay, Aliexpress don't load parts of the page (broken profile?)

  • 5 trả lời
  • 1 gặp vấn đề này
  • 3 lượt xem
  • Trả lời mới nhất được viết bởi gestos

more options

Hi there,

Firefox is my daily browser and a few websites are causing recurrent issues. Aliexpress randomly switches language and currency, but the most annoying problem is that it doesn't let me change it (clicking on it doesn't give the menu it's supposed to give), and searching any item in the search bar just gives the "spinning star symbol", and nothing else.

Similar issue in eBay: some menus just don't open, including submenus in the "Contact seller" form, which cripples the whole experience.

As a comparison: all these websites work fine in a slightly outdated Safari 14.1.2. and the most recent Vivaldi.

Now, I saw the issue being mentioned here 4 years ago.

What I tried:

  1. cookie /cache cleaning, which I did to no avail.
  2. Safe mode: no change
  3. Switched back privacy settings to "Standard": no change.
  4. Manually copied files from one profile folder to another: as could be expected, no change.
  5. I even tried a full refresh, but with extensive customization already performed over the years and most of it either in about:config or extensions, I couldn't spend the time re-setting everything back to normal.

FWIW a list of all files and folders shown in my profile folder. I specifically excluded the "known good" files (see step 4). Interestingly, FF also generated an "Invalidprefs.js" file.

Hi there, Firefox is my daily browser and a few websites are causing recurrent issues. Aliexpress randomly switches language and currency, but the most annoying problem is that it doesn't let me change it (clicking on it doesn't give the menu it's supposed to give), and searching any item in the search bar just gives the "spinning star symbol", and nothing else. Similar issue in eBay: some menus just don't open, including submenus in the "Contact seller" form, which cripples the whole experience. As a comparison: all these websites work fine in a slightly outdated Safari 14.1.2. and the most recent Vivaldi. Now, I saw the issue being mentioned here 4 years ago. What I tried: # cookie /cache cleaning, which I did to no avail. # Safe mode: no change # Switched back privacy settings to "Standard": no change. # Manually copied files from one profile folder to another: as could be expected, no change. # I even tried a full refresh, but with extensive customization already performed over the years and most of it either in '''about:config''' or extensions, I couldn't spend the time re-setting everything back to normal. FWIW [https://pjjoint.malekal.com/files.php?read=20220418_c11k158p6o12 a list of all files and folders shown in my profile folder]. I specifically excluded the "known good" files (see step 4). Interestingly, FF also generated an "Invalidprefs.js" file.

Tất cả các câu trả lời (5)

more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Hữu ích?

more options

Already tried. See 1 to 3.

As for the tracking protection: I tested in a private window: both websites work properly. I then disabled those extensions that didn't have permission to run in a private window just to check if any was causing the trouble: nope. then I disabled tracking protection altogether in the regular browsing mode: broken websites are still broken.

Hữu ích?

more options

Delete browsing, search and download history on Firefox {web link}

Remove a single website from your history {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings And Passwords.

Hữu ích?

more options

Did it work in a new clean profile without making modifications and without installing extensions ?


If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Hữu ích?

more options

Next round of tests:

  1. Just tried to make FF "Forget about this site" from the history view. No change, both websites are still broken.
  2. Other profiles fully synced to this one don't display the bug, either on this computer or on other.
  3. Creating a new profile doesn't display the bug.

Didn't test by deleting the cookies.sqlite as I found it was, along with cert9.db, favicons.sqlite, formhistory.sqlite, handlers.json, key4.db, permissions.sqlite, places.sqlite, search.json.mozlz4: all of these files are known-good, i.e. manually transferred these files to the newly created profile folder, didn't trigger the bug.

Oh, and just noticed that OneDrive displays the same bug: in a regular window, only the top bar, search field and badge are displayed, the rest of the page is blank. In a private window, I get the full interface.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.