Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

My chosen Firefox theme changed my default Windows mode color from light to dark.

  • 12 trả lời
  • 1 gặp vấn đề này
  • 153 lượt xem
  • Trả lời mới nhất được viết bởi CJ

more options

After choosing a particular theme, Firefox took over my default windows mode color from light to dark (Personalize/Colors/Choose Your Default Windows Mode--light or dark). If I manually switch back to Light then I cannot check the box for colors to be changed for start, task bar and action center since this box is faded out and non-responsive. I greatly dislike the new black background. I do not want my theme choices to affect my default settings. Any way to override this invasive feature?

After choosing a particular theme, Firefox took over my default windows mode color from light to dark (Personalize/Colors/Choose Your Default Windows Mode--light or dark). If I manually switch back to Light then I cannot check the box for colors to be changed for start, task bar and action center since this box is faded out and non-responsive. I greatly dislike the new black background. I do not want my theme choices to affect my default settings. Any way to override this invasive feature?

Giải pháp được chọn

You can select a theme that has dark text on the tabs (toolbars) if you currently use a theme with light text to prevent Firefox from using a dark background for webpages.

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior regarding to prefer dark or light background for webpages.

  • layout.css.prefers-color-scheme.content-override [dark:0, light:1, system:2, browser:3]

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (12)

more options

Giải pháp được chọn

You can select a theme that has dark text on the tabs (toolbars) if you currently use a theme with light text to prevent Firefox from using a dark background for webpages.

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior regarding to prefer dark or light background for webpages.

  • layout.css.prefers-color-scheme.content-override [dark:0, light:1, system:2, browser:3]

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Hữu ích?

more options

I am currently not in"3"...it is Boolean which is checked. Should I change this to Number? If so, will it then allow me to write in 2? Thank you for you assistance.

Hữu ích?

more options

I neglected to mention...my options are Boolean, Numbers and String. There doesn't appear to be a 1,2,or 3 option

Hữu ích?

more options

layout.css.prefers-color-scheme.content-override is a Number pref and would be '3' by default.

You only get the Boolean and Number and String choices if the pref doesn't exist and you are offered to create a new pref, so make sure you have the correct pref name.

Hữu ích?

more options

I apologize; this was an error on my part. The link you provided was accurate. I made the change (from 3 to 2) but I don't see what has changed. With my chosen theme, I am in the "dark" Windows default mode. But, in this mode with this theme, the "Start, taskbar, action center" box cannot be checked--it is faded out and non-responsive. While with other themes, this box can be checked and my taskbar color can be manipulated. Nothing, as far as I can see, has changed by making the value 2.

Hữu ích?

more options

To be more clear, my Firefox homepage is black; it is always white. This happened only with my chosen personalized Firefox theme (Happy St Patricks Day Clovers).

Hữu ích?

more options

Did you try to set the pref to '1' (light) ?

Hữu ích?

more options

I appreciate your continued assistance since I am determined to find a fix to my unwanted black background.. I don't know why my chosen theme has taken over my windows default settings; this is most definitely an undesirable feature. When I went back to the preference, I noticed that the 2 I had set prior did not take as it was still showing a value of 3. It turns out that I needed to have hit the blue icon for it to set. The 2 setting did the job. Now I have set it to 1 and will be leaving there since that is my preference regardless of what theme I will choose. As you can tell, I am by no means a techie, but I was able to achieve my desired outcome with your help. Thank you.

Hữu ích?

more options

I was able to change my Firefox homepage to light. Where is the preference in about:config to also change my drop downs from my toolbar to light?

Hữu ích?

more options

For webpages you can use layout.css.prefers-color-scheme.content-override, for the menus the only way is to switch the theme to a theme with dark text.

Hữu ích?

more options

Is there a way to know if a theme I am about to choose if it will be dark text without having to install it and looking? I experimented with several themes and I did notice how my drop down boxes changed back and forth from light to dark with the chosen themes. But, I did not see any consistency prior to selection as to whether or not the text was going to be dark or not.

Hữu ích?

more options

Also, I checked the layout preference...it is marked as 1. What does this value stand for? And how can I find this out myself?

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.