Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Disable UTF-8 input/percent encoding when using a search shortcut

  • 5 trả lời
  • 1 gặp vấn đề này
  • 5 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I've added a search shortcut for Wayback Machine where %s is the URL I need to search: https://web.archive.org/web/*/%s

But Firefox automatically encodes my URL; for example, when I copy-paste https://www.mozilla.org/en-US/ to search its archives with the shortcut, it is automatically encoded with UTF-8: https://web.archive.org/web/*/https%3A%2F%2Fwww.mozilla.org%2Fen-US%2F whereas I want it to lead me to https://web.archive.org/web/*/https://www.mozilla.org/en-US/.

I've googled around and haven't found a solution to this, and setting "browser.urlbar.decodeURLsOnCopy" to "true" only decodes it correctly when copied. The extension I've used to add the WM search shortcut gives me an option to encode input differently than default UTF-8, but I don't know how would I use it to disable encoding altogether. See attached pictures.

I've [https://addons.mozilla.org/en-US/firefox/addon/add-custom-search-engine/ added a search shortcut] for Wayback Machine where %s is the URL I need to search: https://web.archive.org/web/*/%s But Firefox automatically encodes my URL; for example, when I copy-paste https://www.mozilla.org/en-US/ to search its archives with the shortcut, it is automatically encoded with UTF-8: https://web.archive.org/web/*/https%3A%2F%2Fwww.mozilla.org%2Fen-US%2F whereas I want it to lead me to https://web.archive.org/web/*/https://www.mozilla.org/en-US/. I've googled around and haven't found a solution to this, and setting "browser.urlbar.decodeURLsOnCopy" to "true" only decodes it correctly when copied. The extension I've used to add the WM search shortcut gives me an option to encode input differently than default UTF-8, but I don't know how would I use it to disable encoding altogether. See attached pictures.
Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (5)

more options

Hello,

I understand that this does not solve all cases, but in your case, you can solve this issue by forgoing the custom search engine extension altogether.

The search extension for the wayback machine can be found here https://mycroftproject.com/install.html?id=80446&basename=waybackmachine&icontype=ico&name=Internet+Archive%3A+Wayback+Machine

The search extension for archive.org can be found here https://mycroftproject.com/install.html?id=45959&basename=archiveorg-all&icontype=ico&name=Internet+Archive

more options

Well, Wayback Machine add-on from the official site does the job, but I want to know how it encodes the input. I'm looking to solve minor issues like this without needing an extension for each, otherwise I'll end up with a bloated Firefox on my already low-end computer.

more options

I understand what you mean, but I believe that opensearch extensions (like the ones at the links I sent) do not use extra cpu, and sit dormant, and can be removed by simply removing the search engine.

more options

Just as a footnote, that is called URL Encoding or Percent encoding, and it is a built-in feature for keyword bookmarks and search engines. Ref. https://developer.mozilla.org/docs/Glossary/percent-encoding

more options

You can try to use the uppercase "%S" instead of "%s"