Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Add-ons not installing anymore

  • 5 trả lời
  • 1 gặp vấn đề này
  • 44 lượt xem
  • Trả lời mới nhất được viết bởi FredMcD

more options

Out of the blue my add-ons are disabled (see picture of my about:addons screen) and cannot be reinstalled. Every time I try to install an add-on I get: "Installation aborted because the add-on appears to be corrupt."

Setting xpinstall.signatures.required and xpinstall.whitelist.required to false in about:config did not resolve this issue as well.

Out of the blue my add-ons are disabled (see picture of my about:addons screen) and cannot be reinstalled. Every time I try to install an add-on I get: "Installation aborted because the add-on appears to be corrupt." Setting xpinstall.signatures.required and xpinstall.whitelist.required to false in about:config did not resolve this issue as well.

Giải pháp được chọn

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (5)

more options

That is odd.

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address box and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files"

+++++++++++++++++++++++++++ You may have to approve the updating once again.

Hữu ích?

more options

That felt like it could have been the issue but it didn't solve the problem.

I only had a subdirectory called "extensions" and an extensions.json to delete along with compatibility.ini.

Attached is a screen shot of what I'm seeing. Re-attempting to install an add-on re-adds extensions.json but not the "extensions" directory.

Được chỉnh sửa bởi alimar vào

Hữu ích?

more options

Giải pháp được chọn

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Hữu ích?

more options

Uninstalling firefox and removing the entire .firefox directory under $HOME and then reinstalling firefox through the repository from my Linux distribution fixed the issue for me.

I guess we won't know exactly what happened with such a scorched earth approach that resulted in my browsing history being deleted, but the issue is resolved.

Được chỉnh sửa bởi alimar vào

Hữu ích?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.