Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

blocked JavaScript

  • 14 trả lời
  • 1 gặp vấn đề này
  • 88 lượt xem
  • Trả lời mới nhất được viết bởi csengh

more options

hy! I'm using XP-x86, so the latest version is Firefox 52.0esr A few days ago, I can't use Google search normally, because the search result is displayed as if JavaScript is blocked. Also, I can't change my search settings, the arrow isn't active. I started FF in safe mode, but no change. Any help is appreciated.

hy! I'm using XP-x86, so the latest version is Firefox 52.0esr A few days ago, I can't use Google search normally, because the search result is displayed as if JavaScript is blocked. Also, I can't change my search settings, the arrow isn't active. I started FF in safe mode, but no change. Any help is appreciated.
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

I don't believe it's resolved!! Thank you very much. I knew that Microsoft is foolish but I don't know why Google doesn't want to give the full results page experience to Windows XP users any more. So bad!

Thank your work!

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (14)

more options

Pls read /questions/1365101.

Hữu ích?

more options

Giải pháp được chọn

I don't believe it's resolved!! Thank you very much. I knew that Microsoft is foolish but I don't know why Google doesn't want to give the full results page experience to Windows XP users any more. So bad!

Thank your work!

Hữu ích?

more options

Note that replacing 52.0 in the useragent by 55.0 is sufficient to make this work.

  • Mozilla/5.0 (Windows NT 5.1; rv:55.0) Gecko/20100101 Firefox/55.0

Hữu ích?

more options

Now Google search work fine, but unfortunately some site doesn't work corectly with replacing 52.0 in the useragent by 55.0 e.g. I can't login in my Mozilla account or https://www.emag/ don't work anymore.

Please Help!

Được chỉnh sửa bởi csengh vào

Hữu ích?

more options

1. Does it work with default values? I'm not sure if it's connected with that change. 2. Try to go back to defaults and set the domain specific UA override, i.e. general.useragent.override.google.com

Được chỉnh sửa bởi TyDraniu vào

Hữu ích?

more options

if I go back to default UA all sites work fine but unfortunately the domain specific UA override (general.useragent.override.google.com) doesn't work so Google search doesn't show the full results page experience :(

Hữu ích?

more options

This site specific user agent override works for me with google.com in Firefox 52 (site specific override got removed in Firefox 71). If you use another Google locale then you need to adjust the domain.

Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

as I say I use Firefox 52.0esr, I added: general.useragent.override.google.com = Mozilla/5.0 (Windows NT 5.1; rv:55.0) Gecko/20100101 Firefox/55.0 I use google.com as in attached file, but google search result doesn't show the full results.

Hữu ích?

more options

Works for me in 52 ESR. Screenshots with the override enabled and with the override disabled (general.useragent.site_specific_overrides = false).

Are you possibly using extensions that could interfere ?

Hữu ích?

more options

I started FF in safe mode to avoid addon problems.

  • first → without full search result
  • second → without full search result
  • third → search with full result, but some sites don't work correctly

I understand Mozilla/5.0 (Windows NT 5.1; rv:55.0) Gecko/20100101 Firefox/55.0 but please tell me what it means (rv:|Firefox/)\d{2}#$155 or where I get some documentation for that.

Hữu ích?

more options

(rv:|Firefox/)\d{2}#$155 is a so called regular expression that only changes the first two digits (\d{2}) after 'rv:' and after 'Firefox/' in the user agent leaving the rest the same. The '#' in the expression indicates that this is a regular expression and the '$155' is the replacement where '$1' is for the (rv:|Firefox/) part (parameter #1) and '55' for the new value. So this changes your user agent to Firefox 55 without affecting other parts (i.e. it is still Windows XP..

  • Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0 =>
    Mozilla/5.0 (Windows NT 5.1; rv:55.0) Gecko/20100101 Firefox/55.0

Hữu ích?

more options

Thanks to the detailed explanation of the regular expression, now everything is clear, but unfortunately doesn't work for me, only the explicit replacement is efficient. The big problem is why doesn't work site specific override and how to fix it!

Hữu ích?

more options

I've deleted my previous answer and try to reword the last sentence better.

I think that site specific overrides only works when the main general.useragent.override pref isn't set. I've never checked this, so a site specific override might not work with general.useragent.override set. The regular expression only works for a site specific override (general.useragent.override.google.com), so if you use it for general.useragent.override then you get a user agent with the regexp value and not the processed useragent.

You need to reset general.useragent.override (click the trashcan) and set general.useragent.override.google.com to (rv:|Firefox/)\d{2}#$155 to make this work.

Hữu ích?

more options

cor-el said

a site specific override might not work with general.useragent.override set. The regular expression only works for a site specific override (general.useragent.override.google.com), so if you use it for general.useragent.override then you get a user agent with the regexp value and not the processed useragent.

Now everything is clear, thank's your help!

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.