Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Streaming Video Won't PLay

  • 7 trả lời
  • 1 gặp vấn đề này
  • 25 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

Every since updating to the latest FF, I get messages from every major streaming video service that there is some type of error. Amazon Prime says to update to the latest version of FF, Pluto just says that it can't load the player, and generates a P-DEV302 error code. Since Chrome and MS Edge work fine, it's across multiple streaming service and it only happened after a FF update, it would seem that something in FF broke/changed. Any ideas?

Tất cả các câu trả lời (7)

more options

I don't think you need to update Firefox, but some users are having issues with older versions of the Widevine plugin used to decrypt DRM-protected content.

You can try disabling DRM, waiting a minute for Firefox to unload the old plugin, then re-enabling DRM and see whether that helps on the next visit to Netflix.

Watch DRM content on Firefox

If problems continue, could you tell us your Widevine plugin version? You can check that on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Plugins. On the right side, click "Widevine Content Decryption Module provided by Google Inc."

Does yours show as version 4.10.2391.0 ?

Hữu ích?

more options

Obviously that was a copy/paste from a Netflix thread -- I meant Amazon Prime. ;-)

Hữu ích?

more options

I updated the Widevine Plugin on my Windows computer and it helped with Prime and Hulu but not all streaming services. They required that I disable my adblocker, which was never the case before. On my Linux box, there is no Widevine plugin and I can't seem to find one, so I'm stuck with several streaming services refusing to playback video. Since this happened after the 96.0.1 update, I wonder if there is something more fundamental happening, but I can't find anything in the release notes that would indicate that. It also seems implausible that all streaming services would change their DRM, all at once, in such as way that it would only effect Firefox and not Chrome and Edge. At the moment, my Windows machine is mostly working. My guess is that I will see an additional update from Mozilla soon that fixes the problem.

Hữu ích?

more options

tompetrocelli said

I updated the Widevine Plugin on my Windows computer and it helped with Prime and Hulu but not all streaming services. They required that I disable my adblocker, which was never the case before.

While that is annoying, I'm not sure it's due to a change in Firefox. ??

On my Linux box, there is no Widevine plugin and I can't seem to find one, so I'm stuck with several streaming services refusing to playback video.

Do you normally install Firefox from Mozilla's site or from your package manager? Your package manager might have both a regular version and a no-DRM version due to freedom principles, etc.

Since this happened after the 96.0.1 update, I wonder if there is something more fundamental happening, but I can't find anything in the release notes that would indicate that. It also seems implausible that all streaming services would change their DRM, all at once, in such as way that it would only effect Firefox and not Chrome and Edge.

It's possible the older version of Widevine reached an "end of life" status with streaming sites. Or maybe they disabled it for undisclosed security reasons?

For licensing reasons, Firefox doesn't build in Widevine, it needs to be separately downloaded. It seems that some Firefox installations have been slower to update Widevine than others. I have no idea why.

Hữu ích?

more options

Is that a 32 bit Linux box as Widevine is only supported on 64 bit Linux ?

Hữu ích?

more options

64. It's FF 96.0.1 on Ubuntu 21.10.

Hữu ích?

more options

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.