Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox is suddenly using Windows dark mode instead of app light mode. Help!

more options

The look in my browser has suddenly changed. Everything is in dark mode instead of light mode even though I didn't change my Windows settings. Please help.

Giải pháp được chọn

It's the text color in your theme: https://addons.mozilla.org/firefox/addon/beach-grass-acean/

With Firefox 96, when the text color on your background tabs is light/white, it triggers Firefox to use a dark background on menus, the sidebar, the Library window, and various built-in pages. Firefox also signals sites that you have a dark theme preference.

(I realize that many users consider their toolbar theme purely decorative and don't want Firefox to use it to drive colors in other parts of the browser. We are hoping that eventually there's a checkbox for this on the Settings page, but that probably is some time away.)

What to do about this now

(1) For people willing to change their toolbar theme

The fastest workaround for now is to change your theme to one that uses dark text. By dark text I mean, for example, the built-in Light theme, or an add-on theme with black or dark text on the tabs. That doesn't need to be blinding, it can have some color. As examples:

(2) For people who can't part with their toolbar theme

I know of either

(A) A temporary override that gets reset every time you open a new window, or (B) a partial workaround for the built-in pages, and for websites that have light/dark responsive themes (but not menus, sidebar, toolbar drop-downs, etc.)

For either of those, you would go through the back door:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

Temporary Override

(2) In the search box in the page, type or paste browser.theme.toolbar-theme and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 1 for a light theme, then press Enter or click the blue check mark button to save the change.

Partial Workaround

(4) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(5) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.

What about other aspects of the UI?

For the sidebar, menus, and toolbar drop-down panels, there is an unofficial, community-supported option, which is to override the built-in styles using your own style rules in a userChrome.css file. I think people are still pondering how to do that efficiently, and perhaps you aren't that into hacking your browser anyway.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (4)

more options

To change the theme to light mode: 1. Type in about:addons in the address bar 2. Click "Themes" in the left sidebar 3. Choose Enable under "Light" (or a different theme if you prefer)

Được chỉnh sửa bởi Zian vào

Hữu ích?

more options

I don’t think this is the answer. I’m using the beach grass acean theme and would like to continue using it. For some reason though it is now in dark mode. I checked the theme and it has not been changed.

Hữu ích?

more options

I’m guessing it’s the result of the Firefox update. My Windows setting is for apps to be in light mode (Settings - Colours - Choose your default app mode). Perhaps the new Firefox version is not referring to this setting correctly?

Hữu ích?

more options

Giải pháp được chọn

It's the text color in your theme: https://addons.mozilla.org/firefox/addon/beach-grass-acean/

With Firefox 96, when the text color on your background tabs is light/white, it triggers Firefox to use a dark background on menus, the sidebar, the Library window, and various built-in pages. Firefox also signals sites that you have a dark theme preference.

(I realize that many users consider their toolbar theme purely decorative and don't want Firefox to use it to drive colors in other parts of the browser. We are hoping that eventually there's a checkbox for this on the Settings page, but that probably is some time away.)

What to do about this now

(1) For people willing to change their toolbar theme

The fastest workaround for now is to change your theme to one that uses dark text. By dark text I mean, for example, the built-in Light theme, or an add-on theme with black or dark text on the tabs. That doesn't need to be blinding, it can have some color. As examples:

(2) For people who can't part with their toolbar theme

I know of either

(A) A temporary override that gets reset every time you open a new window, or (B) a partial workaround for the built-in pages, and for websites that have light/dark responsive themes (but not menus, sidebar, toolbar drop-downs, etc.)

For either of those, you would go through the back door:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

Temporary Override

(2) In the search box in the page, type or paste browser.theme.toolbar-theme and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 1 for a light theme, then press Enter or click the blue check mark button to save the change.

Partial Workaround

(4) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(5) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.

What about other aspects of the UI?

For the sidebar, menus, and toolbar drop-down panels, there is an unofficial, community-supported option, which is to override the built-in styles using your own style rules in a userChrome.css file. I think people are still pondering how to do that efficiently, and perhaps you aren't that into hacking your browser anyway.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.